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This software interfaces with LibTiff version 3.6.1.1 

 

Copyright (c) 1988-1997 Sam Leffler 

Copyright (c) 1991-1997 Silicon Graphics, Inc. 

 

Permission to use, copy, modify, distribute, and sell this software and  

its documentation for any purpose is hereby granted without fee, provided that (i) the 

above copyright notices and this permission notice appear in all copies of the software and 

related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be 

used in any advertising or publicity relating to the software without the specific, prior 

written permission of Sam Leffler and Silicon Graphics. 

 

THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,  

EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY  

WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.   

 

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY 

SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, 

OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR 

PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND 

ON ANY THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE 

USE OR PERFORMANCE  

OF THIS SOFTWARE. 



SlideBook 4.2 User Manual 

 iii iii 

End-User License Agreement for 3i Software 

 
IMPORTANT - READ CAREFULLY: This 3I End-User License Agreement (―EULA‖) is a 

legal agreement between you (either an individual or a single entity) and Intelligent 

Imaging Innovations, Inc. (―3I‖) for the 3I software product identified in the software 

section of the system registration sheet, which includes computer software and a hardware 

component (i.e., the ―hardware key‖) and may include associated media, printed materials, 

and ―online‖ or electronic documentation (―SOFTWARE PRODUCT‖).  The SOFTWARE 

PRODUCT also includes any updates and supplements to the original SOFTWARE 

PRODUCT provided to you by 3I.  Any software provided along with the SOFTWARE 

PRODUCT that is associated with a separate end-user license agreement is licensed to you 

under the terms of that license agreement.  By installing, copying, downloading, accessing 

or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this 

EULA.  
 

If you do not agree to the terms of this EULA, do not install or use the SOFTWARE 

PRODUCT; you may, however, return it to your place of purchase for a full refund. 
 

SOFTWARE PRODUCT LICENSE 

The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property 
laws and treaties.  The SOFTWARE PRODUCT is licensed, not sold. 
1. GRANT OF LICENSE.  This EULA grants you the following rights: 
 Applications Software.  You may install, use, access, display, run, or otherwise interact with (“RUN”) one copy of the 

SOFTWARE PRODUCT, or any prior version for the same operating system, on a single computer, workstation, terminal or other 
digital electronic device (“COMPUTER”).   
 Storage/Network Use.  You may also store or install a copy of the SOFTWARE PRODUCT on a storage device, such as a 

network server, used only to store the SOFTWARE PRODUCT.  A license for the SOFTWARE PRODUCT may not be shared or used 
concurrently on different COMPUTERS. 
 
 Reservation of Rights. The SOFTWARE PRODUCT is licensed to You on a non-exclusive basis. All rights not expressly granted 

are reserved by 3I. 
2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS. 
 Not for Resale Software.  If the SOFTWARE PRODUCT is labeled “Not For Resale” or “NFR,” then, notwithstanding other 

sections of this EULA, your use of the SOFTWARE PRODUCT is limited to use for demonstration, test, or evaluation purposes and 
you may not resell, or otherwise transfer for value, the SOFTWARE PRODUCT. 
 Limitations on Reverse Engineering, Decompilation, and Disassembly.  You may not reverse engineer, decompile, 

modify or disassemble the SOFTWARE PRODUCT, except and only to the extent that such activity is expressly permitted by 
applicable law notwithstanding this limitation. 
 Separation of Components.  The SOFTWARE PRODUCT is licensed as a single product.  Its component parts may not be 

separated for use on more than one COMPUTER. 
 Trademarks.  This EULA does not grant you any rights in connection with any trademarks or service marks of 3I. 
 Rental.  You may not rent, lease, or lend the SOFTWARE PRODUCT. 
 Support Services.  3I may provide you with support services related to the SOFTWARE PRODUCT (“Support Services”).  Use of 

Support Services is governed by the 3I policies and programs described in the user manual, in “online” documentation, and/or in 
other 3I-provided materials.  Any supplemental software code provided to you as part of the Support Services shall be considered 
part of the SOFTWARE PRODUCT and subject to the terms and conditions of this EULA.  With respect to technical information you 
provide to 3I as part of the Support Services, 3I may use such information for its business purposes, including for product support 
and development.  3I will not utilize such technical information in a form that personally identifies you. 
 Software Transfer.  The initial licensee of the SOFTWARE PRODUCT may make a one-time permanent transfer of this EULA and 

SOFTWARE PRODUCT only directly to an end user.  This transfer must include all of the SOFTWARE PRODUCT (including all 
component parts, the media and printed materials, any upgrades, this EULA).  Such transfer may not be by way of consignment or 
any other indirect transfer.  The transferee of such one-time transfer must agree to comply with the terms of this EULA, including 
the obligation not to further transfer this EULA and SOFTWARE PRODUCT. 
 Termination.  Without prejudice to any other rights, 3I may terminate this EULA if you fail to comply with the terms and 

conditions of this EULA.  In such event, you must destroy all copies of the SOFTWARE PRODUCT and all of its component parts. 
3. UPGRADES.  If the SOFTWARE PRODUCT is labeled as an upgrade, you must be properly licensed to use a product identified by 
3I as being eligible for the upgrade in order to use the SOFTWARE PRODUCT.  A SOFTWARE PRODUCT labeled as an upgrade 
replaces and/or supplements (and may disable) the product that formed the basis for your eligibility for the upgrade.  You may use 
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the resulting upgraded product only in accordance with the terms of this EULA.  If the SOFTWARE PRODUCT is an upgrade of a 
component of a package of software programs that you licensed as a single product, the SOFTWARE PRODUCT may be used and 
transferred only as part of that single product package and may not be separated for use on more than one COMPUTER. 
4. PROPRIETARY RIGHTS.  All proprietary rights in and to the SOFTWARE PRODUCT (including but not limited to patent, 
copyright, trade secret, trademark, or other proprietary rights, any images, photographs, animations, video, audio, music, and text 
incorporated into the SOFTWARE PRODUCT), the accompanying printed materials, and any copies of the SOFTWARE PRODUCT are 
owned by 3I or its suppliers.  All title and intellectual property rights in and to the content which may be accessed through use of 
the SOFTWARE PRODUCT is the property of the respective content owner and may be protected by applicable copyright or other 
intellectual property laws and treaties.  This EULA grants you no rights to use such content.  If this SOFTWARE PRODUCT contains 
documentation which is provided only in electronic form, you may print one copy of such electronic documentation.  You may not 
copy the printed materials accompanying the SOFTWARE PRODUCT. 
5. CONFIDENTIAL INFORMATION.   You agree that the SOFTWARE PRODUCT contains proprietary information, including 
trade secrets, know-how and confidential information, that is the exclusive property of 3I.  During the period this Agreement is in 
effect and at all times after its termination, you and any of your employees, agents, partners, associates, etc. shall maintain the 
confidentiality of this information and not sell, license, publish, display, distribute, disclose or otherwise make available this 
information to any third party nor use such proprietary information concerning the SOFTWARE PRODUCT, including flow charts, 
logic diagrams, user manuals and screens, to any person(s) not an employee without the prior written consent of 3I.  In addition, 
You hereby agree to protect 3I’s proprietary information and take appropriate action against employees, independent contractors or 
others who violate any of 3I’s proprietary rights. 
6. DUAL-MEDIA SOFTWARE.  You may receive the SOFTWARE PRODUCT in more than one medium.  Regardless of the type or 
size of medium you receive, you may use only one medium that is appropriate for your single COMPUTER.  You may not RUN the 
other medium on another COMPUTER.  You may not loan, rent, lease, or otherwise transfer the other medium to another user, 
except as part of the permanent transfer (as provided above) of the SOFTWARE PRODUCT. 
7. BACKUP COPY.   After installation of one copy of the SOFTWARE PRODUCT pursuant to this EULA, you may keep the original 
media on which the SOFTWARE PRODUCT was provided by 3I solely for backup or archival purposes.  If the original media is 
required to use the SOFTWARE PRODUCT on the COMPUTER, you may make one copy of the SOFTWARE PRODUCT solely for 
backup or archival purposes.  Except as expressly provided in this EULA, you may not otherwise make copies of the SOFTWARE 
PRODUCT or the printed material  accompanying the SOFTWARE PRODUCT. 
8. U.S. GOVERNMENT RESTRICTED RIGHTS.  All SOFTWARE PRODUCT provided to the U.S. Government pursuant to 
solicitations issued on or after December 1, 1995 is provided with the commercial rights and restrictions described elsewhere herein.  
All SOFTWARE PRODUCT provided to the U.S. Government pursuant to solicitations issued prior to December 1, 1995 is provided 
with RESTRICTED RIGHTS as provided for in FAR, 48 CFR 52.227-14 (JUNE 1987) or FAR, 48 CFR 252.227-7013 (OCT 1988), as 
applicable. 
9. EXPORT RESTRICTIONS.  This SOFTWARE PRODUCT has been classified by the US Government as exportable under License 
Exception TSU.  Therefore the following terms apply:  You agree that you will not export or re-export the SOFTWARE PRODUCT, 
any part thereof, or any process or service that is the direct product of the SOFTWARE PRODUCT (the foregoing collectively 
referred to as the “Restricted Components”), to any country, person or entity subject to U.S. export restrictions.  You specifically 
agree not to export or re-export any of the Restricted Components (i) to any country to which the U.S. has embargoed or restricted 
the export of goods or services, which currently include, but are not necessarily limited to Cuba, Iran, Iraq, Libya, North Korea, 
Sudan and Syria, or to any national of any such country, wherever located, who intends to transmit or transport the Restricted 
Components back to such country; (ii) to any person or entity who you know or have reason to know will utilize the Restricted 
Components in the design, development or production of nuclear, chemical or biological weapons; or (iii) to any person or entity 
who has been prohibited from participating in U.S. export transactions by any federal agency of the U.S. government.  You warrant 
and represent that neither the BXA nor any other U.S. federal agency has suspended, revoked or denied your export privileges. 
10. INDEMNIFICATION.  You hereby agree to indemnify 3I and hold 3I harmless from and against, and shall defend against, any 
and all claims and damages of every kind, including but not limited to fines, penalties, compensatory damages, consequential 
damages, punitive damages, attorneys fees, or any other damages or fees arising out of or attributed directly or indirectly to your 
negligent, reckless or intentional conduct, operations or performance of the SOFTWARE PRODUCT. 
 

MISCELLANEOUS 

If you acquired this SOFTWARE PRODUCT in the United States, this EULA is governed by the laws of the State of California. 
If you acquired this SOFTWARE PRODUCT in Canada, unless expressly prohibited by local law, this EULA is governed by the laws in 
force in the Province of Ontario, Canada; and, in respect of any dispute which may arise hereunder, you consent to the jurisdiction 
of the federal and provincial courts sitting in Toronto, Ontario.  If this SOFTWARE PRODUCT was acquired outside the United 
States, then local law may apply. 
Should you have any questions concerning this EULA, or if you desire to contact 3I for any reason, please contact 3I at: 
 
Intelligent Imaging Innovations, Inc. 

5124  Washington Street    (303) 607-9429 

Denver, CO  80216    (303) 607-9430 Facsimile 

http://www.intelligent-imaging.com 
 

AUTHORITY TO BIND COMPANY/INSTITUTION: The individual signing this 

Agreement hereby warrants, represents and covenant that they have the right, power 

and capacity and are and will be duly authorized and empowered to enter into, execute, 

http://www.intelligent-imaging.com/
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deliver and perform this Agreement on behalf of the company, organization, institution 

or other legal entity and that the execution, delivery and/or performance by of this 

Agreement shall not, and will not, by the lapse of time, the giving of notice or otherwise, 

constitute a violation of any applicable law or a breach of any provision contained in the  

Articles of Incorporation, By-Laws, Articles of Partnership or similar document, or 

contained in any agreement, instrument or document to which You are now or hereafter 

a party or by which you may become bound. 
 
SEVERABILITY: If any provision of this Agreement is held to be invalid or unenforceable, in whole or in part, such holding will not 
affect the validity of the other provisions of this Agreement, unless the unenforceable provision is essential to this Agreement. 
 
FAIR MEANING:  The language in all parts of this Agreement shall in all cases be construed according to its fair meaning and not 
strictly for or against either party.  It is agreed that if any provision of this Agreement is capable of two constructions, one of which 
would render the provision void and the other of which would render the provision valid, then the provision shall have the meaning 
which renders it valid. 

LIMITED WARRANTY 

LIMITED WARRANTY FOR SOFTWARE PRODUCTS ACQUIRED OUTSIDE THE US AND CANADA.  YOU HEREBY AGREE 
THAT THE UNIFORM COMMERCIAL CODE (“UCC”) OF CALIFORNIA AND THIS AGREEMENT SHALL CONTROL ALL WARRANTIES 
UNDER THIS LICENSE AGREEMENT AND EXPRESSLY WAIVE ANY RIGHTS YOU MAY HAVE UNDER INTERNATIONAL LAW OR 
TREATY INCLUDING BUT NOT LIMITED TO THE INTERNATIONAL CONVENTION ON THE SALE OF GOODS. 
 
LIMITED WARRANTY FOR SOFTWARE PRODUCTS ACQUIRED IN THE US AND CANADA.  3I warrants that (a) the 
SOFTWARE PRODUCT will perform substantially in accordance with the accompanying written materials for a period of ninety (90) 
days from the date of receipt, and (b) any Support Services provided by 3I shall be substantially as described in applicable written 
materials provided to you by 3I, and 3I support engineers will make commercially reasonable efforts to solve any problem issues.  
Some states and jurisdictions do not allow limitations on duration of an implied warranty, so the above limitation may not apply to 
you.  To the extent allowed by applicable law, implied warranties on the SOFTWARE PRODUCT, if any, are limited to ninety (90) 
days. 
CUSTOMER REMEDIES.  3I's and its suppliers' entire liability and your exclusive remedy shall be, at 3I's option, either (a) return 
of the price paid, if any, or (b) repair or replacement of the SOFTWARE PRODUCT that does not meet 3I's Limited Warranty and 
which is returned to 3I with a copy of your receipt.  This Limited Warranty is void if failure of the SOFTWARE PRODUCT has resulted 
from accident, abuse, or misapplication.  Any replacement SOFTWARE PRODUCT will be warranted for the remainder of the original 
warranty period or thirty (30) days, whichever is longer.  Outside the United States, neither these remedies nor any product support 
services offered by 3I are available without proof of purchase from an authorized international source. 
NO OTHER WARRANTIES.  To the maximum extent permitted by applicable law, 3I and its suppliers disclaim all 
other warranties and conditions, either express or implied, including, but not limited to, implied warranties of 
merchantability, fitness for a particular purpose, title, and non-infringement, with regard to the SOFTWARE 
PRODUCT, and the provision of or failure to provide Support Services.  This limited warranty gives you specific legal rights.  
You may have others, which vary from state/jurisdiction to state/jurisdiction. 
LIMITATION OF LIABILITY.  To the maximum extent permitted by applicable law, in no event shall 3I or its 
suppliers be liable for any special, incidental, indirect, exemplary or consequential damages whatsoever (including, 
without limitation, damages for loss of business profits, business interruption, loss of business information, or any 
other pecuniary loss) arising out of the use of or inability to use the SOFTWARE PRODUCT or the provision of or 
failure to provide Support Services, even if 3I has been advised of the possibility of such damages.  In any case, 
3I's entire liability under any provision of this EULA shall be limited to the greater of the amount actually paid by 
you for the SOFTWARE PRODUCT or U.S.$5.00; provided, however, if you have entered into a 3I Support Services 
Agreement, 3I's entire liability regarding Support Services shall be governed by the terms of that agreement.  
Because some states and jurisdictions do not allow the exclusion or limitation of liability, the above limitation may not apply to you. 
 
CONTRACTUAL STATUTE OF LIMITATIONS AND NOTICE.  To the maximum extent permitted by applicable law, no 
action or claim relating to this Agreement may be instituted more than one (1) year after the event giving rise to 
such action or claim.  In addition, you must notify 3I at least thirty (30) days prior to the instituting of any lawsuit 
under this Agreement, with a full description of your claim and what you are seeking in damages. 
 

DISPUTE RESOLUTION 
 
Any controversy or claim arising out of or relating to this Agreement or the breach thereof, with the exception of injunctive relief 
sought by 3I for any violation of the proprietary terms of this Agreement, shall be settled by arbitration in accordance with the rules 
of the American Arbitration Association. Before entering into arbitration, You and 3I shall each appoint an arbitrator, and these two 
arbitrators shall select a third arbitrator to be a member of the panel.  Should the two arbitrators not be able to agree on a choice 
of the third, then the American Arbitration Association shall make the appointment of a person who is neutral to the parties in 
controversy.  None of the arbitrators shall be officers or employees of the parties to this Agreement.  Such arbitrators shall be 
recognized experts in the computer software field.  The cost of arbitration, including fees per arbitrator, shall be borne equally by 
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the parties.  The arbitration shall be held in the City of Los Angeles, in the County of  Los Angeles, in the State of California in the 
United States of America.   
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Contacting Intelligent Imaging Innovations, Inc 

If you have any questions or experience any problems with SlideBook™, please contact us 

by either phone or email.  Our phone number is (303) 607-9429 and our email address is 

support@intelligent-imaging.com.  Our web site at www.intelligent-imaging.com also 

contains additional information about SlideBook™, frequently asked questions, and useful 

microscopy and hardware information. 

 

SlideBook™ comes with one year of free technical support.  We will answer questions as 

promptly as possible and in the event of any program errors we will make every effort 

correct the problem as soon as possible. 

 

 

 

 

mailto:support@intelligent-imaging.com
http://www.intelligent-imaging.com/
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Manual Conventions 

1.1 Typographic Conventions 

Menu commands are written in bold and follow the order of menu navigation.  For 

instance, choosing ―Open‖ from the ―File‖ menu is written as File > Open. 

 

Dialog fields and other interface items are written in bold, as in Initial Offset. 

 

References to other sections of the manual are underlined, as in Image Capture. 

 

New terms are italicized. 

 

NOTES will be written in bold and small capitals.  Notes that you should pay particular 

attention to are prefaced CAUTION. 

 

1.2 Of Pixels and Voxels 

In other contexts, image typically connotes a two-dimensional entity.  However, 

SlideBook™ was specifically designed to operate on three-dimensional data as easily and 

intuitively as two-dimensional data.  In light of this, a two-dimensional data set can be 

seen as a special case of a three-dimensional set where data has been collected for only one 

value of the z-axis.  An image corresponds to all data collected during a particular capture. 

 

To simplify this manual, we always refer to a single data element as a voxel and a region as 

a volume, regardless of the depth of the image.   These terms map directly to pixel and 

area, respectively, for a two-dimensional set. 
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Using this Manual 

 

The SlideBook ™ Manual describes all of the steps necessary for performing digital 

microscopy, from installing the software to analyzing images. The chapters are outlined 

below. If you are new to SlideBook™, you may wish to start by taking a step-by-step Quick 

Tour as outlined in Chapter 2. This will familiarize you with basic elements and commands 

in SlideBook™.  

1.3 Chapter 1 - Installing SlideBook™  

If your system was installed by 3i or a 3i reseller, then you will not need to install software 

on your system. However, if it was not installed by 3i or a 3i distributor, or you need to 

upgrade your software, you can learn how to do this in Chapter 1. 

1.4 Chapter 2 – Quick Tour 

This chapter will take you on a step-by-step guided tour of the basic elements of 

SlideBook™. This is the perfect starting point for the beginning user. 

1.5 Chapter 3 – SlideBook™ Organization 

This chapter describes how hardware control, image capture, data storage, and data 

analysis are organized into SlideBook™ menus, windows, and objects. 

1.6 Chapter 4 - Configuring Your System  

If your system was installed by 3i or a 3i reseller, then you will not need to configure your 

system prior to use. However, if it was not installed by 3i or a 3i reseller, or you need to 

make changes to your system configuration, you may do so by selecting Edit>Define 

Optics… or Edit>Hardware Configuration…  Chapter 4 teaches you how to configure 

hardware and define optics. 

1.7 Chapter 5 - Controlling the Camera and Microscope 

Next, you will learn how to set your microscope to the proper optics and bring your sample 

into view and focus.  Any motorized aspect of the microscope can be controlled through 

SlideBook‘s Focus Window. You may bring up this window by selecting Window>Focus 

Window or clicking on the focus window button in the toolbar . 

1.8 Chapter 6 - Image Capture and Import 

Parameters for image capture will be set in the Capture Window. Here you will set camera 

parameters, such as exposure and binning, by performing test exposures. You may bring up 

this window by selecting Image>Capture New Image... or by clicking on the capture 

button in the tool bar . You may also import images that were captured using other 

programs by selecting Image>Import. 

1.9 Chapter 7 – Advanced Capture 

In this chapter, you will learn to perform more advanced capture sequences, such as 

timelapse, 3D, 4D, and Montage capture.  
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1.10 Chapter 8 - Image Display and Manipulation  

Once you have captured an image set, it may be displayed in various modes using the View 

menu. Interactive data views allow you to display any combination of different channels 

and masks (ROIs) as well as change lookup table parameters. You may also perform 

operations such as volume rendering. Note that operations from this menu do not alter the 

underlying intensity data contained in an image. 

1.11 Chapter 9 - Preparing an Image for Analysis or Export 

Before performing analysis on an image, you may want to perform additional operations on 

an image. For example, you may wish to eliminate any constant artifacts from the image by 

performing Flat Field Correction. It may also be useful to deblur an image by performing 

deconvolution. Other operations that may be necessary or useful prior to analysis are 

cropping, aligning channels, or applying filters. Operations such as these are found under 

the Image menu.  

1.12 Chapter 10 - Image Analysis  

Mathematical analysis can be performed on regions of the image that you select. You may 

select these regions by creating a binary overlay called a mask. Masks are generated from 

the Mask menu. Once you have made a mask, you may obtain information such as average 

intensity and number of pixels in the region of interest by selecting Mask>Statistics...  
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1 Installing SlideBook™ 

1.13 Computer System Requirements  

Your computer must meet the following system requirements in order to run SlideBook™.  

 

1.13.1 Operating System 
 

Windows XP Professional SP2 (Recommended) 

Windows 2000 Professional SP3 

 

1.13.2 Hardware 

1.13.2.1 Processors 

Windows: Intel Pentium Family Processor 

 

1.13.2.2 Memory Requirements 

RAM: minimum 512GB, recommended 3 GB 

Hard drive: minimum 200MB required for installation 

 

1.13.2.3 Graphics Card  

(for Interactive Volume Rendering only) 

 

VRAM: minimum 128 MB, recommended 256 MB 

Minimum models: NVidia GeForce FX or ATI Radeon 9800  

Recommended models: NVidia GeForce 6800 or ATI Radeon x800  

 

Please contact support@intelligent-imaging.com with questions regarding hardware 

compatibility. 

 

1.14 Connecting the Hardware Key 

SlideBook ™ comes with a hardware key, or dongle, that permits the application to run on 

the machine that has the key attached.  The key is a Sentinel series purple USB device 

manufactured by Rainbow Technologies. If you are doing a new installation of the software, 

make sure the key is not attached to the computer. Instead, connect the key after 

installation. 

 

NOTE:  Given the hardware key system, it is possible to install the SlideBook™ software on 

several different machines.  However, the software will only run on the machine that has 

the key attached. Networked computers may run SlideBook ™ if one of the computers on 

the network has a network key. 

 

1.15 About SlideBook™ Installers 

SlideBook installers are available as ―compact‖ or ―complete‖.  

mailto:support@intelligent-imaging.com
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 Compact – installs SlideBook program files, Sentinel dongle drivers, and User‘s 

Manual, and provides link to QuickTime program files via the internet. 

 

 Complete – installs all SlideBook program files, User‘s Manual, QuickTime 

program files, and Sentinel dongle drivers. Also allows the option to copy camera 

driver files, Edgeport driver files, and QuickTour sample files to the 

Intelligent Imaging Innovations, Inc. directory. 

1.16 Copying the Software from CD-ROM 

 

1. Insert the SlideBook™ CD in your CD_ROM drive. 

 

2. Navigate to the CD-ROM and copy the SlideBook™ setup program, 

InstallSlideBook.exe to your desktop. 

 

3. Double-click on the icon to begin installation and proceed to the section 

―Installing SlideBook 4.2‖ (below). 

 

1.17 Copying the Software from your Download Site 

Every SlideBook™ user may access a private download site in order to obtain current 

installers and updaters. You may contact us at support@intelligent-imaging.com to obtain 

your user name and password. You will need to know who originally purchased your 

SlideBook™ software. To access your download site: 

 

1. Go to www.intelligent-imaging.com 

 

2. Go to Downloads, and then Customer Login, and click on link ―Click Here to 

Login‖. 

 

3. Enter your username/password (case-sensitive). 

 

4. Click on the desired link to download the software. When prompted, select Save 

and then navigate to the desired destination for the file. 

 

5. Click OK to save the file. 

 

1.18 Installing SlideBook 4.2 

The SlideBook installer allows you to install the program, drivers, adjunct programs, the 

manual, and tutorials. If you are installing SlideBook for the first time, continue with this 

section. If you already have SlideBook installed on your machine, please see Installing 

Updates. 

 

1. Double-click on the InstallSlideBook icon to start the setup utility. The following 

dialog box will be displayed. 

mailto:support@intelligent-imaging.com
http://www.intelligent-imaging.com/
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2. Click Next and the following dialog box will appear. 

 

 
 

3. If the default destination directory is acceptable, select Next. If you would like to 

install to a different directory, click Browse and navigate to the desired location 

and then select Next to continue installation. The following dialog box will 

appear.(complete installer also has Sample Files and Camera Drivers options). 

Now you may choose the options that you wish to install.  
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For instance, you may select to install QuickTime and Sentinel Rainbow key 

drivers only by selecting Adjunct programs. As you click on each option, a 

description will appear. 

 

4. Select Next and you will be prompted to accept the terms of the License 

Agreement. 

 

 
 

5. Select Yes and the setup utility will display the following message: 
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6. Click Next and the setup utility will install the selected items, add SlideBook to 

the Programs menu (off the Start menu), and create shortcuts. The following 

message will confirm installation: 

 

 
 

 

7. Click Close to complete the Setup. If you have chosen to install key drivers, you 

will be taken to the InstallShield Wizard for Sentinel System Driver. 

 

                  ______________________________________________________ 
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8. Continue to click Next until the following dialog box appears. 

 

 

 

 
 

9. Click Finish to complete the installation. You may now launch SlideBook™ from 

either the Start Menu>Programs or from the Shortcut to SlideBook.exe. 

 

NOTE: When you start SlideBook™ for the first time, it will notice that a preferences file, 

which is stored along with the application, does not exist.  SlideBook™ will create a default 

preferences file.  As you configure your hardware and define optics (discussed in Chapter 4, 

Configuring Your System), SlideBook ™ will update this preferences file with specific 

information about your setup.  
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An electronic copy of this manual, called SlideBook4.2User’sManual.pdf, is in Adobe 

Acrobat 6.0 format, and can be opened by an Acrobat 6.0 reader.  Feel free to distribute the 

manual to all users of SlideBook™. 

 

1.19 Installing Updates 

You may download software updates at www.intelligent-imaging.com as described above in 

―Copying Software from your Download Site‖.  Before installing an update, be sure to back 

up your SlideBookprefs.dat, HardwareProperties.dat, PSFs.dat, and 

FlatFields.dat files. These are located in the Program Files\Intelligent Imaging 

Innovations, Inc\SlideBook folder or in the same folder as your SlideBook.exe file.  

After downloading is complete, double-click on the file that you have just downloaded and 

follow the installation directions. Install the update in Program Files\Intelligent 

Imaging Innovations, Inc\SlideBook. If SlideBook™ is not located in the above 

path, install the update in the folder that contains SlideBook™ on your computer. 

 

1.20 About Memory on Your System 

Windows 2000 and XP support virtual memory, which allows hard disk space to be used to 

extend the effective amount of RAM available to programs.  When SlideBook™ starts up, it 

will first try to allocate a portion of physical memory (actual RAM and not disk space) for 

SlideBook‘s use, so that time-critical operations do not rely on virtual memory.  If many 

other applications are already running, or there is not much physical memory on the 

system itself, then SlideBook™ will report: 

 
SlideBook cannot reserve enough physical memory in order to operate.  

Try closing other applications and then restarting. 

 

and quit.  If you get this message, close other applications and restart SlideBook™.   

 

Although SlideBook™ will perform well when it relies almost entirely on virtual memory, 

there are a few things you can do to make sure the performance is optimal.  If your system 

has several hard disk drives attached, load and save SlideBook™ files to a different disk 

than the one that is used to support virtual memory. If you only have a single hard disk 

drive, but one that is divided into several partitions, use a different partition in which to 

load and save SlideBook™ files than the partition that is used to support virtual memory.  

You can find out which disk is used to support virtual memory by doing the following: 

 

1. From the Start button, choose Settings… > Control Panel.   

 

2. Select the System control panel item and choose the Performance or Advanced 

tab (which should be the rightmost tab).   

 

3. Press the Virtual Memory button and see what drive is named in the Hard 

Drive field. 

 

4. Select the drive or partition that is not being used to load or save SlideBook ™ 

files. 

http://www.intelligent-imaging.com/
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The goal for either single or multiple hard drive systems is to prevent SlideBook™ files and 

virtual memory from competing for the same disk space.  Two and especially three 

dimensional images take up a lot of space in both memory and on disk, so taking this step 

ensures that SlideBook ™ operates as smoothly and efficiently as possible. 



SlideBook 4.2 User Manual 

 2-1 2-1 

2 Quick Tour 

 

This Quick Tour will introduce you to some basic elements of SlideBook. By the end of this 

tour, you will know how to: 

 

 Open Slides and Images 

 Display a Main View, Three View, and Tile View  

 Use Basic Tools in the Info/Tool Bar to Maneuver within a View 

 Perform Volume Rendering 

 Create a Mask and Obtain Statistics 

 

NOTE: Menu operations, such as choosing ―Open Slide‖ from the ―File‖ menu are written as 

File > Open Slide. 

 

In order to run the Quick Tour, first make sure that the SlideBook program and Quick 

Tour slides have been installed. If not, please go to Chapter 1, Installing SlideBook™ and 

follow the procedures for installing the software and the Quick Tour slides. 

 

2.1 Opening Slides and Images 

To begin the tour, we will first open a slide file, SlideBook‘s native file type (*.sld). A slide 

file corresponds to a single file on the disk and can be thought of as SlideBook‘s document 

type. It can contain many multi-plane, multi-channel images in any combination. 

 

1. Launch SlideBook by pointing to Programs>SlideBook from the Start menu.  

 

A new slide will appear in the window under the SlideBook menus. 

 

2. Close the new slide by choosing File>Close Slide or by clicking on the  in 

upper right corner. 
 

3. Choose File > Open Slide and navigate to the Sample Files folder in the SlideBook 

directory. Double click on QuickTourWIN1.sld. 

 

The following slide window appears that shows a thumbnail of one image. This 

slide contains one 3D image of a dividing B cell. 
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2.2 Displaying a Main View 

SlideBook can display any image using a variety of views. Each data set can have as many 

views open at one time as you desire. SlideBook has six kinds of views that display 

individual images: 

 

 Main View 

 Three View 

 Tile View 

 Channel View 

 Volume View 

 Surface View 

 

NOTE:  Views are only used to display and alter the look of an image. The underlying data 

are not affected. 

 

Now, we will open a Main View. 

 

1. Double-click anywhere on the thumbnail or within the shaded region that 

surrounds the thumbnail.  A new Main View window will open that displays the 

image. 
 

2. Create another Main View of the Dividing B Cell image by first selecting the 

image with a single click, then selecting View> New Main View. 

 

At this point you should have three open windows: the Slide window and two 

Main View windows. Both Main Views show the dividing B cell in three colors, 

where each color corresponds to a different channel, or fluorophore. DNA 

appears in blue (AMCA channel), surface immunoglobulin appears in green 

(FITC channel), and tubulin appears in red (Cy3 channel). 
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2.3 Using the Info/Tool Bar 

The Main View window contains an info/tool bar placed above the image of the data. The 

info/tool bar displays a variety of useful information and gives you quick access to tools you 

will use to explore and manipulate the view. The info/tool bar is present in all data views, 

namely the Main View, Three View, Tile View, and Channel View. 

 

Red Channel Menu

Blue Channel Menu

Background Channel 

Menu

Renormalization

Zoom Factor

Pixel Intensity Values

By Channel

x,y,z Position

Tool Menu

Mask Menu

Axis Menu Set Default View

Plane Change

Up/down

Green Channel Menu

Red Channel Menu

Blue Channel Menu

Background Channel 

Menu

Renormalization

Zoom Factor

Pixel Intensity Values

By Channel

x,y,z Position

Tool Menu

Mask Menu

Axis Menu Set Default View

Plane Change

Up/down

Green Channel Menu

Red Channel Menu

Blue Channel Menu

Background Channel 

Menu

Renormalization

Zoom Factor

Pixel Intensity Values

By Channel

x,y,z Position

Tool Menu

Mask Menu

Axis Menu Set Default View

Plane Change

Up/down

Red Channel Menu

Blue Channel Menu

Background Channel 

Menu

Renormalization

Zoom Factor

Pixel Intensity Values

By Channel

x,y,z Position

Tool Menu

Mask Menu

Axis Menu Set Default View

Plane Change

Up/down

Green Channel Menu
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2.3.1 Channel Menus and Data Values 

On the far right of the info/tool bar are three pop-up menus with colored red, green, and 

blue text next to them. These menus allow you to select the fluorescence channel that is 

displayed for each color. The Main View in this data set has the red menu set to the CY3 

channel, the green menu set to the FITC channel, and the blue menu set to the AMCA 

channel.  

 

1. Click on one of the Main View images to select it as the active window. 

 

2. Click on the ―CY3‖ bar (red menu) and select ―FITC‖ from the pop-up menu. 

Notice that FITC now appears yellow from the combination of red and green 

pixels.  

 

3. Click on the red menu and select ―none‖. Note that there are no data displayed 

in red.  

 

4. Next, set all color menus to the same channel, ―FITC‖, and observe that the 

image is now displayed in black and white. 

 

 

 
 

Try changing the settings for each menu, noting how the display changes. 

 

5. Reset the red menu to ―CY3‖, the green menu to ―FITC‖, and the blue menu to 

―AMCA‖. 
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To the left of the channel menus are colored numbers. These numbers 

correspond to the intensity of the voxel that the cursor is positioned over for 

each channel.  

 

6. Move the cursor over the Main View image. Note how the intensity values 

increase as you move over brightly colored areas and decrease as you move to 

black areas. 

 

7. Visualize just the DNA by setting the red, green, and blue menus to DAPI. As 

you move the cursor over the image, note that the red, green, and blue values 

are equal. 

 

8. Close this Main View window by clicking on the  in upper right corner. One 

slide view and one Main View window should now be open.  

 

2.3.2 Up/Down Arrows, Scrolling through a 3D image 

The Dividing B-Cell image is actually a 3D data set containing 50 planes captured at a 0.2 

micron spacing.  You may navigate through the stack in a variety of ways. 

 

1. Click on the remaining Main View. Scroll through the z-axis using the small 

arrow buttons  on the far left of the info/tool bar.  

 

Note that the coordinates in the upper left corner give you the x, y, z position of 

the mouse pointer. As you scroll through the image stack, the z position will 

update to your current location. 

 

2. Select View > Go To Plane. Enter ―2‖ in the data entry field and select OK. The 

value of the z coordinate is now ―2‖ 

 

 
 

3. Next, select View >Previous Plane and View > Next Plane commands, 

observing the value of the z coordinate in the upper left corner. 

 

4. If your mouse is equipped with a scroll wheel it can also be used to move through 

the planes of the image. 

 

2.3.3 Tool Menu 

The tool menu lets you choose the function the mouse cursor performs. 
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2.3.3.1  The Marquee Tool 

 

The marquee tool is the default tool of the tool menu and allows you to select a two- or 

three-dimensional region of the image. 

 

1. Click and drag the mouse over a region in the Main View. Note that the cursor 

appears as cross-hairs. Release the mouse button. 

 

 
 

2. You have just selected a 2-dimensional region using the marquee tool. In the 

visible axes (x and y), the marquee tool works as in any drawing program, but 

because SlideBook is designed around the 3D images, a marquee must be 

manipulated in the invisible plane as well.  To illustrate this point move to 

different z positions in the image using one of the methods outlined above.  

Notice that the marquee selection only appears in the plane that it was 

originally drawn. 

 

3. With the marquee region still selected go to View> Select Rect in All Planes. 

Again, scroll through the different z planes in the image.  Notice that now the 

marquee selection exists in all planes of the image. 

   

4. Click once on the image to remove the marquee from view. 

 

There are other ways to select 3D regions that will be demonstrated later in the 

tour. 
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2.3.3.2  Zoom Tool 

The zoom tool is used to expand or shrink the size of the window (and the corresponding 

zoom factor of the displayed image).   

 

1. Click on the tool menu and select the zoom tool. 

 

2. Click on the Main View image two times, zooming in on the image. Note that the 

percent magnification is displayed below the cursor coordinates in the upper 

right hand corner. 

  

3. To zoom out on the image simply hold the shift button down while the zoom tool 

is selected and click on the Main View image. 
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2.3.3.3  Hand Tool 

The hand tool lets you move the displayed portion of an image that is in a window smaller 

than the dimensions of the displayed axes. 

 

1. Zoom in on the Main View image until it is larger than the confines of the 

window as described above.  

 

2. Select the hand tool button from the tool menu.  

 

3. Click and drag the hand tool in the window, moving the portion of the image 

that is displayed.  

 

Notice that the hand tool performs the same function as the scroll bars to the 

left of and below the image. 

 

4. Again, select the zoom tool from the tool menu. Hold down the shift key while 

clicking twice on the image to zoom out to 100%. 

2.3.4  Axis Menu 

SlideBook is capable of visualizing data along all three axes. 

 

1. Click on the axis menu on the tool bar and select y. Enlarge the image by using 

the zoom tool. 

 

2. Use the up and down arrows to move through the planes.  

 

 
 

The y-axis is now the invisible axis. You are observing the xz-plane and scrolling 

through the y-axis. You may view all three Cartesian planes simultaneously 

using the Three View, which will be discussed later in the tour.  The axis menu 

options are unavailable in the three view because all three planes are displayed. 

 

3. Select the z axis from the axis menu to return the view to the xy-plane. 
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2.3.5  Renormalize Button 

The renormalize button brings up the renormalization dialog box. This tool allows you to 

change the range of intensities that are displayed for any channel that you choose. 

 

1. Click on the renormalize button. The following dialog box will appear. 

 

 
 

A histogram is displayed showing the relative number of pixels on the y-axis and 

intensity values on the x-axis for the specified channel. In this image, the CY3 

channel intensities range from 0 to 14281. 

 

2. Click on the drop-down channel menu and select ―FITC‖. 

 

3. Click on the red and green bars in the histogram window and drag them to the 

left or right, observing the change in the display of the green data. 

 

The red and green bars allow you to select the minimum and maximum 

intensities that correspond to the absence (black) or full saturation of color in 

the display, respectively. Again, the underlying values are not affected. 

 

4. Now enter the numbers 300 and 800 in the Low and High data entry fields. Note 

that the image does not automatically update as it does when moving the red 

and green bars. 
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5. Click Apply to register the change and update the image. 

 

6. Enter 400 and 1000 in the Low and High data entry fields and click on Apply to 

register the change.  

 

  
 

7. Choose OK to exit the renormalization dialog box.  

 

NOTE: You may also bring up the renormalization dialog box by selecting View > 

Renormalize. 

2.3.6  Thumbnail Button 

The thumbnail button lets you set the default view settings for a particular image:  color 

assignment of particular channels, renormalization information, and the z position of a 

newly opened image.  If you were to close the Main View that is currently open without 

setting a default, the changes that you just made using the renormalize button would be 

lost.  

 

1. Select View>Go to plane... and enter ―10‖ in the edit box. Note that plane 

number 10 is actually the eleventh plane. Plane numbering starts at zero. 

 

2. Select OK. 
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3. Click on the thumbnail button to select your current display as the default. 

 

Now all subsequent views of the image will default to the same display. You 

have also changed the ―thumbnail‖ image that is displayed in the slide window. 

 

4. Open another Main View of the image by double-clicking on the thumbnail. Note 

that the new settings that you entered previously apply to this new Main View. 

Also, notice that the eleventh plane is displayed. 

 

5. Close the Main View that you just created. 

 

2.4 Generating a Three View 

SlideBook allows you to view all three axes simultaneously using a Three View. 

 

1. Select View > New Three View to generate a new Three View. 

 

 
 

A new window will open with an xz pane on the top, a yz pane on the left and an 

xy pane in the middle. The most useful tool for exploring this view is the point 
selection tool. 
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2. Choose the point selection tool icon in the tool menu . 

 

3. Click on the xy pane (center pane) of the Three View with this tool. Notice that 

you update the xz and yz panes.  

 

4. Hold the mouse down and drag it around the center pane to get a cutting plane 

effect.   

 

5. Click and drag the mouse along the x axis of the center pane, and note that the 

yz plane is rapidly changing, while the xz pane is relatively still.  

 

6. Next, click and drag the mouse on the yz pane to the left, and observe that the 

other two planes are being updated. 

 

Now we will make 3D selections in the Three View using the marquee tool. 

 

7. Select View > Go To Plane. Enter plane 20 and select OK.  

 

8. Next, choose the marquee tool from the tool menu in the info/tool bar.  

 

9. Select the chromosomes by clicking and dragging a rectangle around them.  

 

10. Then go to View> Define Selection Cube.  The following dialog box will appear 

 

 
 

11. The Define Selection Cube window allows you to manually enter coordinates for 

the selection box.  Change the Z Beginning value to 10 and the Z End value to 

30.  Notice that the Z extent has updated to indicate 20 planes are selected. 

Leave the x and y coordinates unchanged and press OK. 
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Notice that the z extent of the marquee selection only spans the 20 planes that were 

selected.   

 

Next, we will spawn a Tile View that contains the data defined by the selection 

cube. 

 

2.5 Spawning a Tile View  

SlideBook can generate a plane-by-plane mosaic called a Tile View from any Main View or 

3D selection. Now we will spawn a Tile View of the selection cube that we just created. 

 

1. Select View > New Tile View. A large mosaic of the chromosomes is displayed 

with each image representing one of the 20 different z planes that was contained 

within the marquee selection. 

 

 
 

2. Select the hand tool  from the tool menu in the info/tool bar. 
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3. Click and drag around a single pane of the mosaic. This adjusts the position of 

the display cube within the image, and allows all of the tiles to be readjusted 

simultaneously. 

 

4. Close the Tile View. 

 

5. Open a Tile View from the Main View by first clicking on the Main View to 

remove the marquee selection and then selecting View > New  Tile View. Notice 

that the entire image space is now displayed. 

 

NOTE: In order to display a Tile View of a portion of the image from the Main 

View, you must first define a 3D selection. 

 

6. Close the Tile View. 

 

7. You may close the slide by either clicking on the   in the upper right hand 

corner, or by selecting File>Close Slide. 

 

2.6 Performing Volume Rendering 

SlideBook can perform interactive volume renderings using the Volume View. The 

following rendering types are available. 

 

 Dynamic Lighting (High Speed) – allows you to illuminate your object as you 

wish at the highest speed possible. Useful for quickly determining surface 

characterisitics. 

 

 Dynamic Lighting (High Quality) – similar to above, but uses a more rigorous 

lighting algorithm to improve quality of the image at the expense of speed, 

useful for determining surface characteristics 

 

 Fixed Lighting – uses a fixed lighting pattern for shading, approximates surface 

characteristics 

 

 MIP – Displays the pixel of maximum intensity along the axis perpendicular to 

the viewing plane. Does not require advanced graphics cards; however, 

performance of certain functions will be improved. 

 

 X Ray – Displays the summed intensity along the axis perpendicular to the 

viewing plane.  
 

1. Choose File > Open Slide and navigate to the Sample Files folder in the SlideBook 

directory. Double click on QuickTourWIN3.sld. 

 

The following slide window appears that shows a thumbnail of one image. This 

slide contains one 3D image of a mouse mammary gland section. 
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2. Click anywhere in the area of the image in the list and select View > 3D Volume 

View>High Speed. There are two options available, High Speed and High 

Quality.  The High Speed and High Quality only apply to the Dynamic Lighting 

option. All other modes will render identically regardless of the option that is 

selected. 

 

NOTE: If the image contains a marquee selection, SlideBook will only render the 

portion of the image that is selected. 

 

 
 

1. To change the channels that are displayed, use the Channel menus as your would 

for the Main View, Three View, or Tile View. 

 

2. To alter the shading, grab the Lighting Tool by clicking on the icon in the upper 

right hand corner  and rotating it to achieve the desired lighting. 

3. To zoom into the view, click on the Zoom Tool   and then click and drag up and 

down in your view to zoom in and out. 
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4. To rotate the image, click on the Rotate Tool   and then click and drag in the 

direction that you wish to move the image. You may either click and drag directly 

on the image or on the coordinate image in the lower right hand corner. 

 

5. To move the image in the field of view, click on the Hand Tool icon   and then 

grab and move the image by clicking and dragging on it. 

 

6. To instantly reorient your image, you may choose to display a specific face of the 

volume by choosing the Axis Tool  and selecting Top, Bottom, Left, Right, Front, 

or Back. 

 

7. To select a different rendering mode, or to alter the colors displayed, select the 

Renormalization icon . The Volume View Settings window will appear.  

 

NOTE:  The Volume View Settings window automatically opens when you open a 3D 

Volume View. 
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Several features are offered in addition to the ability to renormalize the image 

(change the lookup tables). 

 

8. Alter the background color using the Background slider and change the brightness 

of the gridlines using the Gridlines slider. 

  

9. You may alter the opacity of an individual channel using the Opacity slider control.  

 

10. Once you have explored this view, you may close the slide by selecting the  in the 

upper right hand corner, or by choosing File>Close Slide. 

 

For further information about Volume Rendering, please see Displaying a 3D or 4D 

Volume View (Volume Rendering) on page 8-32. 

2.7 Creating Masks and Generating Statistics 

A mask is a two- or three-dimensional set of binary values that has the same extent as the 

image to which it is assigned. Masks are often termed Regions of Interest (ROI) in other 

imaging programs. Masks are used for performing advanced selection and analysis of 

image data and can either be created and edited manually or generated automatically 

through threshold segmentation and other techniques.  A single image can contain several 

different masks. We will now learn how to create masks using a variety of techniques. 

 

2.7.1 Creating a Mask using Threshold Techniques 

 

1. Select File > Open Slide and navigate to QuickTourWIN2.sld in the Sample Files 

folder within the SlideBook directory.  A slide window will open that contains 

two images. 

 

2. Double click on the Fibroblast thumbnail to open a Main View of the image.  

 

3. Create a threshold mask by selecting Mask>Segment. The following dialog box 

will appear: 
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4. Select Apply. The Generating Mask dialog box will appear and report the 

segmentation progress by plane. 

 

Once segmentation is complete, your entire image will have a blue overlay. 

SlideBook has selected, or masked, any pixel that has intensity values that lie 

between the red and green bars in each of the three channels. 

 

5. Select Cy3 from the drop-down menu. 

 

6. Move the red bar to the right by clicking and dragging it. Note that when you 

release the mouse button, the image will be segmented again with the new 

parameters and the mask will be updated. 

 

7. Set the low threshold edit box to ―550‖ and click on Apply. 
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Now SlideBook is masking any pixel with a Cy3 channel intensity value between 

550 and 2715. 

 

8. Scroll through the image using the scroll wheel or the up and down arrows in 

the info/tool bar. Note that the mask persists throughout the entire image. 
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9. Close the Segment Image dialog box by pressing the OK button. 

 

10. Change the red channel from Cy3 to ―None‖. Observe the mask that is displayed. 

 

11. Click on the mask menu button  in the tool bar and select ―None‖. The mask 

has been removed from the display. 

 

12. Select ―Mask 1‖ from the mask menu. The mask is now displayed. 

 

13. To delete the mask, select Mask>Delete. The following dialog box will appear. 

 

 
 

14. Click OK to delete the mask from the image. 
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2.7.2 Creating Masks Manually (Background Subtraction Example) 

SlideBook also offers a variety of tools that can be used to manually select regions of 

interest. Note that this example illustrates multiple features of SlideBook.  

 

1. Click on the Main View of the Fibroblast image. 

 

2. Go to the middle of the focus range by selecting View>Go to Plane, entering ―7‖ 

in the edit box, and selecting OK. 

 

3. Next, select Mask>Create... The following dialog box will appear. 

 

 
 

4. Click OK to create a new mask for the current image.  

 

Often when you perform analysis, you would like to specify a region to be used 

for background subtraction. This can easily be done using the marquee tool. 

 

5. Click and drag over a region that would be suitable for calculating the 

background intensity.  

 

6. Select Mask>Mark Selection, and notice that the region is highlighted in blue. 
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7. This mask only exists in the current plane.  To copy this region to multiple 

planes go to Mask>Copy This Plane... The following dialog box will appear. 

 

 
 

8. Leave the all planes radio button selected and click OK. 

 

9. Scroll through the image and note that now the same masked region is selected 

in all planes. 

. 
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10. You can use SlideBook to get statistics from masked regions. Go to 

Mask>Statistics.  The following dialog box will appear. 

 

 
 

11. Check the Entire Mask radio button in the Mask Scope section and then expand 

the Intensity menu in the Features section of the Mask Statistics dialog box by 

clicking on the + to the left of the checkbox. Then check Mean Intensity, and 

then click Display.  A table will appear that resembles the following. 

 

 
 

These statistics can be exported as a tab delineated file by selecting Export. 

 

12. To perform background subtraction, choose Image > Channel Operations > 

Channel Math…. The following dialog box will appear. 
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13. Enter the mean background intensity value for the given channel (DAPI) to the 

offset data field for the first channel, then select (no op).  Enter a name, such as 

DAPI-Background‖, for the new channel that will be generated.  The dialog box 

will look like this: 

 

 
 

14. Select OK to create the background subtracted channel.  This new channel will 

now be present in the channel pull down menu within the Main View. 
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15. You may repeat steps 12-14 for each channel by selecting the appropriate 

channel in the Channel Math dialog box and subtracting the relevant 

background intensity value.  When you are finished, close the Main View of the 

Fibroblast image. 

 

 

2.7.3 Defining Multiple Objects 

 

Often you may have several distinct objects that will have intensities that are very similar, 

and thus will segment together. A mask that contains several distinct objects may be 

separated into objects, as we will now demonstrate. 

 

1. Open a Main View of the HeLa image within the QuickTourWIN2.sld. by double 

clicking on the thumbnail.  

 

2. Create a new threshold mask by selecting Mask > Segment… The following 

dialog box will appear. 
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3. Drag the red bar to the right until the low threshold value is approximately 550. 

As you drag the bar, note the masked areas that appear on the image.  Also, note 

that the data that is being selected is shown in white on the histogram. Pixels 

with intensity levels that lie in the gray area are not included in the mask.  

 

Alternatively, type 550 in the Low data entry field and select Apply to set the 

low threshold value. Your dialog box will appear as follows: 
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4. Select OK to create the mask. 

 

 
 

5. Next, select Masks>Define Objects in Mask. The following dialog box will 

appear. 

 

 
 

Here you may choose to exclude objects based on minimum and maximum size 

gates. Leave the box unchecked for now. 
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6. Select OK. A dialog box will appear that gives the status of the object 

generation. When object generation is complete, the following box will appear, 

noting the number of objects generated. 

 

 
 

7. Click on OK, and now position the cursor over one of the objects in the Main 

View.  Note that the object number appears to the right of the cursor location 

coordinates in the info/tool bar. 

 

 
 

8. SlideBook can generate individual statistics for each object.  Select Mask > 

Statistics. The following dialog box will appear. 

 

 

 
 

9. Expand the Morphometry and Intensity statistics selections by clicking on the + 

signs to the right of the checkboxes. 
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10. Select Area (pixels) and Mean Intensity, then select Display to generate 

statistics. The following table will appear. 

 

 
 

11. Expand the column headers by clicking and dragging the edge of the header to 

the right. Click on any object number in the table. Notice that the corresponding 

object in the image is highlighted in pink. 
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Notice that some of the objects are of very small size. If you would like to exclude 

those regions when making objects, you may gate the objects by size. This can be 

done either by going back to the Define Objects dialog box or through the 

Statistics window itself. 

 

12. To gate objects by size using the Define Objects window go to Mask > Update 

Object Definitions (Note the menu item is now named ―Update Object 

Definitions‖ as opposed to ―Define Objects‖ since objects already exist for this 

image).  The following dialog box will appear. 
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For the purposes of this demonstration, select the Gate Objects by Size checkbox 

and enter a minimum size gate of 100 voxels.  This will exclude any objects from 

the mask that are less than 100 voxels. 

 

13. Select OK to update the object definitions.  Notice that SlideBook has generated 

fewer objects than when this operation was performed without a size gate. 

 

14. Statistics can now be generated on these new objects as described above. 

  

15. To gate objects by size using the Statistics window select Mask > Statistics. The 

following dialog box will appear. 
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16. Now click the Remove objects smaller than: check box located under the 

Primary Mask menu and enter a minimum size gate of 100 in the active edit box.  

  

17. Select the statistics you would like to have computed and click Display.  

SlideBook will automatically remove objects smaller than the minimum size gate 

during statistics computation.  

 

18. The statistics table may be exported for use in other programs by clicking the 

Export button. A dialog box will appear that will allow you to choose the file 

destination. The file will be saved as a tab delineated text file (*.txt), which can 

be opened by various programs, such as Excel. 

 

19. Close the slide by clicking on the  in the upper right corner of the slide view or 

by selecting File > Close Slide. 
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3 SlideBook Organization 

 

SlideBook was designed to seamlessly integrate microscope control and image operations 

such as capture, display, and analysis. In this chapter you will learn about the organization 

of SlideBook elements. The following topics will be covered: 

 

 Hardware Control and Image Capture 

 Data Storage, Display, and Analysis 

 

3.1 Hardware Control and Image Capture (Chapters 5, 6 and 7) 

In order to capture an image, two distinct processes are performed. First, a sample is 

brought into view and focus using the Focus Window. Second, image capture parameters 

are set and capture is initiated in the Capture Window. Once the capture begins, it can be 

monitored in the Capture Status Window. 

3.1.1  Focus Window 

In this window, the microscope parameters are selected and moved into position, if 

motorized. A semi-live stream of images are captured and displayed in the Focus Window. 

Additionally, parameters for the XY stage, such as points of interest, and for the Z stage, 

such as the depth for a 3D capture, can be set in this window. Once the hardware is set as 

desired and the sample is in focus, the user will move to the Capture Window. See Chapter 

5 for further explanation of the Focus Window. 

 

3.1.2  Capture Window 

Camera and capture parameters are set in the Capture Window.  The appropriate 

exposure time and capture sequence are determined in this window. For instance, the user 

will decide whether the capture will be two-dimensional, three-dimensional, two-

dimensional over time or three-dimensional over time. Parameters set in the Focus 

Window, such as multiple points in the xy plane and z distances, can be imported into the 

Capture Window and utilized during the capture sequence. See Chapters 6 and 7 for 

further explanation of the Capture Window. 
 

3.1.3 Capture Status Window 

The Capture Status Window shows the progress of a capture sequence. The features in 

this window are most useful when performing timelapse acquisition and are discussed in 

Chapter 7. 

 

3.2 Data Storage, Display, and Analysis (Chapters 8, 9, and 10) 

SlideBook‘s image visualization and analysis tools are designed around five principal 

objects:  image, channel, view, mask, and slide.  This organization is somewhat different 
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than other image processing programs.  For instance, with this organization, operations 

that change data are kept separate from those that only affect its display or analysis. 

3.2.1 Images and channels 

An image is a two- or three-dimensional set of data collected by a digital microscope or 

imported from another application.  It consists of one or more channels, where each 

channel corresponds to a different fluorophore.  For instance, one channel may represent a 

FITC labeled protein while another represents a CY3 labeled protein.   

 

An image (and its constituent channels) represents the underlying data. Operations that 

can alter the underlying data (such as deconvolution, flat field correction, and cropping) are 

found under the Image menu. 

3.2.2 Views 

Unlike images, views represent a visual interpretation of the image‘s data.  SlideBook 

currently has two classes of views:  data views and display views.  It is within a view that 

data can be renormalized (altering the mapping from image intensity levels to red, green, 

or blue intensities on the display) and colors can be assigned to different channels.  You 

can have multiple views open on a given image at one time. Commands used to create 

views are found under the View menu. 

3.2.3 Masks 

A mask is a two- or three-dimensional set of binary values that has the same extent as the 

image to which it is assigned. Masks are often termed Regions of interest (ROI) in other 

imaging programs. Masks are used for performing advanced selection and analysis of 

image data and can either be created and edited manually or generated automatically 

through threshold segmentation and other techniques.  A single image can contain several 

different masks. Commands used to create and manipulate masks are found under the 

Mask menu. 

3.2.4 Slides 

Images in SlideBook are organized into slides.  Typically, a slide corresponds to a number 

of images captured from a single sample, and it is the native file type saved by SlideBook.  

By collecting related images into a single slide, SlideBook makes managing files easier.  

Slides appear on your file system with a .sld extension. 
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4 Configuring Your System 

 

In order for SlideBook to control any motorized aspects of your microscope system and to 

perform deconvolution and analysis of images, it must know the optical and system 

parameters of the microscope used to collect the image. By the end of this chapter, you will 

know how to: 

 

 Designate User Logins 

 Configure Hardware 

 Define Objectives 

 Define Filters 

 Define Magnification Changers 

 Work with SlideBook Preferences and Hardware Properties 

 Define System Parameters 

 

Once the hardware is configured and the optical parameters are defined, they can be 

utilized in several different ways. If the optics are motorized, they may be selected and 

brought into the light train using the focus window. Once an image is captured using the 

selected motorized optics, the capture information is automatically stored with the image. 

If the optics are not motorized, they may be selected in the capture window and then 

automatically stored with the image information. Also, optics information can be added or 

edited post-capture, which is especially useful for imported images. 

 

4.1 Designating User Logins 

You may define multiple user logins to separate user preferences. The user login will allow 

individual users to access their capture preferences (see Saving Capture Parameters on 

page 7-39). Hardware, filter, and objective configurations are shared among all users.  To 

configure user logins: 

 

1. Go to Edit>Hardware Properties… and scroll down until User Login Properties 

is visible. 
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2. Click on the + next to User Login Properties to expand the section, and then 

click on Enable User Login. 
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3. Click Yes and then Apply Change. 

 

4. Restart SlideBook. Upon startup, you will see the following screen: 

 

 
 

5. To add a user, click Add User. The following dialog will appear. 
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6. Enter the desired User Name in the edit field and click OK. 

 

7. Upon restart, choose your User Name from the drop-down list and then click 

Login. Your capture preferences will be available in the Capture Dialog. 

4.2 Configuring Hardware 

SlideBook has the ability to control a range of hardware, including: 

 

 CCD cameras  

 Automated microscope components 

 Objective turret 

 Magnification changer turret 

 Ocular/Photo switch 

 Fluorescence lightpath hardware 

 Filter wheels 

 Filter turret 

 Shutter 

 Automated xy and z stages 

 Image Splitters 

 Transmitted (brightfield) lightpath hardware 

 Shutter 

 Lamp 

 LCD filter 

 TTL controllable hardware 

 

When you start SlideBook for the first time, it will notice that a preferences file, which is 

stored along with the application, does not exist.  SlideBook will create a default 

preferences file.  As you configure your hardware and define optics, SlideBook will update 

this preferences file with specific information about your setup.  

 

4.2.1 General Hardware Configuration 

To configure your hardware: 

 

1. Start SlideBook by selecting the program from the Start menu. 

 

2. Select Edit > Hardware Configuration…. The following dialog box will appear. 
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3. Enter a System Name in the edit field. This should be descriptive and include 

the laboratory name so that the preferences file can be identified by 3i technical 

support. 

 

4. Select the components that are present from the drop-down menus (set to None 

in the dialog box above).  

 

5. For each component, select the COM port to which it is connected in the drop-

down menus to the right of each component. If a component is not present, or 

you would not like it to communicate with SlideBook, be sure the COM port is 

set to Off. 

 

NOTE: A typical PC has two serial COM ports, port 1 and port 2, located at the rear of the 

machine. Additional COM ports are often added (e.g., through use of an Edgeport adapter 

or PCI card). These additional ports are then termed port 3, port 4, etc. instead of following 

the labels on the adapter. 

 

6. Select OK. 

 

7. Restart SlideBook to register the changes and begin hardware communication. 
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8. If you plan to control your hardware via TTL control, please consult the 

SlideBook TTL Module Manual. 

 

 

NOTE: There are instances when you will need to select your objective and filter in the 

Focus Window, even if these components are not motorized. For example, if you would like 

to perform auto focus you will need to select the objective and filter you are using. In these 

instances, you will define Manual Filter Turret or Manual Objective Turret (COM port set 

to OFF). Make sure that you specify the position of your objectives in the Objective 

Definition (see page 4-12). 

 

 

4.2.2 Configuring a Motorized XY Stage 

In order for your motorized xy stage to work properly when collecting montage images, you 

will need to specify the relationship between the stage and camera.  

 

1. To do so, you will first need to bring a sample into view and focus in the focus 

window (see Using the Focus Window on page 5-11).  

 

2. Using the joystick, move the stage so that the image on the screen moves to the 

left (in other words, pan and move the image field to the right). When panning to 

the right, notice whether the x coordinate position in the focus window scan tab 

increases or decreases.  

 

3. Repeat for the y axis by panning down so that the image appears to move up. 

Note the change in the y axis coordinate position (increasing or decreasing) 

when panning.  

 

4. Select Edit > Hardware Properties. The following dialog box will appear. 
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5. Click on the + sign next to XY Stage to expand the list. 
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6. Click on the item in the list titled MoveFieldRightSign. The left side of the 

dialog box will be updated. 
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7. Enter the appropriate value, 1 or -1 based on the change in X position values 

when panning right, in the edit field and select Apply Change. 

 

8. Repeat steps 6 and 7 for the Y Axis by clicking on the MoveFieldDownSign. 

 

9. Close the dialog box using the Close button. 

 

4.2.3 Configuring an Image Splitter 

SlideBook supports the use of image splitter devices. An image splitter allows you to 

capture two separate channels for the right and left halves of the camera. To configure an 

image splitter: 

 

1. Select Edit > Hardware Properties and click on the + sign to expand the 

Simultaneous Capture section.  
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2. Click on Split Capture. The left side of the dialog box will change. 
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3. Select Yes, Apply Change, and then Close.  

 

4. Restart SlideBook to register the changes.  

 

To use the image splitter, you must define filters appropriately (see Defining Filters when 

using an Image Splitter on page 4-25). To align your image splitter, use the Test 

Simultaneous Capture function in the Focus Window as described on page 5-10. To 

capture images using your image splitter, use the Simultaneous Capture checkbox as 

described on page 7-13. 

 

4.2.4 Configuring Camera and Ocular Ports 

If your system has motorized ocular photo and CCD/Video prisms as well as multiple 

cameras, you may define the positions of the prisms that correspond to each camera. To do 

so: 

 

1. Select Edit>Hardware Properties and expand the section titled Camera 1. 



Chapter 4 – Configuring Your System Hardware 

4-11 

 

2. Click on Prism1Pos. The right side of the dialog will be updated. 

 

 
 

3. Enter the value of the ocular photo prism (Prism 1) position that corresponds to 

the position of Camera 1 in the edit field. 

 

4. Select Apply Change. 

 

5. Repeat steps 4 and 5 for Prism2Pos (CCD/Video prism). 

 

6. Repeat steps 2-5 for any other cameras and the ocular lightpath. 

 

Once you have defined the prism positions, you can click on any of your cameras in the 

Camera tab and the prisms will move to direct light to that camera. Additionally, if you 

have defined filters for specific cameras, the prism positions will move to the appropriate 

camera when you select a filter in the Scan tab. 
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4.3 Defining Objectives 

Once an objective is defined, it can be controlled (if motorized) from the focus window. If 

the objective is not motorized, it may be selected in the capture window and the objective 

definition will automatically be stored with the image information. If the objective was 

used to capture an image that has been imported, the objective information can be added to 

the image information. 

4.3.1 Adding a New Objective 

In order to define a new objective for your system, do the following: 

 

1. Select Edit > Define Optics > Define Objectives.  The following dialog box will 

appear: 

 

 
 

2. To add a new objective definition, click on the Add button.  

 

3. Enter the objective name, magnification, numerical aperture, working distance, 

and m/pixel. You must give the lens a name and fill out all parameter fields, 

except Parfocal Offset.   

 

4. Select the location of objectives from the Position drop-down menu. If you have a 

motorized objective turret, Position should reflect the position of the objective on 
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the microscope; if you are using SlideBook offline or with a non-motorized turret, 

you should select Not Mounted. If you are using a non-motorized turret, but 

have selected Manual Turret in your hardware configuration, select the 

appropriate turret position. 

 

5. Select the UV checkbox for UV objectives and select the appropriate medium 

from the radio button menu. 

 

6. Select the appropriate configurations for the desired transmitted light condenser 

turrets using the drop-down menus on the right. Once you have defined the 

condenser positions for a given objective, you may define filters that utilize the 

appropriate condenser positions. Filter definitions are discussed in the next 

section. 

 

7. Repeat steps 1-6 for any additional objectives that you wish to add. 

 

8. Select OK when you are finished. 

 

9. Restart SlideBook to register the changes that you have made. 

 

4.3.2 Modifying Information for an Existing Objective 

You can modify existing settings as follows: 

 

1. Select Edit > Define Optics > Define Objectives… to bring up the Objective 

Parameters dialog box. 

 

2. Select the appropriate lens using the Objective Lens dropdown list. 

3. Change the appropriate fields as desired. 

4. Select OK to save the changes.   

5. Restart SlideBook to register the changes that you have made. 

 

4.3.3 Removing an Objective 

 

1. Select Edit > Define Optics > Define Objectives.. to bring up the Objective 

Parameters dialog box. 

 

2. Select the appropriate lens using the Objective Lens dropdown list. 

3. Choose Remove, then OK to save the changes.   

4. Restart SlideBook to register the changes that you have made. 
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4.4 Defining Filter Configurations 

You can add, modify, and remove filter configurations using the Filter Configuration 

Parameters dialog box.  The components of this dialog box and instructions for adding, 

modifying and removing filter configurations are explained below. 

 

4.4.1 Defining Filter Sets 

SlideBook allows you to assign a particular filter to one of six groupings, or sets. These sets 

can be chosen in the focus window and capture window. The default sets are Fixed, Live, 

User 1, User 2, User 3, and User 4. Sets allow you to work with many different filter 

definitions in an orderly fashion. To change these default group names: 

 

1. Select Edit > Hardware Properties.  The Filter Configuration Parameters dialog 

box will appear. 

 

 
 

2. Scroll down to find the property ―Filter Set Information‖ and click on the + sign 

to expand as shown below. 
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3. Click on the Filter Set Label that you wish to change. 
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4. Enter the text for your filter set. Examples may be a specific user name or a type 

of experiment. 

 

5. Click Apply Change and then Close to register your changes. 

4.4.2 Filter Configuration Parameters 

The Filter Configuration Parameters dialog box is found by selecting Edit > Define Optics 

> Define Filter Configurations… 
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4.4.2.1 Light Source 

Here you may choose which light source will be used. If your microscope has an automated 

brightfield lamp, the lamp will be switched on and off for each brightfield image that is 

acquired. Also, if you have motorized condenser turrets, you may select whether a 

transmitted light channel is brightfield, darkfield, DIC (Nomarski), or phase. If you check 

the Prompt if mode is not available for current objective checkbox, SlideBook will 

automatically warn you if objective and filter definitions are inconsistent. For fluorescent 

channels, input the emission wavelength in microns in the edit field. You should also 

indicate whether the fluor requires a UV objective. SlideBook will automatically check for 

consistency between objective type and fluorescent channel type and prompt you if there is 

a problem. 

 

NOTE: You MUST have condenser turret positions defined for objectives if you would like 

the condenser turret position to correspond to a specific transmitted light channel (see 

Adding a New Objective). 

 

4.4.2.2 Filter Set 

SlideBook allows you to assign a particular filter to one of six groupings, or sets.  The 

default sets are Fixed, Live, User 1, User 2, User 3, and User 4. You may also edit these 

set names as shown on page 4-14. These sets can be chosen in the focus window and 
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capture window. Sets allow you to work with many different filter definitions in an orderly 

fashion. 

 

4.4.2.3 Filter Positions 

SlideBook permits filters to be defined in up to four positions within the optic path.  For 

systems equipped with filter wheels or rapid filter switcher (such as the Sutter DG-4 or 

TILL Polychrome V), use the Excitation Wheel Position and Emission Wheel Position 

fields.  If your system has a motorized filter turret, you must specify the Internal Turret 

Position for the filter configuration‘s cube. If your system does not have a motorized filter 

turret, you should still enter the position of the cube. Then, when you select the filter from 

the Focus Window, SlideBook will visually prompt you to move the turret to the 

appropriate position. Some examples of how to use filter positions are described in the 

section Adding a New Filter Configuration below. 

 

 

NOTE: If you have a manual filter turret, SlideBook will prompt you to move the beam 

splitter when performing multi-channel capture. In cases where you do not want a prompt 

for a different beam splitter (or in the motorized case, you do not want the internal turret 

to move), you can simply set Internal Turret Position to ―Not Mounted.‖ If you believe you 

are seeing a prompt in error, you may wish to review your filter configuration to make sure 

that your positions are defined correctly and also check your hardware configuration to 

ensure that any motorized elements are defined properly. 

 

Finally, if you have an LCD color filter as part of your system, the LCD Filter Position field 

can be set to select positions for individual colors.  

 

4.4.2.4 Camera 

SlideBook supports use of multiple cameras. If you have more than one camera, you may 

select the camera that will be used for capturing the given filter configuration. 

 

4.4.2.5 Channel Types 

All fluorescent filter configurations that are not used for ratio imaging should be set to 

Independent. Configurations for ratio and FRET channels are discussed in the Ratio/ 

FRET Module manual. Brightfield channels that use a color camera should be set to RGB 

Color. Brightfield channels that use an LCD color filter, or three separate color filter cubes 

should be set to Virtual RGB (red), (green), or (blue). 

 

4.4.2.6 Default Color Display 

You can always change the colors (or color display type) of data captured with different 

filter configurations.  The Default Color Display, however, is a convenient way to choose 

how data from different filter configurations is displayed in the capture status dialog box 

as well as the initial view created for an image. Channels may be set to standard RGB, 

pseudocolor, monochrome, user-defined, or set to the emission wavelength.  

 

4.4.2.6.1 Pseudocolor 

Pseudocolor (Color) and Pseudocolor (Intensity) together determine the look of a 

pseudocolored image.  A filter configuration that has Pseudocolor (Color) as its default will 

set the hue value of the display according to the normalized (i.e., scaled from minimum to 
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maximum) value of each voxel.  A filter configuration that has Pseudocolor (Intensity) as 

its default will gate the intensity of the pseudocolored image according to the normalized 

value of each voxel.  If a captured image contains a channel with a filter configuration set 

to Pseudocolor (Color) but not Pseudocolor (Intensity), the corresponding view will show a 

range of hues at maximum intensity (i.e., ranging from bright blue to bright red).  If the 

image also contains a channel with a filter configuration set to Pseudocolor  (Intensity), 

the corresponding view will show a range from dark blue (black) to bright red.  If the image 

only contains a channel with a filter configuration set to Pseudocolor (Intensity) and no 

Pseudocolor (Color) counterpart, the default setting will be treated as if it were set to 

None. 

 

Pseudocolor color types cannot be displayed along with red, green, or blue channels.  

Monochrome settings may only be used for a background channel when displayed with 

RGB channels. In multiple channel images, the pseudocolor setting will override any red, 

green, or blue settings.  Red, green, or blue settings will in turn override a monochrome 

setting.  Again, this doesn‘t mean you can‘t easily get back to viewing any other channels, 

but simply determines what will be visible initially. 

 

4.4.2.6.2 User-Defined Color 

You may elect to set the default color to one of your choosing. To do so, select the User-

Defined radio button, and then click on the color block to the right. A dialog box similar to 

the following will appear. 

 

 
 

Select one of the basic colors by clicking on the color block in the upper left hand color, or 

design a custom color using the color spectrum on the right and choose Add to Custom 

Colors. 

 



SlideBook 4.2 User Manual 

4-20 

4.4.3 Adding a New Filter Configuration 

 

1. Select Edit > Define Optics > Define Filter Configurations….  The Filter 

Configuration Parameters dialog box will appear. 

 

2. To add a new filter configuration definition, click on the Add button.  

 

3. Enter the filter name in the data entry field. 

 

4. Select the light source, and enter the emission wavelength in m (for fluorescent 

filters). Also, if the filter requires a UV objective, select the checkbox under the 

emission wavelength data field. The Light Source field permits sequential 

brightfield (or Nomarski) and fluorescence imaging on systems equipped with 

both a fluorescence shutter and either a brightfield shutter or electronic voltage 

control. 

 

NOTE: You may configure multiple transmitted light channels if you have a 

motorized condenser turret. For instance, you may define a DIC channel by 

selecting Transmitted light source and DIC from the Mode drop-down menu. 

You could also define a Phase channel by creating a new channel with Phase 

selected from the Mode drop-down menu. Then, if you performed capture with 

either of these channels, the condenser turret would move to the appropriate 

position automatically. You must define the condenser turret positions when 

defining objectives for this feature to work properly (see section Adding a New 

Objective). 

 

5. Select the desired Filter Set from the drop-down menu. 

 

6. If the exciter is located in an external excitation wheel, select the position of the 

filter from the Excitation Wheel Position drop-down menu. If it is mounted in a 

cube in the internal turret or if it is not currently mounted on the system, select 

Unmounted. 

 

7. Select the internal turret position of the dichroic mirror from the Internal 

Turret Position drop-down menu. If the dichroic mirror is not currently 

mounted, you should select Unmounted. 

 

8. If the emitter is located in an external emission wheel, select the position of the 

filter from the Emission Wheel Position drop-down menu. If it is mounted in a 

cube in the internal turret or if it is not currently mounted on the system, select 

Unmounted. 

 

9. Repeat steps 1-8 for any additional filter configurations that you wish to add. 

 

10. Select OK when you are finished. 

 

11. Restart SlideBook to register the changes that you have made. 
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4.4.3.1 Example Filter Configuration for Fluorescence Channels 

 
Example  – Quad Pass and Dual Pass sets on a system with filter wheels and motorized 
turret 
 
Some systems with filter wheels will need different beam splitters to be in position for 

different sets of fluorophores.  For instance, a system may have excitation and emission 

filter wheels loaded with filters for DAPI, CFP, FITC, YFP, CY3, and CY5.  The DAPI, 

FITC, CY3, and CY5 filters require a quad pass beam splitter designed for that set of 

fluorophores, while CFP and YFP require a dual pass beam splitter which is designed 

specifically for those two fluorophores. 

 

In a system with filter wheels and a motorized turret, Internal Turret Position should be 

set to the appropriate beam splitter (or dichroic) position for each filter configuration.  In a 

system with filter wheels but no motorized turret, the Internal Turret Position field 

should be set differently for each set of fluors that require a different beam splitter if you 

want SlideBook to prompt you to move to the necessary beam splitter.  Given the example 

above, even if the system does not have a motorized turret, the filter configurations for 

DAPI, FITC, CY3, and CY5 should have Internal Filter Position set to say, 1, while CFP 

and YFP have Internal Filter Position set to 2. 

 

4.4.3.2 Configuring Channels for Color Cameras or Color LCD sliders 

If you have a color camera, you will need one filter definition that appears as follows (you 

must enter the appropriate location of an empty turret and emission wheel position if 

applicable): 
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If you have a LCD slider, such as that made by CRI, you will need to configure three 

separate channels; however, these three channels will appear as one channel in the 

capture dialog. You must define one channel each for red, green, and blue. For the color 

LCD slider, the filter definitions must appear as follows. Create the definitions in the 

following order: red, blue, green. This is because you will most often perform autofocusing 

with the green channel, and autofocusing will be performed with the last channel captured. 

For the red channel, you may also choose ―Red‖ as the Default Color Display. ―RGB 

Settings‖ allows you to manually enter in whitebalance numbers. You may find that using 

the white balance function in the capture dialog is sufficient (please see Performing Auto-

White Balance for Color Capture on page 6-7). 
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4.4.3.3 Defining Filters when using an Image Splitter 

If you have configured an image splitter such as the Dual View from Optical Insights, you 

should define two filters that have identical excitation wheel positions (if applicable) and 

identical internal turret positions. Then, depending on the position of the image splitter, 

select one channel Camera position as Camera 1, and the second channel as Camera 2. 

For instance, if you are performing CFP/YFP FRET, you may wish to define four filter 

configurations, 1) YFP excitation, YFP emission, 2) YFP excitation, CFP emission (this is a 

dummy filter that must be configured, but will not contain information), 3) CFP excitation, 

YFP emission, 4) CFP excitation, CFP emission. In this example, filters 1 and 3 will use 

Camera 1, while filters 2 and 4 will use Camera 2. Also, filters 1 and 2 will use the same 

excitation position, as will filters 3 and 4. You must define the filters in order so that the 

channels within each pair that share an exciter are adjacent. In the example above, 

channels would be defined in order of 1-4. 

4.4.4 Modifying Information for an Existing Filter Configuration 

 

1. Select Edit > Define Optics > Define Filter Configurations….  The Filter 

Configurations Parameters dialog box will appear. 

 

2. Select the appropriate filter using the Filter Configuration dropdown list. 
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3. Modify the appropriate fields as desired. 

4. Select OK to save the changes. 

5. Restart SlideBook to register the changes that you have made. 

4.4.5 Removing a Filter 

 

1. Select Edit > Define Optics > Define Filter Configurations….  The Filter 

Configurations Parameters dialog box will appear. 

 

2. Select the appropriate filter using the Filter Configuration dropdown list. 

3. Choose Remove, then OK to save the changes.   

4. Restart SlideBook to register the changes that you have made. 

 

4.5 Defining Magnification Changers 

A magnification changer, or optovar, is a component which your microscope may or may not 

have.  It acts to increase the effective magnification of an objective.  If you do not have a 

magnification changer, you should use the predefined 1.0 x definition.  

  

4.5.1 Adding a New Magnification Changer 

 

1. Selecting Edit > Define Optics > Mag. Changers… The Mag. Changer 

Parameters dialog box will appear. 

 

 
 

2. Click on the Add button. 

 

3. Enter a Name in the data entry field, and the Magnification as an integer. 

 

4. Click OK to save the definition. 
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5. Restart SlideBook to register the changes that you have made. 

 

4.5.2 Removing or Modifying Magnification Changer Definitions 

You may remove and alter magnification changer definitions as you would for objectives 

and filter configurations. 

 

Note that if you switch between several camera adapters with different relay lens 

magnifications, you can also use magnification changer definitions to specify which relay 

lens is in place. 

4.6 Working with SlideBook Preferences and Hardware Properties 

Your system configuration is stored in the SlideBookPrefs.dat file. It is located in the 

following directory: Program Files/Intelligent Imaging Innovations, Inc./SlideBook. If 

SlideBook is not installed in the above directory, these files will be located in the same 

folder as the SlideBook executable file. You should keep a back-up copy of this file at all 

times. You may be required to send this file to 3i Support for troubleshooting. You may also 

export a .txt version of this file by selecting Edit>Define Optics>Export Preferences, 

Additional system configurations are found in your SlideBookHardwareProperties.dat 

file, which can also be found in the same folder as your SlideBook program file. You should 

also keep a back-up copy of this file as well. 

4.7 Defining System Parameters 

You can adjust the z-axis increment size, the default interplane spacing, the index of 

refraction of the oil you are using, and the disk drive on which to put temporary files using 

Edit > Define Optics > System Parameters.   

 

 
 

For microscope automation to work correctly, you need to enter the size of a single z-axis 

increment of the stage (in microns) in the Microscope Step Size field.  When you import 

files from other applications, SlideBook will assume a default interplane spacing (in 

microns) that is defined in the Default Import Spacing field.
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5 Controlling the Camera and Microscope Hardware (Focus 

Window) 

 

SlideBook provides a Focus Window with control panels for automated hardware control 

and an Image Window for semi-live camera readout. The controls in the Focus Window will 

allow you to choose the appropriate optics and bring your sample into focus. It will also 

allow you to set parameters for advanced capture, including top and bottom z limits for 3D 

imaging, xy coordinates for multipoint acquisition and boundaries for a generating a 

montage. This chapter covers the following topics: 

 

 Focus Window Features 

 Using the Focus Window 

 

The use of the Focus Window for advanced capture is discussed in detail in Chapter 7. 

 

5.1 Focus Window Features 

The Focus Window can be opened by either selecting Window > Focus Window or clicking 

on the focus window button in the toolbar . The Focus Window consists of a Focus 

Controls dialog box and the Image Window. The Image Window operates in a live mode 

when the Focus Window is selected. The Image Window is also used for capture as 

discussed in Chapters 6 and 7. 
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The Focus Controls window has four tabs:  Scope, Z, XY, and Camera and that control and 

report the status of automated microscope components. Additionally, there are several 

components, permanent controls, in the lower half that are displayed no matter which tab 

is selected. 

5.1.1 Permanent Controls 

The lower half of the Focus Controls dialog is present regardless of the tab selected. 
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5.1.1.1 Camera and Display Settings 

The exposure time slide bar allows you to select the duration of a single camera exposure 

(between 1 and 500ms).  This exposure is repeated continuously to form the semi-live 

image display.  You can also select between four bin factors, all of which are based on 

square pixel groupings (i.e., 1x1, 2x2, etc).  Binning increases camera sensitivity and 

readout speed.  This is useful in the focus window because it allow shorter exposure times 

and faster image refresh rates, ultimately making it easier to find a sample and bring it 

into focus.  Importantly, the focus window exposure time and bin factor adjustments are 

used only for optimizing image display in the focus window.  Adjusting the camera settings 

for capturing an image is covered in Chapter 6 on page 6-1. 

 

On systems with multiple cameras and motorized camera port selection, the Camera drop-

down menu lets you direct the light to the desired camera and display the resulting image.  

On systems with two cameras running simultaneously from a single port, these buttons let 

you select which camera‘s output will be displayed in the Focus Window. 

 

The Start and Stop buttons start and stop continuous camera capture.  This can be 

particularly useful if you have a mechanically shuttered camera since the focus window can 

be left open without taking unnecessary camera exposures. You may also press Snap to 

grab a single image that will be stored in an open slide. 

 

The  and  buttons in the bottom left corner are used to zoom in and out on the image 

display.  Zooming in on the display can be particularly useful for focusing on small objects. 

 

The Renorm menu allows you to select the type of renormalization which is used for 

displaying the focus window image (Min-Max, Unrenormalized and Custom). 

Renormalization can be used to highlight a particular range of intensity values in an 

image.  When the focus window Renorm is set to Min-Max, SlideBook will continually 

update the low and high renormalization values to the minimum and maximum pixel 

values in each focus window image.  When set to Unrenormalized, the full intensity range 

will be used for the focus window display.  Selecting custom Renorm activates the Edit… 
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box to the right, allowing a user-defined low and high renormalization value to be entered.  

For a detailed explanation of how renormalization affects image display, refer to Altering 

the Renormalization Parameters (Look-up Table)  on page 8-14. 

 

Selecting the Guides check box will bring up yellow guides that mark a 256x256, 512x512, 

and 1024x1024 pixel region in the image.  The Color check box is used to display a color 

brightfield image in the focus window.  Use of this feature requires specific hardware for 

capturing color images, such as an LCD color filter changer or color camera. 

 

5.1.1.2 Open Fluor, Open Bright, Open Alt 

The Open Fluor button is used to toggle the fluorescence light source if there is a 

computer-controlled shutter or dark slider in the reflected light path. 

 

The Open Bright button is used to toggle the brightfield light source if there is either a 

computer controlled shutter in the transmitted light path or the microscope has computer 

control over the transmitted light source voltage.  

 

The Open Alt button is used to toggle an alternate source if it is present. For example, if 

you have a NEOS AOTF laser system, or a shuttered TIRF laser, Open Alt will toggle the 

laser light on and off. 

 

5.1.1.3 Filter Controls 

You may select a filter set using the filter set drop-down menu. Each button corresponds to 

a filter configuration that you have defined for the system.  (For more information on 

creating new filter configurations, please refer to the section Defining Filter Configurations 

on page 4-14).  If filter configurations have been assigned to a particular filter set, they can 

be accessed using the drop down menu.  Depending on the configuration of your microscope 

system, clicking on a filter configuration tab will change one or more of the following: 

 

 excitation filter wheel position 

 emission filter wheel position 

 internal filter turret (or slider) position 

 camera that is used for display (when the system has multiple cameras) 

 

The filter configuration that is currently selected will be highlighted and displayed in bold 

letters (DAPI in the above example), while the rest of the configurations will have a normal 

button appearance. 

 

5.1.1.4 XY Stage 

On systems equipped with a motorized xy stage, you can use the directional buttons to 

move the stage in increments specified by the value in the adjacent edit field.  This value is 

always given in microns (or fractions thereof).  You can change this increment distance at 

any time. The defaults are 100, 10, 1 and FOV (Field of View) which can be selected from 

the drop-down menu. 

 

TIP: If you double-click on an object in the image display, the xy stage will move so that the 

object is centered. 
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The current x and y positions read from the stage are also displayed in this section. 

 

5.1.1.5 Z Stage 

On systems equipped with motorized z focusing, you can move the focus up and down using 

the directional buttons.  There are three sets of buttons with predefined stage movement 

increments (10, 1, and 0.1 microns).  In addition, an arbitrary stage movement increment 

value can be entered in the edit field below the last set of buttons on the right. The default 

value of the edit field will be set to the theoretical z resolution for the selected objective. 

 

With few exceptions, the up and down buttons correspond to the direction of mechanical 

movement.  For instance, on an upright microscope with either an integrated or external 

stepper motor, the direction corresponds to stage movement, so ―up‖ means focusing 

further past the cover slip and towards the slide since the stage is moving up.  On an 

inverted microscope, ―up‖ corresponds to moving the nosepiece up, and therefore also 

means focusing further past the cover slip. 

 

The Auto focus Button is used to define and test parameters for auto focusing during 

capture.  Use of this feature is covered in Chapter 7. 

 

5.1.1.6 Neutral Density 

If you have defined neutral density positions in your Hardware Configuration, you may 

select the position from the Neutral Density drop-down menu. 

5.1.2 Scope 

The Scope tab lets you observe and control other encoded and automated features of your 

system. 

 

 
 

 

5.1.2.1 Emission Selection 

On systems with a motorized emission light path, these radio buttons let you choose 

between letting the light go 100% to the camera, 100% to the oculars (eyepieces), or to 50% 

each (if available) . 

 

5.1.2.2 Magnification Changer 

On systems with an encoded magnification changer, this field reports its current position. 
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5.1.2.3 Objectives 

On systems with a motorized objective turret, you can move to a different objective by 

selecting the corresponding button.   (For information on adding objectives to those defined 

for your system, please refer to the section Defining Objectives on page 4-12). 

 

If you try to move between objectives that use differing immersion media, such as an oil 

objective to an air objective, SlideBook will bring up a dialog box warning about the 

pending move.   

 

CAUTION:  On most systems with motorized objective turrets, you can safely move between 

objectives of similar immersion media (e.g., air, oil).  However, there are situations where 

you will definitely not want to move between objectives automatically.  For instance, if you 

are using a water immersion objective on an upright microscope, where the objective is 

dipped into the chamber, trying to move the objective could break the chamber or damage 

the motorized turret. 

 

5.1.2.4 Stage Limits 

On certain microscopes with motorized z focus drives, stage limits are used to control the 

maximum and minimum position of the stage.  These limits prevent the microscope from 

being focused above or below certain z positions. The Stage Limits radio buttons are used 

to enable or disable this feature. 

 

5.1.2.5 Lamp 

On microscopes with a computer controlled lamp voltage adjustment, the intensity of the 

brightfield illumination can be controlled using this slider.  Moving the slider to the far left 

corresponds to turning the lamp off, while moving the button to the far right corresponds to 

turning the lamp to maximum intensity. 

 

5.1.2.6 Condenser 

On microscopes with an automated condenser turret, you may select condenser positions 

from the drop-down menu 

5.1.3 Z 

 

There are several possible ways to set up 3D capture using the Focus Window. These 

methods are explained in further detail in Chapter 7, 3D Capture on page 7-1. You must 

first choose the basis for your capture. You may define your capture based on the current z 

position, a selected reference position, or by defining the top and bottom of capture. 

Examples of using the Focus Window for 3D capture are as follows: 

 

 Current z position - Use the Focus Window to find a plane of interest (for example 

the focal plane), and then choose to range your capture around that position in the 

Capture dialog.  

 

 Define a reference position in the Focus Window, and then define a total range in 

microns or number of planes to capture in the Capture dialog. 
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 Define a top and bottom position in the Focus Window, and choose to use those 

positions in the Capture dialog. You may define the step size in either the Focus 

Window or the Capture dialog. 

 

The Z tab contains controls that let you make an interactive selection of a z axis range that 

can be imported into the capture window when performing 3D acquisition.  It is available 

on all systems that have motorized z focusing. 

 

 
 

NOTE:  You can also select a z axis range directly in the Capture dialog box (see 3D 

Capture on page 7-1).  The Z tab allows you to interactively define the 3D capture range 

and is generally used under circumstances where the precise z extent of the sample is 

unknown. 

 

5.1.3.1 Set Top, Set Bottom, Set Reference, Center 

The Set Top and Set Bottom buttons let you specify the end points of a 3D capture range.  

You can select these in either order.  For instance, suppose you have found a cell that you 

want to capture and are in the middle of the focus range. To set the boundaries of capture 

in the z direction, first move the stage (or nosepiece) up until the focal plane is at the top of 

the volume that you wish to capture.  This can be done either by repeatedly clicking on one 

of the ―up‖ buttons or by adjusting the fine focus of the microscope itself.  After you are 

finished, click on the Set Top button.  A number will appear above the Set Top button 

indicating that the top z position has been set.  Next, focus in the opposite direction until 

the focal plane is at the bottom of the volume of interest. Click on the Set Bottom button. 

Again, a number will appear below the Set Bottom button indicating that the bottom z 

position has been set. Once you have set a top and bottom position, you may select Go to 

return to either of those positions. In addition, SlideBook will calculate the Center position 

based on your top and bottom positions. You may select Go to return to the center position. 

 

You may also set a reference, or home, position. This reference position can be the point of 

best focus, or some other position that is of importance for your experiment. Once you set 

this reference position, it may be used for 3D capture. To set the reference position, press 

Set. This position will be saved until you reset the position or close SlideBook. 

 

NOTE: If you do not wish to continuously expose your sample while performing z focusing, 

you may set these ranges using single images generated in the Capture window. Please see 

3D Capture on page 7-1. 
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5.1.3.2 Slider 

Once top and bottom z positions have been selected, the slider to the left of the buttons 

provides the ability to move the z focus of the microscope to any position along the specified 

range.  This is useful for confirming that the specified region covers all of (and not 

significantly more than) the volume you wish to capture and provides a means of returning 

the z focus to the brightest part of the sample without altering the 3D capture range.  

When you later wish to find optimal exposure times that won‘t saturate the camera, it is 

best to be focused on the z position with the highest peak intensities. 

 

5.1.3.3 Capture Information 

Choosing top and bottom positions in the Focus Window to set the extent of z travel is only 

one part of setting up a 3D capture.  You also need to specify how many planes (discrete z 
focus positions) should be collected.  Typically, the most important consideration is the step 
size, as this governs the ultimate z axis resolution of the acquired image.  The step size (in 

microns) is specified in the corresponding edit box.  SlideBook suggests a z step size based 

on the theoretical resolution of the lens. The theoretical resolution is a function of 

wavelength of the chosen filter and numerical aperture. You may adjust this step size by 

entering a value in the Step Size edit field. Once top and bottom positions are defined, 

SlideBook will use the step size to compute how many planes must be acquired to cover the 

specified range.  At any point a different step size can be entered and the computed 

number of planes will be updated. Note that you can also specify the direction of travel of 

the stage (or nosepiece). The stage and objective should always travel toward each other.  

Thus, the direction of the arrow should normally point upwards. 

 

You may also choose to set either number of planes or the step size in the Capture dialog, 

as shown in 3D Capture on page 7-1. 

. 

5.1.4 XY 

If your system is equipped with a motorized xy (and z) stage, the XY tab lets you specify, 

store and visit multiple xy (or xyz) locations.  These points can be used for visiting multiple 

locations of interest in a sample and returning to them later as well as for specifying a 

sequence of locations to repeatedly visit during time lapse acquisition. 

 

  
 

 Set Point - adds the current xyz location to the list 



Chapter 5 – Controlling the Camera and Microscope Hardware (Focus Window)  

5-9 

 

 Clear Point - removes the currently selected xyz location from the list 

 

 Visit Point - moves the stage (and z focus) to the selected xyz location 

 

 Clear All - removes all locations from the list 

 

 Reset All Z – updates the z positions in all points to the current z position 

 

 New Point Z  - updates the z position of the selected point to the current z 

position 

 

 Montage Extent - sets the boundaries that will be used to create a montage 

image.   

 

 Load – allows you to load a saved x,y,z point list 

 

 Save – allows you to save an x,y,z point list 

 

 Home – allows you to calibrate your x,y stage before loading a point list. 

 

Using these features in the context of preparing to capture an image is also discussed in 

Chapter 7- Advanced Capture on page 7-1. 

 

NOTE:  If your system has a motorized xy stage, but not motorized z focus, then the XY tab 

works the same way except with xy rather than xyz locations. 

 

5.1.5 Camera 

The Camera Tab lets you control various settings on the CCD camera as well as view a 

histogram of the pixel intensities for the image in the focus window. 

 

 
 

5.1.5.1 Histogram 

The histogram shows a plot of pixel intensities values for the focus window image.  Pixel 

intensity values are plotted on the x axis, while numbers of pixels at a given intensity are 



SlideBook 4.2 User Manual 

5-10 

plotted on the y axis.  In addition, the minimum, maximum and mean pixel intensity values 

are reported beneath the histogram.  This data is continuously updated when the camera is 

actively acquiring images. The histogram can be operated in two modes as shown in the 

Scale Image Display region of the window, Manual and Auto.  In manual mode, you may 

drag the red and green bars to set the min and max values that are displayed in the live 

image. You may also enter numbers in the Low and High edit fields. In auto mode, the live 

image will use the minimum and maximum intensity values of the live image to set the 

contrast in the image. Thus, if you increase the exposure time, the live image will update 

and automatically reset the contrast of the image to match the range of intensities in the 

live image. You also have the option to display the full dynamic range of the camera using 

the Show Full Dynamic Range checkbox. When this box is checked, the histogram will not 

show the minimum and maximum intensities of the image, but rather the minimum and 

maximum possible intensities based on your camera‘s readout.  

 

5.1.5.2 CCD Temp 

On systems with a camera that has electronic temperature readout, this field reports the 

current sensor temperature in degrees Celsius. 

 

5.1.5.3 Speed 

On cameras that support this adjustment, the CCD read-out speed can be adjusted using 

this drop-down menu. 

 

5.1.5.4 Gain 

On cameras that support this adjustment, the gain can be set using this drop-down menu. 

 

5.1.5.5 Intensification 

On cameras that support this adjustment, the intensification factor can be adjusted using 

the slider and edit field located below the speed menu. 

 

5.1.5.6 Parameters 

This drop-down menu allows for support of additional features on certain cameras. For 

instance, on Hamamatsu cameras, the parameters menu allows you to select the camera 

offset. 

 

5.1.5.7 Stream 

Selecting this button will bring up a window that allows you to perform streaming capture. 

This function allows you to capture directly to disk without any interaction with other 

hardware component, allowing you to run your camera as fast as possible. This option is 

available for Hamamatsu and Roper cameras. Please see page 5-12, How to Perform 

Streaming Capture for further explanation of this feature. 

 

5.1.5.8 Test Simultaneous Capture 

The Test Simultaneous Capture check box is used with systems capable of performing 

dual camera simultaneous capture. It is also available when SlideBook is configured with 

an image splitter such as the Optical Insights Dual View (see Defining Filters when using 

an Image Splitter on page 4-25 and Configuring an Image Splitter on page 4-8) This option 

is only available when multiple cameras or an image splitter have been configured in 
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SlideBook. When this box is checked, the focus window display will rapidly alternate 

between images from camera 1 and camera 2. 

 

5.2 Using the Focus Window 

The following general procedure describes how to use the focus window to focus on a 

sample. If the microscope that you are using is not automated, you will need to move the 

optics manually. Procedures for using more advanced features of the focus window are 

detailed in Chapter 7 - Advanced Capture. 

 

1. Open the Focus Window by either selecting Window > Focus Window or clicking 

on the focus window button in the toolbar . The Image Window will begin 

updating as soon as the Focus Window is opened. 

   

2. Choose the desired objective and magnification changer from the Scope tab. 

 

3. Choose the desired filter configuration from the Focus Controls below the Scope 

tab. 

 

4. Place the sample on the stage. 

 

5. Click on Open Fluor or Open Bright to open the desired lightpath. 

 

Next, you will need to bring the sample into focus. This may be accomplished by 

either viewing the sample through the eyepieces or viewing the sample in the 

focus window. If your microscope is equipped with a motorized emission light 

path, the image can be directed to the eyepieces or the camera using the Scope 

tab.  Moving the xy stage and changing the z focus can be accomplished by either 

using the manual controls on the microscope or the computer controls (see 

above). 

 

6. Using the slider, set the exposure time so that the image is not overexposed. 

 

7. Using the controls in the Focus Controls window (or joystick or manual 

controls), adjust the x and y position of the stage and z position of the stage or 

nosepiece to find and focus on an area of interest. 

 

TIP: If you double-click on an object in the image display, the xy stage will move 

so that the object is centered. 

 

8. Once the sample focus is satisfactory, you may wish to close the lightpath for 

light sensitive samples, and then close the focus window by pressing the X 

button in upper right corner. If desired, the Focus Window and Capture Window 

may be open simultaneously. 
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5.2.1 Snapping an Image 

You may find that you want to capture a single image as you are using the Focus Window. 

To do so, simply press Snap once you are happy with the image in the live view. The image 

will be stored into the open slide file. 

5.2.2 Closing the Fluorescence Shutter Automatically when Closing the Focus 

Window 

If you would like your fluorescence shutter to close automatically when you close the focus 

window, select Edit > Hardware Properties, then expand the Focus Window section. Click 

on ShutterUponClose. 

 

 

 

 

Set the value to Yes and then click on Apply Change. Click Close and then restart 

SlideBook.  
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5.2.3 Labeling the Ocular Photo Prism Positions 

You may also provide custom labels for the emission selection positions (ocular photo prism 

positions) that appear in the Scope tab of the focus window. To do so, select 

Edit>Hardware Properties, then expand the Focus Window section. Click on the Ocular 

Photo Prism Pos you wish to edit and enter the label in the edit field. 

 

 
 

Click Apply Change, Close, and restart SlideBook. 

5.2.4 How to Perform Streaming Capture  

The Streaming Capture function allows you to run your Hamamatsu or Roper camera at 

the fastest possible speed. There are limitations with Streaming Capture. When a camera 

is recording in this mode, you may only alter other hardware via the Focus Window. 

Streaming Capture does not work using the Capture dialog, so you may not perform 

automated multi-channel, 3D, 4D, multipoint or montage capture. This capture mode is 

ideal for rapid 2D timelapse capture. To run your camera in Streaming Capture mode: 

 

1. Open the Focus Window and select the Camera tab. 
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2. Select the Stream button. The following window will appear. 
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3. Your camera will continuously generate images with the exposure time that you 

have selected in the Focus Window. If desired, select the Number of frames to 

average from the drop-down list.  

 

4. To get maximal speed, uncheck the Enable Updates checkbox. You will no 

longer be able to view the image as it updates, but your camera will run at a 

higher speed. The speed gained by unchecking this box depends on your 

computer configuration. For instance, you will see a greater gain in speed on a 

single processor machine than a dual processor machine as the saving and 

updating processes run on separate threads on a dual processor machine. 

 

5. Press Record to save the captures to disk. Once you have pressed record, images 

will be saved to disk and the Record button will convert to Pause. To end the 

recording, press Stop. This will also stop the streaming update. To resume the 

streaming update, press Start. You will not be able to change camera settings 

while the camera is streaming. You must press Stop and make changes to 

camera settings, then press Start again. 

 

CAUTION: Recording at this speed will rapidly use computer disk space.  

 

Spool files are saved to the same folder as the SlideBook executable file with the 

naming scheme of ―Spoolxx_yy_zz.spl-0‖, where xx, yy, and zz are hours, minutes, 

and seconds of the time when recording began. 

 

6. Once you have finished performing your capture, click OK to close the dialog 

box. 





SlideBook 4.2 User Manual 

 6-1 6-1 

6 Image Capture and Import  

 

Image capture parameters are set in SlideBook‘s Capture window. In order to capture an 

image, you must first set your optics and bring your sample into view and focus using the 

Focus Window (please see Chapter 5 - Controlling the Camera and Microscope Hardware 

(Focus Window) on page 5-1). Next, you must set camera parameters such as binning, 

exposure time, and image extent, as described in this chapter. Once all of these parameters 

have been set, you may initiate capture. You may also choose to import an image created 

using another program. This chapter covers the following topics: 

 

 Selecting Channels and Setting Exposure Times 

 Selecting the Area to be Imaged 

 Entering Image Information and Optical Parameters before Capture 

 Capturing a 2D Image 

 Performing Auto-White Balance 

 Importing an Image 

 Getting and Editing Image Information after Capture 

 

Advanced topics such as 3D, timelapse, 4D, montage, and multipoint imaging are covered 

in Chapter 7 - Advanced Capture on page 7-1. 

 

6.1 Selecting Channels and Setting Exposure Times   

Exposure times are set by generating a series of test images for each channel that will be 

exposed.  If you are performing a transmitted light capture with a color camera or color 

LCD filter, you may wish to first perform an auto-whitebalance (see below). 

 

1. Once you have a sample in focus, open the Capture dialog by selecting Image > 

Capture… or by selecting the Capture icon in the tool bar . Note that you 

must have a slide file open in order to open the Capture dialog. 

 

The dialog box that appears is divided into eight parts starting from the upper 

left corner:  capture settings, image extent and binning factor, multiplane 
capture, multipoint capture, exposure settings by channel, image histogram, 
optical parameters, and image info. The Capture dialog uses the same image 

view as the Focus Window. 
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2. First select the binning factor in the upper left drop-down menu. 

 

Binning lets you group several pixels together to increase sensitivity (at the cost 

of resolution).  For instance, selecting 2 x 2 binning effectively gives you a 

camera with half the horizontal and vertical resolution, but four times the 

sensitivity. Note that as you increase binning, you will need to reduce the 

exposure time. 

 

3. Select the desired Filter set from the drop-down menu. 

 

4. Click on the checkbox of the channel that you would like to expose. The channel 

that you select will be highlighted in blue. 
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5. Enter an exposure time, if desired, and press Test. 

 

Pressing the Test button for a particular filter configuration will give you a 

sample single-plane image at the specified exposure time for that channel. You 

may resize the image by dragging and dropping the corners or edges of the 

image. An intensity histogram and the minimum and maximum data values will 

be displayed in the Capture dialog in order to show you where in the dynamic 

range of the chip your exposure lies.   

 

Making a test image for each channel gives you the opportunity to choose the 

best exposure times (and of course make sure that the light is directed towards 

the CCD camera and not the eyepieces). 

 

6. Press the Once button in the Adjust Exposure section of the dialog and notice 

that the exposure time has been adjusted to take advantage of the CCD camera‘s 

full dynamic range. 

 

7. Press the Test button again to update the image in the test view. 

 

8. Repeat the test and adjust exposure process until the histogram shows an 

adequate intensity distribution (see note below).    

 

For multi-channel capture, simply repeat this process for each channel that you 

wish to expose.  For instance, a two channel capture using both the DAPI and 

the FITC filter configurations will appear as follows: 

  

   
 

NOTE:  The maximum value for a pixel depends on the bit depth of the camera.  For 

instance, on 12-bit cameras, the pixel values can range from 0 to 4095. In order to 

take advantage of the full dynamic range of the camera, it is important to try to get 

the maximum pixel value well into the four digit figures.  Pressing the Once button 

will automatically adjust the exposure time to try to achieve a maximum pixel value 

of about 3000.  In extremely dim samples, this may not be practical, but it is a good 
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target value.  Conversely, it is important for deconvolution that no pixel values are 

at the camera‘s maximum value, as that means that the image is overexposed and 

past the linear range of the CCD detector.  Pressing the Once button will reduce 

exposure times if necessary to try to reach a lower maximum value. 

 

6.2 Selecting the Area to be Imaged 

A typical camera contains a 1280 x 1024 pixel chip, but often you will want to capture from 

a smaller portion of the chip in order to reduce the memory required for capture and/or 

increase the camera frame rate. You may select the area to be imaged in two ways. 

 

6.2.1 Using the Image Extent Menu 

The image area can be selected using the features in the Image Extent and Binning section 

of the Capture window. 

 

1. Select the x- and y-extent of the image from the Width and Height drop down 

menus.  You may also manually enter the desired values in the edit field. 

 

 
 

You may select to add yellow guides in the test view that correspond to 256x256, 

512x512, and 1024x1024 pixels. By default, SlideBook reads from an area 

centered on the chip with the provided dimensions. To add the guides, you must 

select the Guides checkbox in the Focus Window. 
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2. If you want to move the region that is read to some other location on the chip, 

enter offset values for both the x- and the y-axes in the X Offset and Y Offset 

fields.   

 

3. Select Test to update the Image Window so that it has the desired size. 

 

6.2.2 Using the Test View 

Alternatively, you may choose a region of the chip to be imaged by directly selecting it from 

the Image Window. 

 

1. Be sure that the  button at the top of the window is depressed. 

 

2. Click and drag the mouse over the desired portion of the test view. 

 

3. Select Update to register the new image size. 

 

4. Select Test to update the Image Window to show the new image size. 

 

Clicking on the Full Chip button will automatically select the maximum extent of the 

camera.   

 

NOTE: After you have selected the area to be imaged, you may wish to adjust the exposure 

times using the Test and Once buttons to take advantage of the full dynamic range of the 

camera. 

 

6.3 Entering Image Information and Optical Parameters before Capture 

You may specify the following image information and optical parameters in the Capture 

window.  

 

 Image Name and Comments – can be entered in edit fields 

 Objective and Mag. Changer - can be selected (or will automatically be selected if 

they are either encoded or automated) using the drop-down lists 

 

The channels to be captured and their exposure times are automatically stored with the 

image. Although these settings don‘t immediately affect the microscope settings or capture, 

they are stored with the image and are important for correct deconvolution and 

measurement. 

 

You can always go back and add or alter this information by selecting Image > Get Info, 

which is described in the section Getting and Editing Image Information After Capture on 

page 6-13.  
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6.4 Capturing a Single or Multi-Channel 2D Image 

The default mode of the capture window is for a single 2D image. The 2D image may be 

either single or multi-channel depending on the number of channels that you have checked. 

If you wish to capture 3D, timelapse, 4D, multipoint, or montage images, please see 

Chapter 7 - Advanced Capture. 

 

1. Once you have set all of the parameters (channels, exposure times, binning, etc.) 

in the Capture Window, select OK to begin capture.  

 

If your system does not have automated filter control, you will be prompted to 

move the filters into the correct position before the image is captured. 

 

 
 

NOTE: If you see these prompts in error, you need to make sure that you do not have 

positions defined for hardware components that are not motorized. For example, if 

you have a filter (reflector) turret that is not motorized, make sure that your filter 

definitions are designated ―Unmounted‖ in the filter turret position .  

 

2. Move the hardware into position and click OK. 

 

The Image Window will show the image in color as it is being acquired. If you 

have more than one channel selected for capture, it will show a combined image. 

Thus if you have designated your DAPI and FITC filters to display as blue and 

green, respectively, the Image Window will first display the DAPI image in blue 

and then overlay the FITC image in green. In addition to the Image Window 

updates, the Capture Status window will become active and report the progress 

of your capture. 
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The default tab of the Capture Status window displays the current channel in 

monochrome. The features of the Capture Status window are best utilized when 

performing timelapse imaging and are discussed in Timelapse Capture on page 

7-8.  

 

6.5 Performing Auto-White Balance for Color Capture 

If you are performing a color capture with an LCD filter, you may first wish to perform a 

white balance procedure (you must first define your filters as discussed on page 4-21). This 

will yield the truest color rendering. To do so: 

 

1. In the focus window, find a clear portion of your slide. Alternatively, use a piece 

of white lens paper. 

 

2. Make sure that the halogen lamp is set to 3200K and that you microscope is set 

for Koehler Illumination. 

 

3. Select the green filter and check that your exposure time is at least 25 msec (this 

yields the best white balance results). If you are saturating the camera at 25 

msec, you should use neutral density filters. 
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4. Once you have achieved an adequate exposure time, go to Image>Capture… or 

select the Image Capture icon  . 

 

5. Select the Color channel checkbox and then Test. 

 

6. Select the area to be imaged and binning if desired. 

 

7. Adjust the exposure time as described above. 

 

8. Select the area of the test view that you would like to use for performing white 

balance by clicking and dragging over the region.  

 

9. Select White Balance from the radio buttons and then click Update.  

 

 
 

10. A white balance operation is performed and a dialog box similar to the following 

will appear. 

 

 
 

NOTE: If you are getting inconsistent color maximums when performing capture 

and the RGB factors are varying significantly each time you perform a white 

balance, then you should adjust your illumination.  Bright, dim or inconsistent 

lighting may cause this phenomenon. 

 

 

11. Select OK to close the dialog box. 

 

12. You may now capture an image by selecting OK in the Capture Window. 

 

The white balance settings will remain in the system memory until the slide file 

is closed.  

 

13. If you would like to manually enter white balance settings, go to Edit>Define 

Optics>Filter Configurations… and select the Red filter definition for an LCD 

filter, or to the Color camera filter definition. 
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14. In the default Color Display section, select the Settings… button. The following 

dialog box will be displayed: 

 

 
 

15. Enter the white balance gain factors. In general, the green factor will be the 

largest. 

 

16. Click OK to save the settings. 

 

6.6 Importing an Image 

You may also use SlideBook to display and analyze images captured using other programs. 

The following file types are supported by SlideBook: 

 

 SlideBook Spool (*.spl) 

 TIFF 

 TIFF Sequence  

 

SlideBook Spool is the file type used when capturing images to disk. Please see Saving 

Images to Disk (Spooled Capture) on page 7-38. 

 

NOTE: In order to import a sequence of TIFF images, it must be named with the format 

filename.#.TIF where # designates the plane number.  

 

6.6.1 Importing SlideBook Spool Files 

To import a SlideBook Spool file: 

 

1. Select the destination for import by either opening a new slide or opening an 

existing slide file. You may do this by selecting File>New Slide or File>Open 

Slide... If the slide is already open, make it the active window by clicking on it. 

 

2. To import an image, select Image>Import>SlideBook Spool.. The following 

dialog will appear. 
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3. Navigate to the desired spool file and select Open. The Load Spool File dialog 

will appear.  

 

 
 

4. Select the time points that you wish to load and select Load. A Main View of the 

selected time points will appear. 

 

6.6.2 Importing TIFF Files 

To import individual TIFF files or TIFF sequences: 
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1. Select the destination for import by either opening a new slide or opening an 

existing slide file. You may do this by selecting File>New Slide or File>Open 

Slide... If the slide is already open, make it the active window by clicking on it. 

 

2. To import an image, select Image>Import and select the file type that you wish 

to import.  

 

If there are already images in your slide file, the following dialog box will appear 

for TIFF files: 

 

 
 

If you have selected TIFF Sequence, or there are no images in your slide file, the 

above dialog box will not appear and you will be directed to the following dialog 

box. 

 

3. Select whether you would like to import the file as a new image or as a new 

channel in the current image, and click OK. The following dialog box will appear: 

 

 
 

 

4. Navigate to the file and select Open. The following dialog box will appear. If you 

have selected TIFF sequence, proceed to step 6.  
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5. Select the planes you would like to import as well as the channels to be used for 

each color in the image.  

 

For example, if you have an image that displays FITC as green data, you will 

designate the green data as FITC in the drop-down menu.  

 

6. Select OK, and the following dialog box will appear.  

 

 



Chapter 6 - Image Capture and Import  

6-13 

 
 

7. Enter image information as outlined in the following section.  

 

8. Click OK after you have entered the information. The imported image will 

appear as a Main View. You may always go back and edit the image information 

by selecting Image > Get Info. 

 

6.7 Getting and Editing Image Information After Capture 

You can get information about an image after capture or import.  The Image Info dialog box 

gives you the name of the image, comments associated with the image, and the time and 

date of capture if the image was collected using a digital microscopy workstation (as 

opposed to imported).  It also gives you the optical settings as well as which filter 

configurations were used to collect each channel along with the exposure time. If you would 

like to add optical information to an imported image, you must first define the objective, 

magnification changer, and filter configurations as described in Chapter 4 - Configuring 

Your System. 

 

You may view and edit information as described below.  

6.7.1 Images that were captured in SlideBook 
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1. Open a Main View of the desired image by either double-clicking on the 

thumbnail in the slide file, or by clicking once on the thumbnail and then 

selecting View > New Main View.  

 

2. Select Image > Get Info. The following dialog box will appear. View and edit the 

Image Name and Comments fields as desired.  

 

 
 

3. Press the Edit Info… button if you wish to change any of the optical 

configuration or collection information. This brings up the following dialog box: 
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NOTE: If you open a SlideBook file that was created on another computer or with a 

different SlideBook preferences version, the filter and objective configurations will 

be displayed as Other. To prevent this, make sure that the SlideBook preferences 

match those that were used for capture. 

 

4. Select the Objective and Mag. Changer used during capture from the drop down 

menus. 

 

NOTE: If you have imported an image from another program, you must first enter 

the objective and magnification changer definitions as discussed in Chapter 4. Then 

you may select the proper objective and magnification changer from the drop down 

menus. 

 

5. Enter the Interplane Spacing for 3D images. 

 

6. Select the filter configurations from the drop down menus, and enter the 

exposure times for each channel. 

 

7. Select OK when you are finished. The data that you entered is saved with the 

image. 
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NOTE:  Even if you are working with 2D images, it is a good idea to provide a value for 

Interplane Spacing as this will be used in the no neighbors deconvolution algorithm for the 

theoretical spacing value.  That way, you will not have to change any values that appear in 

the deconvolution dialog box. As a guideline, you should use the approximate z resolution 

for the objective used. 

 

6.7.2 Imported Images 

You may also add information to images that are imported into SlideBook from other 

programs. 

 

1. Import the image as discussed above in Importing an Image  on page 6-8. 

 

2. Make sure that the objective definitions exist by selecting Edit > Define Optics 

> Objectives and looking at the available objectives in the drop-down list. If the 

objective is not available, add the objective definition as described on page 4-12 .  

 

3. If an optovar or relay lens was used, make sure that its definition exists by 

selecting Edit > Define Optics > Mag. Changers and looking at the available 

magnification changers in the drop-down list. If the magnification changer is not 

available, add the definition as described on page 4-26.  

 

4. Make sure that the filter definitions exist by selecting Edit > Define Optics > 

Filter Configurations and looking at the available filters in the drop-down list. 

If the filters are not available, add the filter definitions as described on page 4-

20.  

 

5. Open a Main View of the imported image by either double-clicking on the 

thumbnail in the slide file, or by clicking once on the thumbnail and then 

selecting View > New Main View.  

 

6. Follow steps 2-7 above for getting and editing info for images that were captured 

in SlideBook. You should also select the Capture Type for your imported 

image and make sure that the image information is accurate. 
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7 Advanced Capture 

SlideBook can automate many different types of capture. This chapter covers the following 

topics: 

 

 3D Capture 

 Timelapse Capture 

 4D Capture 

 Multipoint Capture 

 Montage Capture 

 Multiwell Capture 

 Simultaneous capture 

 Configuring Your Hardware for Speed 

 Auto Focus 

 Varying Capture Rates for Timelapse Capture (Sequence Feature) 

 Saving Images to Disk (Spooled Capture) 

 Saving Capture Parameters 

 

7.1 3D Capture 

Similarly to 2D capture, 3D capture is accomplished by setting microscope parameters in 

the Focus Window and then setting capture parameters in the Capture window. In order to 

perform 3D capture, your system must have motorized z control.  

 

There are two procedures for performing 3D capture. In Method 1, you will use the focus 

window both to bring the sample into view and to interactively set the capture extent in 

the z dimension. These z parameters will then be imported into the capture dialog box.  In 

Method 2, you will use the focus window to bring the sample into view and focus, but then 

set the z parameters in the capture dialog box. You may wish to use Method 2 if you 

already know the z range of capture. For example, if you are imaging an object that you 

know to be 30 m in height, you may bring the cell into focus and then capture 20 m above 

and below the plane of focus.  However, if you are unsure of the extent of the object of 

interest in the z dimension, you should use Method 1 since it allows the range of capture to 

be interactively defined. Both methods are outlined below: 

 

7.1.1 Method 1 

 

7.1.1.1 Setting Focus Window Parameters 

 

1. Open the Focus Window by either selecting Window > Focus Window or clicking 

on the focus window button in the toolbar . The current camera image will 

begin updating as soon as the Focus Window is opened. 

 

2. Select your objective, magnification changer, and filter configuration, and bring 

your sample into view and focus as discussed on page 5-11 in Chapter 5 -

Controlling the Camera and Microscope Hardware (Focus Window). 
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3. Click on the Z tab. 

 

 
 

 

4. Select the direction of capture in the Capture Parameters section of the Z tab. 

The arrows denote the direction of travel of the motorized component of the 

microscope, either the stage (upright microscope) or the nosepiece (inverted or 

fixed stage microscope). In general, the default direction will be the correct 

direction. 

 

Now, you will need to set the z limits for capture. 

 

5. Starting at the middle of the focus range, move the stage (or nosepiece) up until 

you are at the top of the volume that you wish to capture.  This can be 

accomplished either by repeatedly clicking on one of the ―up‖ arrow buttons or by 

manually adjusting the fine focus of the microscope. 

  

NOTE: When moving the Z position by computer control you may either use one 

of the fixed increment buttons (10, 1 or .1 micron steps) or manually enter a step 

size in the edit box. 

  

6. Click on the Set Top button.  SlideBook will save the current z position and 

display it above the Set Top button. 

 

7.  Focus in the opposite direction until you are at the bottom of the volume of 

interest.  

 

8. Click on the Set Bottom button.  SlideBook will save the current z position and 

display it below the Set Bottom button. 

 

9. Return to the point of best focus (the brightest plane) using the slider tab or 

microscope controls.  Returning to the brightest point in the sample is necessary 

so that the correct exposure times can later be defined in the capture window. 

 

10. Close the lightpath for light sensitive samples by choosing Close Fluor. 
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11. Enter the step size that you would like to use for capture in the Capture 

Parameters edit field. The number of planes that will be required to capture the 

entire z range will be calculated and displayed above the step size. 

 

Note: You may wish to alter the capture step size so that the size of the captured 

image is not excessive. Alternately, you may decrease the total distance traveled 

by resetting the top and bottom parameters. 

 

12. Close the focus window by pressing the Close button. 

 

7.1.1.2 Setting Capture Window Parameters 

 
1. Once you have set the z parameters in the Focus Window, open the Capture 

window by selecting Image > Capture… or by selecting the Capture icon in the 

tool bar .  

 

2. Select channels and set exposure times as described in the section Selecting 

Channels and Setting Exposure Times in Chapter 6 (page 6-1). 

 

NOTE: It is important that z parameter is set at the middle of the focus range 

(brightest) when setting exposure times so that the brightest planes are not 

overexposed. 

 

3. Select the area to be imaged as described in the section Selecting the Area to be 

Imaged in Chapter 6 (page 6-4) 
 

4. Enter image information and settings as described in the section Entering Image 

Information and Optical Parameters before Capture in Chapter 6 on page 6-5. 
 

5. Click on the 3D checkbox in the Multiplane Capture section. The radio buttons 

and edit fields in the 3D Capture section will become active. Note that default 

value of the # Planes field is one, signifying a single plane capture. 
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6. Import the z parameters that you set in the focus window by selecting the Use 

top and bottom positions radio button.  The # Planes field will display the 

number of planes to be captured (see dialog box below). The Spacing field 

determines how many microns the stage needs to move between planes.  The 

Offset field is not used with the method of setting 3D capture parameters. 

 

 
 

7. If you wish for your z focus position to return to the center of the volume once 

capture is completed, select the Return to center of volume after capture 

checkbox. 

 

8. Click OK to begin capture. The Capture Status dialog box will appear and 

display each plane as it is captured. You may choose to Pause, Cancel, or Stop 

your capture any time after it has started. 

 

 Pause – pauses the capture until you press Continue 

 Cancel – cancels capture and does not save any images 

 Stop – stops capture and saves a truncated image file 

 

7.1.1.3 Setting Capture Preferences to Open and Close Shutter during Capture 

If you are performing single channel 3D capture, the default fluorescence shutter action in 

SlideBook is to leave the shutter open during capture. If you would like the shutter to open 

and close after every capture, select the Advanced.. button in the Capture Parameters 

section of the Capture dialog box. Select the 2D/3D capture checkbox labeled Open and 

close shutter on single channel or simult 3D capture in the General tab.  The default 

action for multiple channel capture is to open and close the shutter after every capture.  
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7.1.2 Method 2 

Use this method if you already know the distance above and below the plane of focus or 

other reference position that you would like to capture. 

 

1. Bring your sample into view and focus by following steps 1-2 as described above 

in Method 1: Setting Focus Window Parameters. If desired, you may set another 

position of interest by pressing the Set button next to Reference. 

 

2. Set capture preferences as described above in Method 1: Setting Capture 

Preferences. 

 
3. Open the Capture window by selecting Image > Capture… or by selecting the 

Capture icon in the tool bar .  

 

4. Follow steps 2-5 as described above in Method 1: Setting Capture Window 

Parameters. If you have set a reference position, the dialog will appear as 

follows: 
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5. The edit fields that appear are described below. 

 

 Range – the total distance traveled in microns 

 

 Number of planes - The total number of z planes acquired during capture. 

 

 Step Size ( m) – Distance the stage (upright) or objective (inverted or fixed-

stage) must move between z planes. A positive number corresponds to the 

stage or objective moving up during capture, while a negative number 

corresponds to the stage or objective moving down during capture. 

 

 Offset ( m) – The distance above or below the current stage location that the 

stage or objective will move before starting image collection.  For example, on 

an inverted microscope, a positive number corresponds to the stage moving 

up while a negative number corresponds with the stage moving down. Thus, 

on an inverted microscope, you will need to use a positive spacing and 

negative initial offset. 

 

If your sample is already in focus, you may select the Use current position radio 

button and choose the Range around current checkbox and simply enter in the 

total range of travel (Range) and either the number of planes or the step size. 

The remaining capture parameters will be calculated for you. If you have set a 

reference position, you may choose to use the reference position as the basis for 

capture.  

 

6. If you would like your z focus to return to the current position or reference 

position after capture check the Return to current position or Return to 

reference position checkbox as appropriate. 

 

7. Click OK to begin capture. The Capture Status dialog box will appear and 

display each plane as it is captured. You may choose to pause, cancel, or stop 

your capture any time after it has started, as described above in Method 1. 

 

A comparison of these capture situations are shown in the figures below. 
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Top

Bottom

Center

(calculated from top

and bottom positions)

 
 

Fig. 7.1 Method 1 is accomplished by setting top and bottom positions in the Focus Window 

and then setting the capture window parameters as shown. 

 

Current 

position

Current 

position

 
 

Fig. 7.2 Method 2 can be accomplished using either the current position or a chosen 

reference position. This figure shows how capture is performed when using the current 

position of the z stage with the given capture window parameters.  
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Reference 

position
Reference 

position

Reference 

position

 
 

Fig. 7.3 This figure shows how Method 2 is performed when a reference position is selected 

in the Focus Window. Note that the offset is different for the two situations on the right. 

 

7.2 Timelapse Capture 

In order to perform timelapse capture, first bring a sample into view and focus as described 

in the Using the Focus Window section of Chapter 5 on page 5-11. Then, proceed as follows: 

7.2.1 Setting Capture Preferences 

Before beginning a timelapse capture, you may alter your capture preferences to do the 

following: 

 

 Change capture frequency for a single channel in a multi-channel timelapse 

capture 

 Open and close shutter between exposures for single channel capture 

 Change the rate of live updates (to increase capture speed) 

 Autofocus during capture 

 Change capture frequency 

 Save images to disk 

 

All of these options can be accessed in the Capture Preferences dialog. This dialog box is 

displayed when you select the Advanced… button in the Capture Settings portion of the 

Capture dialog. 

 

 
 



Chapter 7 - Advanced Capture 

7-9 

7.2.1.1 Performing Periodic Capture 

You may choose to capture a single channel at a slower rate than other channels when 

performing a multi-channel 2D timelapse capture. You may do so by bringing up the 

Capture Preferences dialog and selecting the Periodic tab. Select the check box, the 

channel that you would like to capture at a slower rate, and the frequency at which you 

would like to capture that channel. For example, a frequency of 5 indicates that you would 

like to capture a channel every 5th image. 

 

 
 

7.2.1.2 Opening and Closing Brightfield Shutter Between Exposures 

For fluorescence shuttering, please see the above section Setting Capture Preferences to 

Open and Close Shutter during Capture on page 7-4. If you are performing 2D timelapse 

capture, the default fluorescence shutter action in SlideBook is to open and close the 

shutter if your timelapse interval is non-zero. If you have a 0ms timelapse interval, the 

shutter will remain open to allow you to capture as quickly as possible. This default 

behavior is designed to protect the sample at non-zero timelapse intervals, yet maximize 

acquisition speed at 0 ms timelapse intervals. Thus, the Open and close shutter on single 

channel or simult 3D capture checkbox is only applicable when you wish to shutter for 2D 

timelapse images with a timelapse interval of 0 msec. 

 

If you would like your brightfield shutter to close between transmitted light images:  

 

1. Select Edit>Hardware Properties… and expand the Advanced Capture 

Settings list. 
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2. Click on ShutterBrightFieldTimelapse. The right side of the dialog box will 

update. 
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3. Select Yes and then Apply Change. 

 

4. Select Close and then re-launch SlideBook to register the changes. 

 

7.2.1.3 Changing the Status Update Frequency 

You may change the frequency with which the elements in the Capture Status window are 

updated by choosing Advanced… in the Capture dialog box to bring up the Capture 

Preferences dialog and then entering the desired update frequency in the edit boxes in the 

General tab. An update frequency of ―3‖ would update the given element at the conclusion 

of every 3rd capture. Reducing the update frequency is primarily useful for increasing 

capture rate with single processor computers. 
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You may suppress all updates for optimal speed performance. To do so, select the 

Suppressed radio button. If When Possible is selected, updates will be provided when the 

computer processor allows. Some updates will be dropped in the interest of speed.  If 

Always is selected, each frame requested will be displayed (at the expense of speed).  

 

7.2.1.4 Autofocus During Capture 

Please see the section Auto Focus on page 7-27. 

 

7.2.1.5 Changing Capture Frequency 

Please see the section Varying Capture Rates During Timelapse Capture on page 7-33. 

 

7.2.1.6 Saving Images to Disk 

Please see the Saving Images to Disk (Spooled Capture) section on page 7-38. 

 

7.2.2 Setting Capture Window Parameters 

 

1. Open the Capture window by selecting Image > Capture… or by selecting the 

Capture icon in the tool bar .  
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2. Follow steps 2-4 in the above section 3D Capture: Setting Capture Window 

Parameters. 

 

3. Create any annotations that you would like to record during capture (see 

Creating Notes below). 

 

4. Check the Timelapse checkbox in the Multiplane Capture section of the Capture 

window. You now have the option to define a variety of timelapse parameters.  

Enter the desired values in the following fields: 

 

 
 

 # Time Points- The number of time points that will be captured. 

 

 Duration – the total length of time for the experiment. Units of time, in 

milliseconds (ms), seconds (s), minutes (m) or hours (h), can be selected from 

the drop-down menu. Due to the inability to predict time required for 

hardware movement, this option is only available when the interval for 

capture is over 30 seconds. 

 

 Interval- The delay between the beginning of one time point and the 

beginning of the next time point.  The interval unit can be selected from the 

drop-down menu.  If the capture sequence at one time point takes longer 

than the interval, SlideBook will capture the next time point immediately 

following the preceding time point. 

 

NOTE:  As you type in two of these values, the third field will be calculated 

automatically. 

 

 Renormalize to First Time Point- When checked, the minimum and 

maximum pixel intensity values for the first time point in a timelapse 

capture series will be used to determine the renormalization values of all 

subsequent time points.  This option only affects the image display during 

capture and will not affect the captured image.   

  

7.2.3 Creating Notes 

SlideBook allows you to record the exact time of experimentally relevant actions. To do 

this, you may either create notes prior to capture or during capture. These notes will then 

appear as buttons in the Capture Status window during capture. If you do not wish to 

create notes, proceed to the next section, Initiating and Monitoring Timelapse Capture.  
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1. To create annotations, first bring up the Capture Preferences dialog from the 

Capture dialog by clicking on the Advanced… button. 

 

2. Select the Edit Notes tab. The following dialog box will appear. 

 

 
 

You may specify up to eight notes. In the first field, specify the name as it will 

appear in the button.  There is a maximum of eight characters in this name.  In 

the second field, you can provide a more detailed description of the event, which 

will appear in the exported data.  

 

3. Click OK once you have entered the desired annotations. 

 

Once capture is initialized (by clicking OK in the Capture window), the notes 

will appear in the Capture Status window (see below). 

 

4. To record an event, simply click on the desired annotation button during 

capture. You can access notes from the Notes tab of the Capture Status dialog. 
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You may also add new notes at this point. You need not specify the notes before 

capture. 

 

 
 

NOTE: You can make multiple clicks during capture (even of the same event), 

but currently only one event can be recorded with any single time point. After 

capture, elapsed time and timelapse annotations can be displayed as a text 

overlay in the image by selecting View > Annotations > Timestamps.  In 

addition, these events are displayed next to the annotated time point when data 

is exported using Image > Export > Ratio/Timelapse data. 

 

7.2.4 Creating ROIs and Graphs to Monitor Regions of Interest 

Before beginning your capture, you may wish to create regions of interest in order to 

monitor intensities during capture as well as specify layouts for graphs. You may also do 

this during capture. To draw regions and layout graphs before capture, perform the 

following: 

 

1. Make sure that the Image Window is displaying an image. You can do this by 

pressing Test in the Capture Window. 
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2. Click on the ROI tool of interest. The ROI toolbar is at the top of the screen.  

 

  - Rectangle Tool, click and drag to draw a rectangle 

 

  - Ellipse Tool, click and drag to draw an ellipse 

 

  - Polygon Tool, click to draw a series of straight lines, double-click to 

close the shape 

 

  - Free Hand Tool, click and drag to draw freehand, release mouse button 

to close the shape 

 

  - ROI Selection Tool, use to select an ROI. Holding shift and clicking on 

multiple regions will allow you to select more than one region. Clicking and 

dragging on a selected region will move the selected ROIs. If the ROI 

number is displayed, this indicates that the ROI is selected. 

 

3. Continue to draw regions as desired. The following operations can be performed 

by selecting the ROI with the ROI selection tool, and then right-clicking to bring 

up the ROI menu. 

 

 Set as background – uses the selected ROI for background subtraction 

during graphing 

 

 Duplicate – creates a copy of the selected ROI 

 

 Delete – removes the selected ROI (s) 

 

4. Set up graphs by selecting Advanced.. in the Capture Dialog to bring up the 

Advanced Capture Parameters Dialog. 

 

5. Once you have created the desired regions of interest, select Continue to resume 

capture. 

 

The regions of interest that you have created can be displayed popst-capture as discussed 

in Displaying Annotations on page 8-24. To recreate the graph post-capture, please see 

page 10-31. 

 

7.2.5 Initiating and Monitoring Timelapse Capture 

In the Capture window, click OK to begin capture. The Capture Status dialog box will 

appear and display the current single channel image in the Status tab. The Image Window 

will show multi-channel captures, a combined image is displayed on the left. 
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7.2.5.1 Creating Graphs to Monitor Regions of Interest 

If you have created Regions of Interest, you may choose to display intensity graphs. To do 

so: 

 

1. Select the Channel that you wish to graph from the drop-down in Graph 

Channels and click Show. You may choose to display the graphs for multiple 

channels individually or by type. 
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2. Use the Zoom In and Zoom Out tools to explore your data. You may display or 

remove ROI data by checking or unchecking the ROI in the list. 

 

3. Once your capture is finished, your graph will remain open for viewing. 

 

4. To export your graph, simply select View > Export Tiff…. 

 

The regions of interest that you have created can be displayed as discussed in Displaying 

Annotations on page 8-24. To recreate the graph post-capture, please see page 10-31. 

 

7.2.5.2 Focusing During Capture 

You may adjust the focus of your image during capture. To do so, go to the Live tab. The 

Live view works similarly to the Focus Window.  

 

NOTE: Before using the Live tab, you must first select Pause. Once you are finished 

focusing, you must select Continue to resume capture. 

 

Channel menus

Zoom in

Zoom out

Reset time to full range

Zoom out

Zoom in

Reset intensity

to full range

Scroll bar

Channel menus

Zoom in

Zoom out

Reset time to full range

Zoom out

Zoom in

Reset intensity

to full range

Scroll bar
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The window has the following features: 

 

 Start/Stop – begins/ends the semi-live camera readout 

 

 Open Fluor/Close Fluor  - opens and closes the fluorescent shutter 

 

 Open Bright/Close Bright – opens and closes the transmitted light shutter 

 

 Filter – moves motorized filters into position when you select Go. 

 

 Z Stage – allows you to refocus your sample using precise movements. 

 

To use this window, press Start, open the desired shutter, select the appropriate filter, and 

focus your sample. When you are finished, close the shutter, press Stop, and then 

Continue. 

 

7.2.5.3 Viewing Previous Timepoints 

You may choose to view previously captured images while your 2D timelapse or 4D 

experiment is in progress.  To do so: 
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1. Set up your capture as you would normally in the Capture dialog box. Make sure 

that you are saving images to memory, or to memory and disk (see page 7-33). 

You can do this by selecting Advanced…  to bring up the Capture Preferences 

dialog. Then, select Spool and be sure that one of the first two radio buttons is 

selected. 

 

2. Once you have set up your capture, click OK. The Capture Status dialog box will 

appear. 

 

3. Select the Live tab. 

 

 
 

4. Select the Show button next to Captured Images and the following window will 

appear. 
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5. Use the slider to scroll through previously captured images, or enter a specific 

timepoint into the edit field and select Go. You may also use the + and – buttons 

to move one timepoint at a time.  

 

6. If you would like to view a single channel, select the Single Channel radio 

button and the desired channel from the drop-down list. 

 

7. Once you are finished viewing images, close the dialog box by clicking on the X 

in the upper right hand corner of the dialog box or selecting Hide from the Live 

tab. 

 

7.3 4D Capture 

SlideBook allows you to capture 3D images over time. To set up for 4D capture simply set 

up for 3D capture and timelapse capture as described in the above sections, then make 

sure that both the 3D and Timelapse checkboxes are selected in the capture window and 

the appropriate parameters are entered in the edit fields before selecting OK. The 

resulting slide file will contain a series of 3D images, one for each time point that was 

collected. 

 

NOTE: If you have specified a timelapse interval that is shorter than the time required to 

capture a single 3D stack, SlideBook will default to capturing 3D stacks as quickly as 

possible. 
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In addition to all of the options available for 2D timelapse imaging, SlideBook also allows 

you to perform mid-volume capture and sequential multi-channel z series, as discussed 

below. 

 

7.3.1 Shifting the Volume During 4D Imaging 

You may find that your sample exhibits focus drift during image acquisition. You may 

correct for this by selecting the Live tab during capture. To move your volume: 

 

1. Click on the Live tab and press Pause to pause the capture. 

 

2. Click Start to go into Live mode in the Image Window. Refocus your sample 

either manually or by using the Z Stage controls and select Recenter Z. You may 

also shift the whole 3D volume by checking the Shift 3D Volume 

 

 

7.3.2 Mid-volume Capture During 4D Imaging 

SlideBook offers the ability to capture up to three 2D mid-volume images during each time 

point of a 4D capture.  This feature is useful for acquiring channels that do not need to be 

imaged in three-dimensions (such as a DIC image) during a 4D capture.  To setup a 4D 

mid-volume capture: 
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1. Go to Capture Preferences dialog box by pressing the Advanced… button in the 

Capture window.  

 

2. Select the 4D tab from the capture preferences dialog box.  The following 

window will appear. 

 

 
 

 

3. Select the Capture midvolume plane checkbox.  This will activate the edit box to 

the right allowing you to specify the plane at which a midvolume image will be 

acquired.  The midvolume plane must fall within the plane limits of the 4D 

capture as specified in the Capture window. 

  

4. SlideBook defaults to capturing the midvolume plane during each 3D 

acquisition.  For instance, consider the case of a 4D capture with a 15 plane 

three-dimensional image being acquired at every time point.  If the midvolume 

capture plane is set to 10, SlideBook will acquire 10 planes of the 3D image, 

acquire the midplane channel and then acquire the remaining 5 planes of the 3D 

image.  To have SlideBook capture the midvolume image at the end of the 3D 

capture select the Capture midvolume plane at end of 3D acquisition  

checkbox.  When this option is selected, SlideBook will capture the entire 3D 

volume, return to the specified midvolume plane and then capture the selected 

channels. 
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5. Select the midvolume channels that will be captured at each time point during 

the 4D capture.  In the edit box to the right of each channel specify the exposure 

time that will be used to capture the channel.  Importantly, channels that will be 

captured at midvolume planes should not be selected for exposure in the 

Capture Window when setting up the 4D capture parameters. 

 

6. Click OK and then proceed to the Capture Window to set up for 4D capture as 

described above. 

 

7.3.3 Multi-Channel Z-Series 

In order to speed up capture, you may wish to capture multi-channel z stacks one channel 

at a time.  

 

1. Go to Capture Preferences dialog box by pressing the Advanced… button in the 

Capture window. 

 

2. Select the 4D tab from the capture preferences dialog box.  The lower half of the 

dialog box appears as follows: 

 

 
 

3. Select the desired capture order. If you would like to reduce the number of filter 

switches that occur during capture, select Capture one channel at a time for all 

z positions. 

 

4. Click OK and then proceed to the Capture Window to set up for 4D capture as 

described above. 

 

7.4 Multipoint Capture 

If your stage is equipped with a motorized xy stage, SlideBook allows you to select multiple 

locations to visit throughout the course of capture. You may perform timelapse and/or 3D 

capture at each location. As with the other types of capture, you will set parameters in the 

focus window and in the capture window. 
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7.4.1 Setting Capture Preferences 

Depending on the type of capture you plan to perform (2D timelapse, 3D or 4D), you may 

wish to select capture preferences such as periodic capture, midvolume capture, multi-

channel z options, autofocus and spooled capture as described in the sections above and 

below (see pages 7-9, 7-12, 7-4, 7-6, and 7-30). 

7.4.2 Setting Focus Window Parameters 

You may choose to select new points, or you may load points that you have saved 

previously. 

 

7.4.2.1 Setting Points 

 

1. Open the Focus Window by either selecting Window > Focus Window or clicking 

on the focus window button in the toolbar . The Image Window will open and 

begin updating as soon as the Focus Window is opened. 

 

2. Select your objective, magnification changer, and filter configuration, and bring 

your sample into view and focus as discussed in Chapter 5 - Controlling the 

Camera and Microscope Hardware (Focus Window) on page 5-1. 

 

3. To select a field to be visited during capture, first click on the XY tab. 

 

4. Choose Set Point to add a field of view to be visited during capture. The xy 

location coordinates will be added to the window of the XY tab.  

 

NOTE: If your system also has encoded z focusing, you may specify xyz 

coordinates. 

 

 
 

 

Once you have added a location to the list, you may remove, visit, or add 

locations. To perform these operations, first highlight the location by clicking on 

the coordinates in the list, then click on the appropriate button to perform the 

following actions: 

 

 

 Visit Point - moves the stage (and z focus) to the selected xyz location  
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 New Point Z – allows you to alter the z position of a given xyz location. 

This allows you to update the focus position of a certain sample if it has 

drifted. 

 

 Reset All Z – resets the z location on all points to the current z location 

 

 Clear Point - removes the selected location from the list 

 

 Clear All – clears all locations from the list 

 

 

5. Once you are satisfied with your list of locations, close the lightpath for light 

sensitive samples by choosing Close Fluor. 

 

6. Return to the brightest field that you are planning to capture by selecting the 

location from the list in the XY tab and choosing Visit Point. It is important that 

the brightest field is in view when setting exposure times in the Capture 

window. 

 

7. Close the focus window by pressing the Close button. 

 

7.4.2.2 Saving and Loading a Multipoint List 

This feature allows you to save the xyz multipoint list so that you may visit the same 

points in future experiments. To do so: 

 

1. Before placing your sample on the stage, open the Focus Window and go to the 

XY tab. 

 

 
 

2. Before setting points, you will need to home the stage. Some stages do not 

maintain an absolute coordinate system, but rather reset to zero at whatever 

position the stage is in when it is turned on. If it is your first time performing 

the home operation with the stage, make sure that your objectives are in the 

―load‖ position, as far from the stage as possible. Once you have all possible 

obstructions cleared, select Home…. If Home… is greyed out, you must 

manually home the stage by taking the stage to its limit at any of the four 

corners, then resetting your stage to zero (for instance, on an ASI stage, you 
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would take the stage to the limit, then turn the stage off and on to zero the 

stage). You must perform this procedure each time you plan to save or load a 

multipoint list. 

 

3. Once the stage is homed, place your sample on the stage and proceed with 

setting your point list. Once the list is complete, select Save… You will be 

prompted to enter a description for your point list. 

 

 
 

4. Enter a description and then select OK. 

 

Now that you have saved XY stage positions, you can load them for subsequent 

experiments. To load them, simply home the stage before loading your sample, then 

select Load… to populate the point list. 

 

7.4.3 Setting Capture Window Parameters 

 

1. Once you have set the appropriate parameters in the Focus Window, open the 

Capture window by selecting Image > Capture… or by selecting the Capture 

icon in the tool bar .  

 

2. Follow steps 2-4 in the above section 3D Capture: Setting Capture Window 

Parameters in order to select channels to be captured and set parameters for 

image extent and binning. 

 

3. Click on the Entire List radio button in the Multiple Point (XY) Capture section. 

Alternately, if you would only like to capture the current point, you may choose 

the Current Point radio button.  

 

If you wish to take a single image at each location, proceed to step 8. 

 

7.4.3.1 3D Multipoint Capture 

 

4. If you would like to capture 3D stacks at each location, set up for 3D capture as 

discussed in 3D Capture on page 7-1. 

 

5. Click on the 3D checkbox in the Multiplane Capture section.  
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7.4.3.2 Timelapse Multipoint Capture 

 

6. If you would like the points to be visited repeatedly, click on the Timelapse 

checkbox in the Multiplane Capture section of the Capture window. 

 

7. Enter the number of time points to be collected and the interval between capture 

in the appropriate edit fields. 

 

NOTE: In multipoint timelapse capture, the timelapse interval corresponds to 

the time that elapses between the completion of capture for the last point in the 

list and the beginning of the capture for the first point in the list. 

 

8. Click OK to begin capture. The Capture Status dialog box will appear and 

display each plane as it is captured.  You may choose to pause, cancel, or stop 

your capture any time after it has started. 

 

7.5 Montage Capture 

Often, you may wish to capture an image that is larger than a single field of view. 

SlideBook can stitch multiple fields together into what is called a montage image. It does 

this by taking successive camera fields and moving the motorized xy stage a computed 

amount. The procedure for capturing a montage image is described below. 

 

NOTE: Before attempting to perform montage capture, make sure your xy stage is properly 

configured as discussed in Configuring a Motorized XY Stage on page 4-5. 

 

7.5.1 Setting Focus Window Parameters 

 

1. Open the Focus Window by either selecting Window > Focus Window or clicking 

on the focus window button in the toolbar . The current camera image will 

begin updating as soon as the Focus Window is opened. 

 

2. Select your objective, magnification changer, and filter configuration, and bring 

your sample into view and focus as discussed in Chapter 5 - Controlling the 

Camera and Microscope Hardware (Focus Window) on page 5-1. 

 

3. The XY tab of the focus window has a panel of buttons that assist in selecting 

the range of the montage:  
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4. These buttons are used to define the boundaries of the entire region to be 

included in the montage image.  SlideBook needs enough coordinate information 

to generate an imaginary ―box‖ around the region to be imaged.  Thus, the extent 

of the montage image can be defined by selecting one of the following sets of 

coordinates: upper left/lower right, upper right/lower left, top/bottom/left/right.  

In the following example the upper left and lower right buttons are used to 

define the montage extent. 

 

5. Navigate to the upper left corner of the region that you want to image by either 

moving the stage controller‘s joystick or using the up, down, left, and right 

arrows that appear under the Focus Window‘s Scan tab. 

 

6. Click on the  button.  The x, y, and z coordinates of that position will appear 

in the XY tab‘s list of points with a UL designation next to it. 

 

7. Now, search for the lower right corner of the selection and click on the  

button.  The x, y, and z coordinates of that position will appear in the XY tab‘s 

list of points with a LR designation next to it. 

 

 
 

Selecting these two corners lets SlideBook automatically compute how many 

camera fields need to be captured in order to stitch together a montage image 
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that will cover the entire region.  When a montage extent has been successfully 

defined, the number of vertical and horizontal camera fields needed to cover the 

region will be displayed (in this case a 2x3 grid of 6 images).  If X axis? or Y 

axis? is displayed, SlideBook cannot compute a montage extent because the 

selected coordinates are not correctly orientated with respect to one another.  

For instance, Y axis? would be displayed if the selected lower right position is 

actually located above the selected upper left position. If you continue to see 

these errors, please check that your xy stage is configured properly (page 4-5). 

 

If you want to change the montage extent, you can simply go to a different 

location and click on one of the buttons again, as appropriate.  The previous 

coordinates will remain on the list of points, but the UL or LR designation will 

move to the new point. 

 

Once you have added the locations to the list, you may visit or adjust them. To 

perform these operations, first highlight the location by clicking on it and then 

click on the appropriate button to perform the following actions: 

 

 Visit Point - moves the stage (and z focus) to the selected location  

 

 Clear All – clears all locations from the list 

 

 Reset All Z – resets the z coordinate of all locations to the current z position. 

 

 New Point Z – resets the z coordinate of the selected location to the current z 

position. 

 

 

8. Once you have selected the upper left and lower right boundaries, close the 

lightpath for light sensitive samples by choosing Close Fluor. 

 

9. Close the focus window by pressing the Close button. 

 

7.5.2 Setting Capture Window Parameters 

 

1. Once you have set the boundaries of the montage image in the Focus Window, 

open the Capture window by selecting Image > Capture… or by selecting the 

Capture icon in the tool bar .  

 

2. Select channels and set exposure times as described in the section Selecting 

Channels and Setting Exposure Times in Chapter 6 on page 6-1. 

 

3. Enter image information and settings as described in the section Entering Image 

Information and Optical Parameters before Capture in Chapter 6 on page 6-5. 
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NOTE: It is critical to verify that the Objective and Mag. Changer fields under 

Optical Parameters are set correctly. SlideBook uses its knowledge of the size of 

the camera field at the current magnification to compute the number of images 

needed to span the montage extent. If your microscope has an automated 

objective nosepiece, SlideBook can read its position and the Objective field 

should already be set correctly.  If it has an automated magnification changer 

turret (or only a single magnification changer setting) then the Mag. Changer 

field should also be set correctly.  However, if your microscope has manual 

selection of objectives or more than one manually selected magnification 

changer, you must make sure the Objective and Mag. Changer fields are correct 

before proceeding.   

 

4. Click on the Import Montage button in the Multiple Point (XY) Capture section 

of the Capture dialog. The image extent is adjusted to reflect the montage extent 

in pixels. 

 

 
 

NOTE: If the Import Montage button is not enabled, a montage extent was not 

properly defined in the Focus Window. 

  

5. Click on the OK button to start the capture.  

 

SlideBook will return the xy stage to the upper left corner and begin its 

acquisition sequence.  The Capture Status dialog box will appear and display 

each plane as it is captured. You may choose to pause, cancel, or stop your 

capture any time after it has started. Once the capture is complete, the current 

slide will contain images of all of the fields that contributed to the montage.  To 

generate a montage image please see page 8-12, Displaying a Montage. 

7.6 MultiWell Capture 

Multi-well capture uses a different interface than other forms of capture. In this section, 

you will learn how to: 

 

 Create a Layout 

 Manipulate Hardware and Focus on the Sample 

 Calibrate the Stage Position 

 Select Wells for Capture 

 Initiate and Monitor Capture 

 

7.6.1 Creating a Layout 

In order to perform multi-well capture, you must first create a Layout, or template, that 

defines capture parameters. These layouts may be saved and applied for future captures. 

To create a layout: 
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1. Go to Image>Advanced Operations>Capture Multi-well Plate…. The Multi-

Well Capture dialog will appear. 

 

 
 

2. Go to the upper left corner and select New to generate a new Layout. The 

following dialog will appear. 
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3. Enter the Layout Name in the edit field. This layout will be saved so you may 

use it again for future experiments. 

 

4. Select the Microscope Components from the drop-down menus. 

 

5. Enter Plate Setup parameters by either entering numbers or using the up and 

down arrows. 

 

 X spacing, Yspacing – center-to-center distance in x and y directions in 

microns (can be determined by contacting the plate manufacturer; values 

show in above dialog box are typical for a standard 96-well plate 

 

 Well Diameter - can be determined by contacting the plate manufacturer 

 

 Calibration Row – row used for setting upper left corner (see below). For 

a 96 well plate, you can generally specify this to be 1. 

 

 Calibration Column – column used for setting upper right corner (see 

below). For a 96 well plate, you can generally specify this to be 12.  

 

6. Select the channels that you wish to capture by clicking in the appropriate 

checkboxes. You may choose to perform an autoexposure or you may set the 

exact exposure time.  

 

7. Select the type of capture that you wish to perform for each well as shown in the 

Capture Parameters section of the dialog. You have the following choices  
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 Images at the center of the well - you may choose the size of the grid, 

and you may generate a montage of the grid 

 

 Single center frame 

 

 Image pattern - for the predefined grid pattern, you may enter a 

separation value, which will allow you to sample at various points in the 

well. 

 

8. Select autofocus parameters. You may wish to determine these parameters first 

using the Focus Window (see Auto Focus on page 7-27.) 

 

9. Set stage parameters as defined below: 

 

 Neg Move Stage Right – move your stage so that the plate moves to the 

right. If the stage‘s x position values are decreasing, select the checkbox. 

Leave it unchecked if the values are increasing (Note: you can view these 

position values in the main capture dialog for multi-well capture) 

 

 Neg Move Stage Down – move your stage towards you (down if you are 

looking at the stage from above) and note the position values. If the stage‘s y 

position values are decreasing, select the checkbox. Leave it unchecked if the 

values are increasing. 

 

10. Click Save to exit the Layout dialog box. 

 

7.6.2 Manipulating Hardware, Focusing on the Sample 

Once you have determined your layout, you can interface with hardware in the Multi-Well 

Capture dialog. This works very similarly to the Focus Window. You can select filters, 

move x,y, and z positions, and open the fluorescence or transmitted light shutters. Before 

proceeding to the next section, make sure that your sample is in view and focus. 

 

7.6.3 Calibrate the Stage Positions 

 

1. Go to the well in the calibration row (as defined in your layout, generally row 1) 

and 1st column.  

 

2. Focus on the upper middle edge of the well and center it in the camera image 

(see picture below), and click Set UL.  

 

3. Go to Calibration Row and Calibration Column (generally row 1 or A, column 

12).  

 

4. Focus on the upper middle edge of the well as shown in the picture below, and 

click Set UR.  
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5. Go to last row (row H for a 96 well plate) and Calibration Column. Focus on the 

right middle edge of the well as shown in the picture below, click Set LR. 

UL

UR

LR

 
 

6. Test calibration by clicking on a well (it will turn white), and selecting Goto. 

 

7.6.4 Selecting Wells for Capture 

 

1. Select the wells you wish to image by clicking on the well and then clicking 

Select. If you wish to select multiple wells, first select a single well (it will be 

gold). Starting from the selected well, click and drag over the wells you want to 

image. The selected wells will turn gold. 

 

2. To unselect wells, click on the well that you don‘t want to image and press 

Unselect. To unselect multiple wells, first unselect a single well, then click and 

drag over the wells you wish to unselect. The unselected wells will turn gray. 

 

7.6.5 Initiating and Monitoring Capture 

To begin imaging, you will first make sure that the first well is in focus. 

 

1. Go to the first well that you will capture (by clicking on the first well and using 

the Goto command).  

 

2. Open the desired light path by clicking Open Fluor or Open Bright.  

 

3. Select the desired filter from the Filter Configuration section. 

 

4. Obtain focus on your sample in the camera view. 

 

5. If you would like to view images as they are captured, select the Live Picture 

during Capture checkbox. 
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6. Click Start to begin capture. 

 

7.7 Simultaneous capture  

SlideBook allows for simultaneous dual camera or image splitter operation for systems so 

equipped (see  

Configuring an Image Splitter on page 4-8 and Defining Filters when using an Image 

Splitter on page 4-25). Simply set up for the type of capture that you would like to perform 

as described in the sections above.  Before initiating capture, make sure that the 

Simultaneous Capture checkbox is selected in the Multiplane Capture section of the 

Capture Window.  

7.8 Configuring Your Hardware for Speed 

The following sections describe how to get the best speed performance when performing 

timelapse imaging.  In addition, to get best speed performance, you may wish to change the 

frequency of image and histogram updates during capture (see page 7-11). 

7.8.1 Roper Cameras 

If you feel that your camera is not running at appropriate speeds, go to the Camera tab in 

the Focus Window and make sure that the drop-down Speed menu is set to 0. Also, you 

may choose to set the clear cycle on the camera so that charge is not cleared from the chip 

before each image is captured. Charge accumulates between image captures, and the 

default action of SlideBook is to clear the accumulated charge before capturing an image. If 

you choose not to perform the clear action, the camera will run at a faster rate. However, 

the accuracy of the intensities measured will be reduced.  

 

To change the clear cycle setting, do the following: 

 

1. Select Edit > Hardware Properties…. 

 

2. Click on the + sign to expand the PVCAM section. 

 

3. Click on Clear Cycles and the right hand side of the dialog box will update. 
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4. Enter ―0‖ in the edit field and then Apply Change. 

 

5. Click Close and then restart SlideBook to register the change. 

 

6. Before performing an experiment, make sure to capture a test image 

immediately before beginning the experiment. This will help reduce the effect of 

charge build up in the first frame of the image capture. 

 

7.8.2 DG-4 

You may increase the switch time on your DG-4 by employing TTL control. You must 

purchase the TTL module for SlideBook to enable TTL control (contact sales@intelligent-

imaging.com if you do not own this module).  Note that in order to use TTL control, the 

exposure times of the various channels to be captured must be equal. Please see the 

SlideBook4.2TTLManual.pdf for details on configuring a system for TTL control. The 

TTL module for SlideBook includes software plus a NiDaq board and breakout box. 

 

mailto:sales@intelligent-imaging.com
mailto:sales@intelligent-imaging.com
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7.8.3 Z Stages 

There are delays that may be reduced in order to increase the speed performance of the 

Mad City Piezoelectric stage and the Polytech PI PiFOC Piezoelectric focusing collar.  The 

following adjustments allow the user to fine-tune the amount of time the software waits for 

a Z movement to complete. The appropriate delay depends on system configuration and 

experimental conditions. The following parameters must be set to give you the minimum 

possible delay to achieve maximum system performance. Real-world conditions may make 

it necessary to increase the delays to achieve scientifically acceptable results. Should you 

experience issues with image quality we recommend you reset these parameters to the 

default value. 

 

7.8.3.1 Mad City Piezoelectric Stage 

To increase the speed of this device, perform the following steps: 

 

1. Select Edit > Hardware Properties…. 
 

2. Click on the + sign to expand the section next to Advanced Z Stage Parameters.  
 

 
 

3. Click on StaticSerialMoveDelay and enter ―0‖ in the edit field on the right side 

of the dialog box. 
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4. Click on the + next to ASI Z Stage to expand the section. 

 

5. Click on Mad City Static Delay and the right hand side of the dialog box will 

update. 
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6. Enter the number ―1‖ in the edit field and then select Apply Change. 

 

7. Select Close and then restart SlideBook to register the change. 

 

You may find that you need to increase the delay above 0 msec in order to achieve 

scientifically acceptable results. 

 

7.8.3.2 PiFOC Piezoelectric Focusing Collar 

The PiFOC collar can be operated in TTL mode (see SlideBookTTLManual.pdf) or in 

serial mode. In order to operate in TTL mode, you must purchase the TTL module for 

SlideBook. You should perform the following procedure to increase speed in serial mode 

whether you are configured for TLL or serial mode. There may be instances where the TTL 

mode will not be activated, so you will need to increase the performance in serial mode. To 

increase the speed of this device in serial mode, perform the following steps: 

 

1. Select Edit > Hardware Properties…. 
 

2. Click on the + sign to expand the section next to Advanced Z Stage Parameters.  
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3. Click on StaticSerialMoveDelay and enter ―0‖ in the edit field on the right side 

of the dialog box. 
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4. Click on the + next to Polytech PI to expand the section. 
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5. Click on ShortMoveSerialDelay 
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6. Enter the number ―0‖in the edit field and then select Apply Change. 

 

7. Click on EnableLongDelay, the right side of the dialog will update. 
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8. Select Yes and then Apply Change. 

 

9. Select Close and then restart SlideBook to register the change. 

 

You may find that you need to increase the delay above 0 msec in order to achieve 

scientifically acceptable results. 

 

7.9 Auto Focus 

SlideBook offers the ability to perform an automatic focus routine during a 2D timelapse, a 

2D multipoint timelapse or a montage capture. As with the other types of capture, you will 

set parameters in the focus window and in the capture window.  The basic procedure for 

adding an auto focus routine to a multiplane capture is given below: 

 

7.9.1 Determining Auto Focus Parameters 

 

1. Open the Focus Window by either selecting Window > Focus Window or clicking 

on the focus window button in the toolbar .  

 

2. Select your objective and filter configuration then bring your sample into view as 

discussed in Chapter 5 - Controlling the Camera and Microscope Hardware 

(Focus Window) on page 5-1. 
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NOTE: It is critical that the Objective information is set correctly under 

Edit>Optical Parameters>Objectives. SlideBook uses its knowledge of the 

objective to compute the z spacing that it will use during auto focus.  If your 

microscope has an automated objective nosepiece, SlideBook can read its 

position; however, if your microscope has a manual objective turret you must 

make sure the proper Objective selected. To view objectives in the focus window 

on a manual microscope, go to Edit>Hardware Configuration and select Manual 

Objective Turret from the Objective Turret drop-down menu. 

 

3. Select the Auto Focus button from the Focus Window.   

 

 
 

4. The Auto Focus dialog box is used to determine the optimal auto focus 

parameters for your particular sample. 

 

 
  

5. Enter parameters into the edit boxes according to the following descriptions: 

 

 Method – The computational method used to evaluate and compare focal 

planes.  Changing the method can affect the success of the auto focus 
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routine.  The default method of Spectral 2D Template will work best 

in almost all cases.  The other methods are experimental. You should 

consult 3i if you are not having success with the default method. 

 

 Total Search Range – The total distance in the z dimension that will be 

searched during the auto focus routine starting from half the specified 

distance below the current z position.  SlideBook will automatically 

compute the number of planes to image based on the total search range 

and the calculated depth of field of the microscope objective.  This 

information is displayed below the Total Search Range edit box.  For 

instance, in the above example in order to span the 11 micron search 

distance with an objective that has a focal distance (FD) of 0.91 microns, 

a total of 12 planes will be imaged. 

 

 Post Focus Offset – A positive or negative offset distance that the z stage 

will be moved from the optimal focus position.  This feature is useful for 

always focusing a constant distance above or below the automatically 

determined focal plane. 

 

 Peak Delta Threshold – Used to determine when no optimal plane of 

focus should be computed from a particular image position.  When 

performing a montage capture, for example, some fields might not contain 

tissue and should not be used to change the current z position.  This 

value can range between 0.0 and 1.0, but should not be decreased below 

0.1 in most cases.  For captures where you know that each image in the 

sequence will have sufficient detail to focus, this threshold can be raised.  

If the value is set to 1.0 then the threshold will be ignored. 

 

 X-Y Threshold – Not currently used. 

 

 Exposure – The exposure time used for image capture during the auto 

focus routine.  This edit box will have the same value as the exposure 

time used in the focus window. 

 

 Save TIFFs – An advanced debugging feature that will generate a series 

of TIFF files in a numbered directory created in SlideBook program 

directory. 

 

 Save Logfile – An advanced debugging feature that creates an autofocus 

log file in the SlideBook program directory. 

 

6. Press the Auto focus button to initiate a single auto focus scan.  When finished, 

SlideBook will report the optimal focal z position in the Best Z information box 

and automatically move the z stage to this location.  In addition, timing 

statistics for the auto focus routine are given in the Total Time and Image Time 

information boxes.   
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NOTE: If SlideBook is unable to determine the optimal focal plane in the sample 

it will return one of two messages in the Best Z information box.  The No 

Gradient message indicates that SlideBook was unable to find a focal gradient 

within the specified search range.  In this case, the peak delta threshold used for 

auto focus computation may need to be increased or the search range may need 

to be increased.  The At Edge message indicates that the optimal focal plane lies 

above or below the specified search range.  Since SlideBook will automatically 

move the z stage to the best focal plane within the specified search range, simply 

running the auto focus routine again (starting from this new z position) will 

often find the optimal focal plane. 

 

7. Press the OK button in the auto focus dialog box. 

 

8. Use the focus window to evaluate the success of the auto focus routine.  Using 

the zoom button   to enlarge the image often aids in determining the best 

plane of focus (see page 5-2). Once an acceptable set of auto focus parameters 

has been determined, an auto focus routine can be added to the capture 

sequence. 

7.9.2 Adding Auto Focus to an Image Capture Sequence 

 

1. To include an auto focus routine in an image capture sequence go to Capture 

Preferences dialog box (via the Advanced.. button in the Capture dialog box) 

and select the Focus tab.  The following window will appear: 
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2. Select the Auto focus during timelapse/multipoint captures checkbox.  This will 

enable specification of several auto focus parameters. 

  

3. Enter the auto focus frequency for the image capture series in the Update focus 

every __ image captures edit box.  The auto focus routine will always be 

initiated before the first image of a capture series.  Specifying the auto focus 

frequency will determine at which subsequent time points an auto focus will 

occur.  For instance, setting a frequency of 2 would cause an auto focus to occur 

every other time point. 

 

NOTE: SlideBook keeps track of the optimal auto focus plane during the image 

capture series.  Thus, after an auto focus routine has determined an optimal 

focal plane, all subsequent images will be captured at this z position until 

another auto focus routine is initiated.  The z position of this new auto focus 

routine will be determined by the results of the previous auto focus. 

 

4. Select the channel that will be used for auto focus.  This should be the same 

channel that was used to test the auto focus parameters in the focus window. 

 

5. The Total Search Range, Post Focus Offset, and Peak Delta Threshold values 

will be automatically entered based on the auto focus parameters determined in 

the focus window.  If needed, these values can be further modified. 
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6. If the auto focus channel will be a captured channel during the image series, 

click the OK button and proceed with setting up the timelapse image capture 

parameters as described on page 7-8. Make sure to expose the auto focus 

channel in the image capture window and set an appropriate exposure time. 

SlideBook will use these capture parameters (image extent, bin factor and 

exposure time) when acquiring the image stack for auto focus computation.  

  

7. If you do not want to capture the auto focus channel, or you want to use a 

different image extent, bin factor or exposure time for auto focusing, select the 

Expose uncaptured auto focus channel checkbox. 

  

 
 

Enter the exposure time and bin factor for the uncaptured auto focus channel.  

These parameters will be used to determine image capture for the purposes of 

auto focusing.  Click the OK button and proceed with setting up the image 

capture.  Now the channel that is being used for auto focusing does not need to 

be exposed during the capture series. 

 

8. Selecting Expose uncaptured auto focus channel also provides the ability to 

specify a region of interest that will be used for auto focusing. This is useful for 

auto focusing on samples that have features with heterogeneous optimal focal 

planes. In this case, a full chip image extent can be captured at each time point 

while using only a small subregion to determine optimal focus.  Specifying an 

auto focus region of interest is done in the image capture window (Image> 

Capture). 

 
 

9. When the Expose uncaptured auto focus channel checkbox is selected in the 

Capture Preferences window, the Capture/Auto Focus pull down menu is active.  

This menu is used to alternate between designating the image extent for 

captured channels and the image extent for auto focus.  To define a subregion for 

auto focus, simply select Auto Focus from the pull down menu and specify a 

Width, Height, and Offset. Alternatively, draw a selection in the Test Capture 

image and press the Update button.  For more information on defining image 

subregions refer to the Selecting the Area to be Imaged section of Chapter 6 on 

page 6-4.  
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7.10 Varying Capture Rates During Timelapse Capture (Sequence Feature) 

You may choose to capture at various capture rates throughout your experiment when 

performing a multi-channel 2D or 3D timelapse capture. The capture rates may be changed 

either automatically in a preset protocol or manually during capture.  

 

7.10.1 Setting Capture Preferences 

To use this feature, you must first set up Capture Preferences. To do so: 

 

1. Open the Capture dialog (Image>Capture…) and press the Advanced... button.  

 

2. In the Capture Preferences dialog, select the Sequence tab. 

 

 
 

The elements of the dialog box are described below. A sequence is made up of a 

series of stages. Each stage may have a specified duration and timelapse 

interval (time between captures). 

 

 Begin capture with first event in sequence – if checked, capture will start with 

the first event in the sequence. 

 

 Loop to first stage when done – if checked, capture will return to first stage 

 

 Stages -  each stage will be automatically performed in the order they are 

displayed, from top to bottom 
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 Not in Sequence - these stages must be manually selected in the Capture Status 

dialog; they will not be performed automatically 

 

 Stage name - defined by the user 

 

 When complete - after the stage has been executed you have the following 

options: 

 

o Goto Next Stage - if a ―Not In Sequence‖ stage, will go back to default 

capture that is defined in the Capture window. 

o Return to Last Stage  - only available for ―Not In Sequence‖ stages 

 

 Capture Interval - the delay between the beginning of one time point and the 

beginning of the next time point. Units are milliseconds, seconds, minutes, and 

hours. 

  

 Duration of Stage - how long capture will occur at the defined rate. You may 

define the length as time points (e.g., 5 times), a time period (e.g., for 10 min), or 

continuous (ending when manually selecting the next stage) 

 

An example of a completed dialog box is shown below. 
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3. To add a stage, select Add. Enter the stage information described above. The 

stage will appear in the Stages frame. 

  

4. To add a stage that will be started manually in the Capture Status dialog, click 

on the Other Events frame to activate it. 

 

5. Add a stage as described in Step 3. The stage will appear in the Not In Sequence 

frame. You may use the > or < buttons to move events from the Stages frame to 

the Not In Sequence frame and vice versa. 

 

To change the sequence of stages, use the Up and Down buttons to move the 

stage in the list up or down one place. 

 

6. To remove a stage, select the stage from the list by clicking on the stage name 

and then clicking Remove. 

 

NOTE: The overall time points (duration) and the number of timepoints of all 

sequential stages is shown. 
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7. After you have set up your Sequence, press OK. If you have selected to perform 

an automated sequence, the appropriate parameters will be loaded into the 

Capture window.  

 

7.10.2 Setting Capture Window Parameters  

 

1. Open the Capture window by selecting Image > Capture… or by selecting the 

Capture icon in the tool bar .  

 

2. If it is not already checked, check the Timelapse checkbox in the Multiplane 

Capture section of the Capture window. You now have the option to define a 

variety of timelapse parameters.  Enter the desired values in the following 

fields: 

 

 # Time Points- The number of time points that will be captured. 

 

 Duration – the total length of time for the experiment. Units of time, in 

milliseconds (ms), seconds (s), minutes (m) or hours (h), can be selected from 

the drop-down menu 

 

 Interval- The delay between the beginning of one time point and the 

beginning of the next time point.  The interval unit can be selected from the 

drop-down menu.  If the capture sequence at one time point takes longer 

than the interval, SlideBook will capture the next time point immediately 

following the preceding time point. 

 

NOTE:  As you type in two of these values, the third field will be calculated 

automatically. 

 

  
 

3. To begin a capture click OK. The Capture Status dialog will appear. 

 

4. Click on the Sequences tab. 
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This tab has two frames, Stages and Not in Sequence. 

 

5. If you have opted to start a sequence at the beginning of capture, the first stage 

in the top frame will be marked with a ―*‖.  To manually execute a stage, select 

the stage by clicking on it in the list and then click on the Execute Stage button. 

The number of timepoints in the stage and the timelapse interval will be 

displayed at the bottom of the window. 

 

7.10.3 Examples for Variable Capture 

7.10.3.1 Example 1 

Suppose you have set up a stage with 22 timepoints and a 200 msec interval, and have 

checked the Begin capture with first stage in sequence checkbox in the Capture 

Preferences dialog. In the Capture window, you select a timelapse capture with 100 

timepoints, and a 1000ms interval. When you click OK, capture will start by executing the 

sequential events in the displayed order in the ―sequential event‖ frame. After the total 

sequence has been captured (22 time points) the remaining 78 time points (100-22=78) will 

be captured with the interval set in the multiplane capture dialog box (1000ms). 
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7.10.3.2 Example 2 

Suppose you have set up capture as in Example 1, but did not check the Begin capture 

with first stage in sequence checkbox. Capture will begin with 1000ms interval between 

time points. To execute the stage, click on the stage to be executed and click Exec Stage. 22 

timepoints will be captured. The remaining time points will be capture at 1000ms interval 

until the total of 100 time points have been performed. 

 

7.11 Saving Images to Disk (Spooled Capture) 

SlideBook allows you to save your images directly to disk. This is especially important 

when performing long timelapse captures that will exceed your computer‘s memory limit. 

To save images to disk: 

 

1. From the Capture window, select Advanced… to bring up the Capture 

Preferences dialog box. 

 

2. Select the Spool tab.  The following window will be displayed: 

 

 
 

2. Select the spool capture mode: 

 

 

 Capture images to memory only – images are saved in memory and only 

become permanent after capture if Save Slide is selected. 
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 Capture to memory and save to spool file after each time point – 

images are both kept in memory and saved to disk. This feature allows 

you to permanently save images as they are captured, and immediately 

view the images post-capture (no need to import a spool file). This is only 

useful for captures that are not larger than the memory available. 

 

 Capture to spool file after each time point only – images are saved 

directly to disk. In order to view the data, you must import a spool file 

(see below). 

 

3. Select the location for storage of spool files by selecting Browse and then 

navigating to the desired location. 

 

4. Click OK to save these preferences, and then set up for your desired capture 

sequence. Once your capture is finished, you may import it for viewing as 

discussed in the section Importing SlideBook Spool Files on page 6-9.  

 

WARNING: You MUST rename your spool file after capture.  The spool file will be 

overwritten when you restart SlideBook and perform a spooled capture. For multipoint 

timelapse capture, a single spool file will be saved for each location, named CaptureN-0.spl, 

CaptureN-1.spl, etc. Each of these files can be overwritten if you do not rename the file 

after capture.  

 

7.12 Saving Capture Parameters 

You can store and recall frequently used capture parameters. The following parameters 

can be saved: 

 

 Image extent 

 Binning 

 Capture type 

 Channels and exposure times 

 Camera intensification and gain settings (if applicable) 

 Capture Preferences (e.g., Periodic, 4D, Spool features) 

 

To do so: 

 

1. Begin a new capture by selecting Image>Capture…  The Capture dialog will 

appear. 

 

2. Select your capture parameters. To access advanced parameters such as periodic 

capture select the Advanced… button. The Capture Preferences dialog will 

appear. 
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3. Configure the desired preferences and select OK. 

 

4. To save these preferences, select Save As…from the Capture Settings drop-

down menu in the Capture dialog. If you choose Save, the Default parameters 

will be overwritten. 

 

 
 

The following dialog will appear. 

 

 
 

5. Enter a name for these preferences and select OK. 
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6. If you‘d like to load a different set of parameters, select one from the drop-down 

list. If you modify your capture parameters, the name of the currently loaded 

parameters will say ―(mod)‖ next to the name. You may choose to save them 

under the same name by selecting Save or under a different name by selecting 

Save As… as discussed above. 
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8 Image Display and Manipulation (Views) 

SlideBook stores images in slides and displays images using views. There are two kinds of 

views:  data views and display views.  Data views are interactive--the user can display any 

combination of different channels and masks as well as change lookup table parameters 

(renormalization) and edit the image‘s masks.  A new data view can be spawned either 

from the slide, or in one case, from another view.  Display views, on the other hand, are 

always spawned from a data view and are set to the channel, mask, and renormalization 

selections of that view.  Data views focus on interactive analysis, while display views focus 

on visualization.  

 

This chapter covers the following topics: 

 

 Introduction to Slide and Image Display in SlideBook 

 Using Data Views to Display Images 

 Manipulating Data Views Using the Info/Tool Bar 

 Using the Tool Menu 

 Using Display Views (Creating Renderings and Movies) 

 Exporting Views  

 

8.1 Introduction to Slide and Image Display in SlideBook 

When you start SlideBook a new slide called Slide1 is created, and unless you open 

another slide, it is into this slide that all new and imported images are inserted.  Typically 

a slide corresponds to all of the images taken from a particular sample.  

  

 

 
 

 

Each image in a slide is represented in a slide window as a thumbnail and some associated 

data.  The image may be either a single image or a set of images depending on the type of 

capture that was performed (e.g., 2D, 3D or timelapse). The thumbnail is either a shrunken 

rendering of the first plane of an image (the default) or of some portion of an image (if you 

have specified a particular thumbnail using the thumbnail button—see Changing the 

Default Display on page 8-23).  The information includes: 

 

 Image name - automatically generated in the case of captured images or 

corresponds to a file name in the case of imported images. 

 Comments – entered by the user either before or after capture (see Chapter 6 - 
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 Capture date and time 

 Capture type – 2D, 3D, 2D timelapse, or 4D 

 Number of channels – number of fluorophores  

 Dimensions – image size in pixels 

 Image size – image size in MB 

 Masks – number of masks stored with the image 

8.1.1 Working with Slides  

The Slide file is SlideBook‘s native document type. Opening, closing, and saving slide files 

is performed in a manner similar to other software programs.  

 

8.1.1.1 Saving Slides 

To save a newly created or updated slide: 

 

1. Click on the slide that you wish to save to make it the active slide. 

 

2. Select File>Save Slide.... If you have not previously saved the slide, you will be 

prompted for a file name. 

 

3. Enter a filename and select Save. 

 

To save a copy of a slide: 

 

1. Click on the slide that you wish to save to make it the active slide. 

 

2. Select File>Save Slide As....  

 

3. Navigate to the location where you would like to save the file, enter a filename, 

and select Save. 

 

8.1.1.2 Opening Slides 

To open an existing slide: 

 

1. Select File>Open Slide.. 

 

2. Navigate to the desired slide and select Open. 

 

8.1.1.3 Closing Slides 

To close a slide: 

 

1. Click on the slide that you wish to close to make it the active slide. 

 

2. Select File>Close Slide or click on the  in upper right corner. 
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8.1.1.4 Deleting Slides 

Slides can be deleted using standard Windows operations for deleting files. You may not 

delete a slide from within SlideBook; however, you may delete the images that are present 

in the slide. 

 

8.1.1.5 Changing the Slide View Display 

SlideBook offers several ways to view your Slide. To change your Slide View display, go to 

View>Slide View Display and select one of the following options: 

 

             
 

   Icons       List 

 

The default display is the Details display (shown at the beginning of the chapter). 

 

8.1.2 Working with Images 

As discussed above, each slide may contain several images. Using the same clipboard 

metaphor as other applications, SlideBook lets you remove images from a slide, duplicate 

images, and insert images.  You can cut or copy an image from one slide and insert it into 

another. There is currently no mechanism for multiple selection; you can only manipulate 

one image at a time.  

 

8.1.2.1 Selecting an Image 

Before performing any operations on a given image, it must first be selected, or made the 

active image. To make an image the active image, click on an image thumbnail in an active 

slide window (or anywhere in the box surrounding an image‘s information). 

 

The box around the selected image will turn green.  It is on the selected image that all data 

manipulation commands (such as deconvolution), mask creation commands, and image 

information commands will operate. 

 

8.1.2.2 Removing an Image from One Slide and Placing it in Another 

To move an image from one slide to another, do the following: 

 

1. Make the slide that contains the image that you would like to move the active 

slide by clicking on it. 

 

2. Make the image that you would like to move the selected image by clicking on it 

as discussed above. 
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3. Select Edit>Cut Image, or click on the Cut Image icon .  This will remove the 

image from the slide. 

 

4. Click on the slide that will hold the pasted image. 

 

5. Select Edit>Paste Image, or click on the Paste Image icon . 

 

NOTE:  Since the image is stored internally in a proprietary format, these operations do not 

use the Windows clipboard.  In other words, if you quit SlideBook without pasting a cut 

image, you will not be able to get to that image again. 

 

8.1.2.3 Copying an Image 

You may duplicate an image and place it in another slide, or in the same slide. It is often 

useful to copy an image before performing manipulations that affect the underlying data. 

 

1. Make the slide that contains the image that you would like to copy the active 

slide by clicking on it. 

 

2. Make the image that you would like to move the selected image by clicking on it 

as discussed above. 

 

3. Select Edit>Copy Image, or click on the Copy Image icon .   

 

4. Click on the slide that will hold the copy of the image. This may be the current 

slide, or another slide. 

 

5. Select Edit>Paste Image, or click on the Paste Image icon . 

 

CAUTION: When copying images into the same slide, it is very important to watch the total 

size of the slide.  

 

 

8.1.2.4 Deleting an Image 

To permanently remove an image: 

  

1. Make the slide that contains the image that you would like to delete the active 

slide by clicking on it. 

 

2. Make the image that you would like to delete the selected image by clicking on it 

as discussed above. 

 

3. Select Edit>Delete Image.  

 

CAUTION: This is a permanent removal that cannot be undone. 
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8.1.3 Image Display 

SlideBook contains four different kinds of data views:  the Main View, the Three View, the 

Tile View, and the Channel View. Data views may be used not only to look at data, but to 

generate statistics. Display views are strictly used for viewing data. The following display 

views are available: Volume View, Surface View, and Series Movies.  The displays that are 

most appropriate for different modes of imaging are shown in the table below. Note that 

single channel signifies an image containing a single fluorophore, while multi-channel 

signifies images containing more than one fluorophore. 

 

 
 

 

           Imaging 
Mode 
 
Data  View 

2D 3D 2D Timelapse 
4D (3D 

Timelapse) 
Single 

channel 

Multi- 

channel 

Single 

channel 

Multi- 

channel 

Single 

channel 

Multi- 

channel 

Single 

channel 

Multi- 

channel 

Main View         

Three View         

 Tile View         

Channel View        * 

Volume View         

Surface View         

Series movie    
    *  * 

* must make projection images to generate these views 

 

Next, we will discuss how to generate data views and manipulate those views using the 

info/tool bar. Finally, we will discuss display views. 
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8.2 Using Data Views to Display Images 

This section describes how to display data views. SlideBook allows multiple data views of a 

single image to be open simultaneously. 

8.2.1 Displaying a Main View 

The Main View can be used to display 2D, 3D, and timelapse data.  The Main View 

displays a single plane at a time where the ―invisible axis‖ can be either x, y or z for 3D 

data, and x, y, or t for timelapse data.  A 4D Main View is available for displaying x, y, z 

and t data. 

 

To generate a Main View: 

 

1. Choose File > Open Slide and navigate to the desired slide file. Double click on 

the slide file to open it. A slide window will appear. 

 

 

 
 

 

2. Double-click anywhere on the thumbnail or within the shaded region that 

surrounds the thumbnail.  

 

A new window will pop-up that contains the image. This window is a Main View 

of the image. 
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Alternatively, you may open a Main View using the View menu. To do this: 

 

1. Click once anywhere on the thumbnail or within the shaded region that 

surrounds the thumbnail to highlight the image.  

 

2. Choose View>New Main View to display a new Main View. 

 

To create a 4D Main View: 

 

1. Select an image in the 4D series by clicking on it. 

 

2. Select View> 4D View. A 4D Main View will appear. 

 

 
 

The 4D Main View operates similarly to Main Views for 3D and timelapse data. 

Additionally, there is a slider that you may click and drag to view individual 

time points of the 4D capture. You may scroll through the z axis by using the up 

and down arrow bars in the tool bar (see Scrolling through the Invisible Axis in a 

3D or Timelapse Image on page 8-22). 

 

8.2.2 Displaying a Three View 

The Three View is equivalent to three Main Views put together, one for each invisible axis. 

It is useful for exploring 3D and timelapse data. 

 

To open a Three View from an open slide: 

 

1. Click once anywhere on the thumbnail or within the shaded region that 

surrounds the thumbnail to highlight the image.  
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2. Choose View>New Three View to display a new Three View. 

 

 

 

 
 

NOTE: You may notice that your object may appear disproportionately small, or ―squashed‖ 

in the z direction. When performing 3D imaging, each plane that is captured is represented 

by a set of pixels in the image set. Each pixel is a perfect cube. You will notice that the z 
dimension in the 3D image set appears to be different than what was actually captured. 

This is because the z step size that was selected during capture is not actually the same as 

the length of the z dimension of the pixel. In the image set, planes are simply stacked on 

top of one another with no regard for the actual z distance traveled (this is done in order to 

save space). You may interpolate between planes and expand your z dimension to 

represent the actual z distance traveled by the microscope by generating an isotropic image 

(see page 9-14). 

8.2.3 Spawning a Tile View 

The  Tile View can display many planes simultaneously.  Both the  Tile View and the 

Three View are designed to enhance interaction with 3D and timelapse data.   

 

8.2.3.1 Displaying a  Tile View of an Entire Image 

 

From an open slide: 

x,y pane 

x,z (x,t) 
pane 

y,z (y,t) 
pane 
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1. Click once anywhere on the thumbnail or within the shaded region that 

surrounds the thumbnail to highlight the image.  

 

2. Choose View>New Tile View to display a new Tile View. 

 

 
 

 

8.2.3.2 Displaying a Tile View of a Portion of an Image 

The Tile View is slightly different than the main, three, and Channel Views in that it is 

tailored to display a portion of the image rather than the entire image.  Since the Tile View 

creates a pane for every plane that it displays, a  Tile View of the entire image will often be 

far larger than the size of the monitor, which defeats the  Tile View‘s purpose of allowing 

simultaneous viewing of multiple planes along the same axis.  So although a Tile View can 

be created directly from the slide window, you will more likely be making a 3D selection in 

either a Main View or a Three View (or even another Tile View) and spawning a Tile View 

from there. 

 

In order to spawn a Tile View from another view: 

 

1. Make the desired view the active window by clicking on it. 

 

2. Define a three dimensional selection.  There are several ways to do this, and 

they are discussed Making a 2D or 3D (x,y,z or x,y,t) Selection on page 8-29.  

 

3. Choose View>Tile View to display a new Tile View of the selected portion of the 

image.   

 

4. To change the portion of the image that is displayed, select the Hand tool from 

the Tool menu and click and drag in one of the panes (see table on page 8-27 for 

a description of this function). 

 

You can create a Tile View that shows slices along any of the three axes simply by making 

your selection in a view (or pane) that is currently set to the desired invisible axis (see 
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description of Axis Menu in the table below).  In other words, if you make a selection in a 

Main View that has an invisible y-axis, and the selection spans ten units in the y-axis, the 

resulting Tile View will have ten panes that display the x-axis horizontally and the z-axis 

vertically. 

 

8.2.3.3 Arranging your Tile View 

You may wish to change the way your Tile View is displayed. For instance, the default tile 

display may choose a 4x6 arrangement, while you desire a 6x4 arrangement. To alter these 

settings: 

 

1. With a Tile View displayed, select View>Advanced>Edit View Settings. The 

following dialog box will appear: 

 

 
 

2. Select the Specify Dimensions Manually checkbox, then enter the Tiles Per 

Row that you desire in the edit field. 

 

3. Click OK to update your Tile View. 

 

8.2.4 Displaying a Channel View 

The Channel View is most useful for displaying multi-channel images. The Channel View 

displays each channel independently in monochrome plus a composite RGB image. To 

display a Channel View from an open slide: 

 

1. Click once anywhere on the thumbnail or within the shaded region that 

surrounds the thumbnail to highlight the image.  
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2. Choose View>New Channel View to display a new Channel View. 

 

 
 

8.2.5 Working with 4D Data Views 

There are two views that allow for visualization and quantification of 4D data. They are 

the 4D Main View, and 4D Tile View. The first three views are discussed in the sections 

above. The 4D Tile View is discussed in the following section. 

 

8.2.5.1 4D Tile View 

You may also create a 4D Tile View. The 4D Tile View allows you to view a single z plane 

for all time points simultaneously. You may scroll through the z axis to select different z 

planes. As the 4D Tile View is similar to the Tile View, you may wish to choose a region 

before generating the 4D Tile View in order to improve viewing ability (see Making a 2D or 

3D (x,y,z or x,y,t) Selection on page 8-29). To create a 4D Tile View: 

 

1. Select an image in the 4D series by clicking on it. 

 

2. Select View>New 4D Tile View. A 4D Tile View will appear. 
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3. You may then alter the arrangement of tiles as discussed on page 8-10 , 

Arranging your Tile View. 

 

8.2.6 Displaying a Montage 

SlideBook allows you to generate montages from images captured in SlideBook using the 

montage feature (see page 7-10). To generate a montage: 

 

1. Open the slide that contains montage data. 

 

2. Select Image>Generate Montage. A dialog box similar to the following will 

appear. 

 

 
 

3. You may choose to manually align the images by choosing an image from list and 

then pressing any of the arrow buttons. Only the selected image will move. You 

may also hold down the shift key to move all of the images to the right and below 

the selected image. If you click on an image in the montage display, the 

appropriate image will be highlighted in the image list. Alternatively, you may 

choose to perform an auto-alignment by pressing the Auto Align key. 

 

4. Once you are satisfied with the alignment, select OK to close the dialog box and 

save your alignment settings. 

 

8.3 Manipulating Data Views Using the Info/Tool Bar 

Main, Three, Tile, and Channel views have, at the top, a set of buttons, menus, and 

readouts collectively called the info/tool bar.   
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x, y, z position

plane change

up/down arrows

tool menu

zoom factor

mask menu

axis menu

set default view

renormalize

red menu

green menu

blue menu

pixel values

by channel

bkgnd menu

(monocolor)

x, y, z position

plane change

up/down arrows

tool menu

zoom factor

mask menu

axis menu

set default view

renormalize

red menu

green menu

blue menu

pixel values

by channel

bkgnd menu

(monocolor)
 

 

The various features are described in the table below. 

 

Feature Function 

Pointer location (x,y,z) 
Shows and continuously updates x,y,z (3D images) or x,y,t (timelapse 
images) position of the mouse pointer. The location follows x,y,z (or t) 
order regardless of the invisible axis that is displayed. 

Zoom factor Displays the magnification, or zoom factor of the image 

Channel menus 
Allow the user to select the channels that correspond to R,G, and B or 
monochrome displays; default display corresponds with filter configuration 
definitions (Defining Filter Configurations on page 4-14)  

Pixel values 
Shows and continuously updates pixel intensity values corresponding to the 
mouse pointer location for a given channel 

Up and down buttons  

 
Main View: used to navigate through the invisible axis  
 
Three and Channel View: used to navigate the z- or t-axis   
 
4D Tile View: used to navigate z-axis  
 
Clicking once will move the displayed plane by one; holding continuously 
will scroll through the planes. Not used for 2D images. 
 

Tool menu  

Allows the user to choose the function that the mouse and its cursor 
perform, as described in the section Using the Tool Menu. This menu has 
different functions when a mask is displayed (see Chapter 10). 

Mask menu  

Allows the user to display a mask, or region of interest, as a blue overlay 
on the image. It is usually best to display image data in only red and green 
while displaying or editing masks. 
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Axis menu  

Allows the user to choose the invisible axis in Main Views of 3D and 

timelapse data, and in Tile Views of 4D data. The up and down buttons are 

tied to the invisible axis. 

Thumbnail button  

 
Allows the user to alter the default view of a particular image. Once the 
thumbnail button is selected, subsequent views and the slide thumbnail 
image will retain channel settings, renormalization information, and 
invisible axis plane. 
 

Renormalize button  
Allows the user to alter the look-up table, or renormalization parameters, 
for each channel of the view 

 

Now, we will explore several data view manipulations that require features of the info/tool  

bar. 

 

8.3.1 Altering the Renormalization Parameters (Look-up Table) 

You will often want to highlight a particular range of data values in an image.  Perhaps a 

particular feature is dim relative to other features, so you will want to saturate the 

mapping between the data and the display so that this feature will become more apparent.  

Or, perhaps in one channel you have a histological marker that might otherwise overpower 

the data and want to dim its contribution to the color values.  To alter the range of data 

that is displayed, you will choose the minimum and maximum data values that correspond 

to the absence or full saturation of the color associated with each channel.  You also have 

the ability to apply non-linear look-up tables to your view. 

 

8.3.1.1 Changing Renormalization Parameters for a Single View 

To alter renormalization parameters:  

 

1. Create a Main View, Three View, Tile View, or Channel View of an image. If 

you have several views open, make sure that the desired view is the active 

window by clicking on it. 

 

2. Click on the renormalize button  or select View>Renormalize. The 

Renormalize Image dialog box will appear. 
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A histogram is displayed showing the relative number of pixels on the y-axis and 

intensity values on the x-axis for the specified channel. The x-axis value shown 

on the left is the lowest data value across the entire image.  The x-axis value 

shown on the right is the highest data value. In the dialog box above, the DAPI 

channel intensities range from 182 to 1545. 

 

3. Select the channel that you wish to renormalize from the drop-down Channel 

menu. 

 

The red and green bars allow you to select the minimum and maximum 

intensities that correspond to the absence (black) or full saturation of color in 

the display. Thus, any data whose value is lower than the low bar will not 

appear in the view.  Any data whose value is above the high bar will show as 

fully saturated color.  The display‘s dynamic range, then, is a linear 

interpolation of the values in between.  

 

4. You may move the red and green bars and alter the display two ways.  

 

a. Click and drag the red and green bars in the histogram window to the left or 

right. The change will automatically register once you release the mouse 

button. 

 

OR 

 

b. Enter the desired minimum and maximum intensities in the Low and High 

edit fields and click on Apply to register the change and update the image. 

This gives you the opportunity to see the effect of the values and make 
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changes without closing and reopening the dialog. Choosing Close after 

entering intensities manually will close the dialog box without registering 

the change. 

 

Again, the underlying intensity values are not affected by the renormalization 

process. 

 

5. Follow steps 3 and 4 for any other channels that you wish to renormalize. 

 

6. Choose OK to exit the renormalization dialog box. If you would like subsequent 

views of the image to contain the same renormalization parameters, click on the 

Thumbnail button. 

 

NOTE: You can reset the low and high values for a single channel to correspond to the 

minimum and maximum intensities for that channel by pressing the Reset to Selection 

Min/Max button. You can also set all channels to the global min/max (the lowest and 

highest values of any channel present in the image) by pressing the Reset all to Image 

Min/Max. This is particularly useful when working with transmitted light color images. 

 

Remember that renormalization is a property of a particular view, not the entire image.  It 

is possible to have multiple views on the same image each with their own renormalization 

values.  If, however, you decide that a particular selection of values is best for most 

viewings of an image, you can press the thumbnail button in the corresponding view and 

make those values the default for that image (see Changing the Default Display on page 8-

23). 

 

8.3.1.2 Changing Renormalization Parameters for a Group of Images in a Slide 

You may apply the default renormalization parameters of an open view to all images in a 

slide by selecting Image>4D Operations>Renormalize All to Selected.  

 

NOTE: You MUST set the display as default using the thumbnail button before you apply 

the settings across the images in a slide. 

 

You may also set the renormalization to the global minimum and global maximum for each 

channel for all images in a slide. To do so, select Image>4D Operations>Renormalize All 

to Global Min/Max.  This function finds the lowest minimum and highest maximum pixel 

value for the group of images in the slide on a per channel basis, and then uses those 

values to set the renormalization of all images in the slide. 

 

8.3.1.3 Applying Non-Linear Look-up Tables 

SlideBook allows you to apply non-linear look-up tables using a gamma correction. This 

feature is particularly useful for emphasizing dim features in an image. To apply a non-

linear look-up table, simply click and drag the gray line that crosses the histogram 

diagonally. This adjusts the value of gamma. Alternatively, you may enter a value for 

gamma manually and select Apply.  If you wish to return the gamma to 1 (no gamma 

correction), simply click-and-drag the line off of the histogram and it will return to 1. 
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8.3.2 Changing the Display Colors 

Images may be displayed using a variety of color schemes, including RGB, monochrome, 

inverted monochrome, pseudocolor, and user-defined color. SlideBook also supports a 

mixed display that blends a monochrome background image (e.g., DIC) with an RGB image. 

The default display is determined by the filter configuration definitions (see Defining Filter 

Configurations on page 4-14), though you may easily change the colors that are displayed 

for a given view. Generally, the filter configurations will be set to R, G, or B. However, 

monochrome display may be useful for visualizing a single channel. Pseudocolor display 

may be useful for visualizing one or two channels. 

 

8.3.2.1 Changing the Channels Displayed on an RGB Image 

 

1. Make the desired view the active window by clicking on it. 

 

2. Select the fluorophore that you would like to display from the corresponding 

drop-down channel menu in the info/tool bar. 

 

NOTE: If your image is displayed as something other than RGB, you may change the 

display to RGB by choosing View>RGB Color. 

 

8.3.2.2 Changing an Image Display to Monochrome 

 

1. Make the desired view the active window (by clicking on it). 

 

2. Select View>Monochrome to change the display to monochrome. 
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3. Click on the channel menu, and select the fluorophore that you would like to 

display from the drop-down list 

 

8.3.2.3 Changing an Image Display to Pseudocolor 

 

1. Make the desired view the active window by clicking on it. 

 

2. Select View>Pseudocolor to change the display to pseudocolor.  

 

Two channel menus will be available. The first channel will be displayed as a 

pseudocolored image ranging from saturated red to saturated blue, known as 

Pseudocolor (Color). 

 

3. Click on the first channel menu, and select the fluorophore that you would like 

to display as Pseudocolor (Color) from the drop-down list. 

 

The second channel menu will act to gate the pseudocolor image based on 

intensity. This second channel is called Pseudocolor (intensity).  Thus, an area 

with a high pixel intensity for the first channel and a low pixel intensity on the 

second channel will appear as dim red. An area with a low pixel intensity for the 

first channel and a high pixel intensity on the second channel will appear as 

bright blue. 

 

4. If you would like to gate the first channel by the intensity of a second channel, 

select a second channel from the drop-down menu. 

 

8.3.2.4 Changing the Display to a User-Defined Color Palette 

You can now display up to eight channels in colors of your choosing. This is useful for 

applications such as FISH (Fluorescence In Situ Hybridization).  

 

To use this feature: 

 

1. Open a Main View, Three View, or Tile View. 

 

2. Select View>User-Defined Color. Your image will appear in the following 

format. All channels that were captured will be listed in the channel list. 
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3. To change the color of one of the channels, click on the colored box next to the 

channel whose color you would like to change. The following dialog box will 

appear. 

 

 
 

4. To change the color, either click on one of the Basic Colors in the upper left 

section of the dialog, or click on one of the Custom Colors in the lower left, or 

create your own color on the right side. If you would like to add a color to the 
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Custom Colors, use the color picker on the right to select a color, then select 

Add to Custom Colors. 

 

5. To add a channel to display, simply select the checkbox next to the channel. 

 

You may choose to always display a channel using a color of your choosing by specifying it 

in the Filter Definition (see page 4-18).  

 

8.3.2.5 Displaying a DIC image as Background of an RGB Image 

 

In an RGB image, the first three popup menus control which channel is visible in red, 

green, and blue respectively.  The last popup menu, labeled ―Bkgnd,‖ selects a background 

display channel.  In multi-channel images, one channel can be chosen to be displayed in 

monochrome wherever the other channels would not otherwise be visible.  This can be 

particularly useful for showing DIC information alongside fluorescence. To display DIC 

alongside a fluorescent RGB image: 

 

1. Create a Main View, Three View, Tile View or Channel View of an image that 

contains a DIC channel and at least one fluorescent channel. 

 

2. Make sure that the fluorescent channels are displayed as RGB. If they are not, 

select View>RGB Color to change the display to RGB, and select the 

fluorophores to be displayed from the channel menus. 

 

3. Set the Bkgd Channel menu to DIC.  

 

The DIC image will show through in any pixel that has RGB intensities that are 

below the minimum intensity threshold of the fluorescent channels. If you would 

like to increase the amount of DIC that shows through, you must raise the 

minimum intensity threshold on all of the RGB channels (See Altering the 

Renormalization Parameters (Look-up Table) on page 8-14). 

 

4. To change the display so that the DIC and fluorescent channels are blended at 

50% opacity, select View>Blend Background. You will not need to alter the 

minimum intensity threshold on the RGB channels to see DIC. 

8.3.3 Cropping an Image 

You may wish to crop an image in order to reduce its size or center on a specific portion of 

the image.  

 

CAUTION: Cropping is an irreversible process. You may wish to make a copy of the image 

before cropping (see Copying an Image on page 8-4) or select Crop to New Image. 

 

To crop an image: 

 

1. Open a main or Three View of the desired image. 
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2. Define a 2D or 3D selection as described in Making a 2D or 3D (x,y,z or x,y,t) 
Selection on page 8-29. 

 

3. Select Image>Crop… to replace the existing image, or Image>Crop to New 

Image to generate a new, cropped image.   

8.3.4 Rotating an Image 

You may wish to rotate a view of the image for publication purposes. 

 

CAUTION: Rotation is an irreversible process. You may wish to make a copy of the image 

before rotating (see Copying an Image on page 8-4). 

 

To rotate an image: 

 

1. Open a Main View of the desired image. 

 

2. Select Image>Rotate….  The following dialog box will appear: 

 

 
 

3. Select the Image Range as described below. You may also select and deselect 

images using the checkboxes in the Selected Images list. 

 

 Current Image- Operation will be performed on the selected image only. 

 

 Current Capture- Operation will be performed on all images that were 

acquired during a single capture series.  An example of a capture series is 

a 4D acquisition, where multiple 3D images are generated at each time 

point. 
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 Current Capture Type- Operation will be performed on all images in the 

slide with the same capture type (2D, 3D, 4D, etc.) as the selected image. 

 

 All Images with Same Channels- Operation will be performed on all 

images in the slide with the same channels as the selected image. 

 

4. Select the desired rotation angle and select OK. The image will be rotated as 

specified. 

 

8.3.5 Changing the Invisible Axis 

SlideBook allows for 3D and timelapse data to be viewed in all possible dimensions. By 

default, a Main View will display the x,y plane (invisible z-axis for 3D and t-axis for 

timelapse). However, you can change the invisible axis to the x- or y-axis if you wish. To 

view your image with a different invisible axis: 

 

1. Open a Main View of the desired image as discussed above. 

 

2. Click on the Axis Menu  in the info/tool bar and select the desired invisible 

axis from the drop-down menu. The up and down arrows in the info/tool bar will 

be tied to the new invisible axis. 

 

NOTE: The axis menu is not available in the Tile View or Channel View. If you would like 

to view a different invisible axis in the Tile View you should first open a Main View, 

change the invisible axis, make a 3D selection and then spawn a Tile View as described 

above (Displaying a Tile View of a Portion of an Image on page 8-9). 

 

8.3.6 Scrolling through the Invisible Axis in a 3D or Timelapse Image 

There are several ways to scroll through the invisible axis in Main Views, Channel Views, 

and 4D Tile Views. 

 

 Using the Up and Down arrows  in the info/tool bar: one click on either arrow will 

move one plane up or down; holding continuously will scroll. 

 

 Using menu commands: View>Prev Plane, View>Next Plane, View>Go to Plane… 

and View>Loop will move the invisible axis location one plane down, one plane up, 

to a specified plane, or in a continuous loop, respectively. See page 2-5 for 

instructions on how to use the Go to Plane... feature. 

 

NOTE: To scroll around Three View images, see the section titled Scrolling through a Three 

View on page 8-30. 
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8.3.7 Changing the Default Display  

Once you have an image that has the color scheme and renormalization parameters that 

you desire, you may save those parameters so that all subsequent views retain those 

parameters. To do so: 

 

1. Using a Main View, Three View, or Tile View, adjust the color display and 

renormalization parameters as described in the sections above. 

 

2. Click on the thumbnail button  in the info/tool bar to set new default display 

parameters. The thumbnail image in the slide view and all subsequent views 

will display the new default parameters. 

 

NOTE: When using a Main View, you may wish to scroll to a desired plane in the invisible 

axis before clicking on the thumbnail. The selected invisible axis plane will be displayed in 

subsequent Main Views. 

 

8.3.8 Displaying Annotations 

The following annotation features are available in SlideBook 4.2: 

 

 Timestamps – available for timelapse captures 

 Scale Bars  

 Lookup Tables – range of colors that correspond to intensities for a given 

channel 

 Notes – formerly called Annotations in previous SlideBook versions, can be used 

to record experimental actions (see Creating Notes on page 7-13) 

 Object IDs – corresponding to objects in a displayed mask 

 Regions – selections made using ROI tools. 

 

Timestamp

Scale bar

Lookup table

Object IDs
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8.3.8.1 Displaying Annotations 

To display any of these annotations on an open view: 

 

1. Open a Main View, Three View, or Channel View of your data.  

2. Select the item you wish to display from the View>Annotations menu. 

 

 
 

3. When an item is selected for display, a checkmark will appear next to the item on 

the menu. 

 

 
 

8.3.8.2 Formatting Annotations 

Several formatting options for annotations are available. Once you have displayed your 

annotations, you may format by doing the following:  

 

1. Open the Annotation Default Settings dialog by selecting 

View>Annotations>Settings…. The following dialog will appear. 
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2. Select the annotation that you would like to format. The dialog boxes for 

annotations are shown below. 

  

Scale Bars – You may define the length of the scale bar; choose color, placement 

and font; and include text or not. 

 

 
 

Lookup Tables – You may choose the size of the lookup table (as a percentage of the 

image width and height) as well as placement, text color and font. 
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Notes – You may choose placement, text color, or font. 

 

 
 

Object IDs – You may select text color and font. Note that object IDs only appear if 

you have a mask displayed that has been divided into objects. 
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8.4 Using the Tool Menu 

The Tool Menu of the info/tool bar allows the user to choose the function that the mouse 

and its cursor perform. 

tool menu

marquee tool

hand tool

zoom tool

ROI tools

ruler tool

angle tool

point selection

tool

ROI selection

tool

tool menu

marquee tool

hand tool

zoom tool

ROI tools

ruler tool

angle tool

point selection

tool

ROI selection

tool

 
 

 

The tool menu may also be accessed by selecting View>Tool. The various features are 

described in the table below. 
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Feature Function 

Marquee tool  

Lets you select a two- or three-dimensional region of the image and is used 
when spawning a Tile View or a volume rendering (Making a 2D or 3D (x,y,z 

or x,y,t) Selection on page 8-29). Can also be used to make masks (see 
Chapter 9) 

ROI Selection tool  

Lets you select an ROI in order to perform further operations. Holding shift 
allows you to select multiple ROIs. See Creating ROIs and Graphs to 
Monitor Regions of Interest on page 7-15 for more information on working 
with ROIs. This tool is also available from the menu bar 

Rectangle ROI tool  

Allows you to draw rectangular ROIs on an open view by clicking and 
dragging. This and all other ROI drawing tools are available at the top of 
the screen. 

Ellipse ROI tool  
Allows you to draw elliptical ROIs on an open view by clicking and 
dragging. 

Polygon ROI tool  
Allows you to draw closed polygons by clicking to draw a series of straight 
connected lines. Double-clicking closes the shape. 

Freehand ROI tool  
Allows you to draw freehand by clicking and holding.  Shapes close 
automatically when mouse button is released. 

Hand tool  

 

 
Main and Three Views: lets you move the displayed portion of an image in 
a window smaller than the dimensions of the displayed axes (performs the 
same function as the horizontal and vertical scroll bars).  
 
Tile View that displays a portion of an image: adjusts the position of the 
display cube within the image, therefore scrolling the portion of the image 
that is visible in all planes. 
 

Zoom tool   

 
Main and Three Views: grows or shrinks the size of the window and image 
by a factor of two.  
 
Tile View: the overall size of the window and its panes remains constant, 
but the zoom factor of the displayed image is adjusted by a factor of two. 
 
Clicking on a view will zoom in (double the size) and clicking while holding 
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down the shift key will zoom out (halve the size).   

Point selection tool  

 

 
Three View: updates the displayed position in the other two panes by 
clicking or dragging in any of the three panes.  Dragging over a pane will 
continuously update the other two panes.  
 
Main View: Ctrl-click on a region in a 2D timelapse image to display an 
intensity v. time graph. 
 
No function in Tile View or Channel View.  
 

Ruler tool  

 

Measures a desired distance in 2D and 3D images, and velocity in 2D 
timelapse images.  See Making Measurements with the Ruler Tool below.  

Angle tool  

 

Measures a desired angle in 2D and 3D images. Click to draw a single line, 
then make a second click at the angle you wish to measure. The angle 
measurement appears next to the zoom factor.  

 

Now, we will explore several data view manipulations that require features of the tool 

menu. 

8.4.1 Making a 2D or 3D (x,y,z or x,y,t) Selection  

As discussed above, the ability to make a 3D selection is useful when spawning a Tile 

View. You may also want to make a 3D (or 2D) selection in order to perform volume 

rendering (see page 8-32), crop an image (see page 8-20), or generate statistics for analysis 

(see page 10-5). 3D selections will be visible in all three panes of the Three View, and when 

scrolling through the invisible axis in the main and Channel Views. 

 

8.4.1.1 Making a 2D Selection in any Data View 

 

1. Select the Marquee tool   from the tool menu. This is the default tool in 

Main, Tile, and Channel Views. 

 

2. Click and drag to designate a 2D selection. 

 

 

There are three ways to make 3D selections. 3D selections may be for 3D volumes (x,y,z) or 

2D timelapse (x,y,t) images. One of the methods does not apply in Tile Views. 

 

8.4.1.2 Making a 3D Selection in a Main, Three, and Channel View  

 

1. Select the Marquee tool   from the tool menu. 
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2. Click and drag to designate a 2D selection, and continue to hold the mouse 

button down. 

 

3. Hold the shift key down while continuing to hold the mouse button and move the 

mouse up or down to move the display along the invisible axis. 

 

4. Release the shift key, and then the mouse button. 

 

 

8.4.1.3 Making a 3D Selection in any Data View 

 

1. Select the Marquee tool   from the tool menu. 

 

2. Click and drag to designate a 2D selection and release the mouse button 

 

3. Extend the 2D selection across the third dimension by 

 

a. Selecting View>Select Rect in all Planes…. This will extend the selection to 

all planes of the third dimension. 

 

OR 

 

b. Selecting View>Define Selection Cube… and entering the location range of 

the z or t planes that you would like to include in your selection. You must 

click OK to complete the selection. 

 

NOTE: You may also use the View>Define Selection Cube... menu selection to enter x, y, 

and z (or t) dimensions. The x and y dimensions are pixel locations, while the z and t 
dimensions are plane numbers. 

 

8.4.1.4 Selecting an Entire Image 

If you would like to return your selection to the entire image, simply select View>Select 

All. This will negate any previous selections. 

 

8.4.2 Scrolling through a Three View 

The point selection tool   allows you to easily maneuver around the Three View, and it 

is the default tool for the Three View. Click the point selection tool somewhere in the pane 

where z is the invisible axis (the x,y pane), and the x-axis (y,z) pane and y-axis (x,z) panes 

will scroll to the same coordinates that you selected in the z-axis pane.  Clicking and 

dragging around any of the panes will continuously update the other two panes. 

 

8.4.3 Making Distance or Velocity Measurements  

This tool can be used in any of the views to measure a desired distance (2D, 3D images) or 

velocity (2D timelapse images). In all cases, it is critical that both the optical parameters of 

the objective (um/pixel) are accurately defined (see Defining Objectives on page 4-12) and 
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the z or t interval is specified in the image info (see Getting and Editing Image Information 

After Capture on page 6-13). The ruler tool makes one measurement at a time, and each 

measurement replaces the previous measurement. In other words, the ruler tool is not 

used for permanent measurements, but it can be used to make scale bars or to make quick 

and easy measurements. 

 

8.4.3.1 Making a Measurement on a 2D Image 

This measurement can be made in any of the views. 

 

1. Select the Ruler Tool   from the Tool Menu. 

 

2. Click and hold the mouse button on the image at the point where you would like 

to begin measurement.  

 

3. Drag the mouse to the desired end point and release the mouse button. 

 

Alternatively, you may click and release once at the start point and click and 

release at the end point.  

 

The length of the line that you have just drawn will be displayed in microns in 

the Info/Tool Bar area. Note that these distances can not be saved to disk from 

within SlideBook. In order to perform measurements that are to be saved, see 

Chapter 10. 

 

4. To remove the line from the view, click once anywhere on the view. 

 

8.4.3.2 Making a Measurement on a 3D or 2D Timelapse Image 

 

1. Open a Three View of the desired image by clicking once on the thumbnail 

image, and then selecting View > New Three View. 

 

2. Click the mouse button on the image at the point where you would like to begin 

measurement. This point may be in any of the three panes. 

 

3. Click the mouse button on the image at the point where you would like to end 

measurement. Again, this point may be in any of the three panes. 

 

The length or velocity between the two points will be displayed in microns in the 

Info/Tool bar area. Note that these distances can not be saved to disk from 

within SlideBook. In order to perform measurements that are to be saved, see 

Chapter 10. 

 

4. To remove the line from the view, click once anywhere on the view. 

 

8.4.3.3 Making a Measurement on an Imported Image 

 

1. Import the image as discussed in Importing an Image on page 6-8. 
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2. Make sure that the objective definitions exist by selecting Edit > Define Optics 

> Objectives and looking at the available objectives in the drop-down list. If the 

objective is not available, add the objective definition as described on page 4-12. 

It is extremely important that the microns/pixel data field is reported 

accurately. 

 

3. If a magnification changer or relay lens was used, make sure that its definition 

exists by selecting Edit > Define Optics > Mag Changers and looking at the 

available magnification changers in the drop-down list. If the magnification 

changer is not available, add a new mag changer definition as described on page 

4-26. 

 

4. Add the objective and magnification changer information to the image by 

selecting Image > Get Info, pressing the Edit Info button, and then selecting the 

objective and magnification changer information from the drop-down menus. 

You will also want to select the capture type from the drop-down menu. 

 

5. Select OK to exit the Edit Image Info dialog box, then OK in the Image Info box 

to save the image information. 

 

6. Use the Ruler Tool as discussed above to perform distance and velocity 

measurements. 

 

8.4.3.4 Using the Ruler Tool to make a Scale Bar 

 

1. Open a Main View or Three View of the image. 

 

2. Select the Ruler Tool as discussed above to draw a line of the desired length, 

observing the distance reported in the Info/Tool bar. 

 

3. To preserve the line, export the view of the image as discussed below in 

Exporting Views on page 8-41. The scale bar will be present in the exported 

image. This image can then be further modified using a drawing program. 

 

8.5 Using Display Views (Creating Renderings and Movies) 

Besides data views, SlideBook can generate two types of movie displays, volume renderings 

and series movies. Both must be created from an open data view (main, three, tile, or 

Channel View) and will use the same color assignments and renormalization values as 

that data view. The volume rendering will be generated and displayed from within 

SlideBook, while the series movie must first be saved and then later viewed in QuickTime. 

The volume rendering can also be exported and viewed using QuickTime. 

8.5.1 Displaying a 3D or 4D Volume View (Volume Rendering) 

There are several styles of Volume Views. These Views can be used to explore 3D and 4D 

data sets. 
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 Dynamic Lighting (High Speed) – allows you to alter the direction of 

illumination. This mode is useful for determining surface characteristics. 

 

 Dynamic Lighting (High Quality) – similar to above, but uses a more rigorous 

shading algorithm to improve quality of the image at the expense of speed. This 

mode is useful for determining surface characteristics 

 

 
 

Dynamic Lighting 

 

 Fixed Lighting – uses a fixed lighting pattern for shading, approximates surface 

characteristics 

 

 

 
 

Fixed Lighting 

 

 Maximum Intensity Projection (MIP) - The brightest pixels through the axis 

perpendicular to the screen are displayed. This algorithm requires the least 

processing power and is particularly useful for rendering large data sets.  (does 

not require advanced graphics card) 
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MIP 

 

 X Ray – Similar to MIP; however, the sums of pixels through the axis 

perpendicular to the screen are displayed. This mode is useful when trying to 

visualize density or concentration differences. 

 

 

8.5.1.1 Working with 3D Volume Views 

To open a new 3D Volume View: 

 

1. Click once anywhere on the thumbnail or within the shaded region that 

surrounds the thumbnail to highlight the image.  

 

2. Select View>3D Volume View or View>4D Volume View and select either High 

Speed or High Quality (Fixed Lighting and MIP will be available with either 

menu choice). A new window will appear. 
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3-D Dynamic Lighting Volume View 

 

3. To change the channels that are displayed, use the Channel menus as your 

would for the Main View, Three View, or Tile View. 

 

4. To alter the shading, grab the Lighting Tool in the upper right hand corner  

and rotate it to achieve the desired lighting. 

5. To zoom into the view, click on the Zoom Tool   and then click and drag up 

and down in your view to zoom in and out. 

 

6. To rotate the image, click on the Rotate Tool   and then click and drag in the 

direction that you wish to move the image. You may either click and drag 

directly on the image or you on the coordinate image in the lower right hand 

corner. 

 

7. To move the image in the field of view, click on the Hand Tool icon   and then 

grab and move the image by clicking and dragging on it. 

 

8. To instantly reorient your image, you may choose to display a specific face of the 

volume by choosing the Axis Tool  and selecting Top, Bottom, Left, Right, 

Front, or Back. 

 

9. To select a different rendering mode, or to alter the colors displayed, select the 

Renormalization icon . The Volume View Settings window will appear.  
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NOTE:  The Volume View Settings window automatically opens when you open 

a 3D Volume View. 

 

 
 

Several features are offered in addition to the ability to renormalize the image 

(change the lookup tables). 

 

10. Alter the background color using the Background slider and change the 

brightness of the gridlines using the Gridlines slider. 

  

11. You may alter the opacity of an individual channel using the Opacity slider 

control.  

 

12. Select the rendering mode from the Style drop-down menu.  

 

13. You may also change the channels that are display just as you would in other 

standard views. 
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8.5.1.2 Working with 4D Volume Views 

The 4D Volume View has the same functions as the 3D Volume View plus a timepoint 

navigation feature. 

 

To display a 4D Volume View, click on a thumbnail in your slide and select View> 4D 

Volume View.  

 

Loop

Play

Move one timepoint

back/forward
Timepoint slider Playback speed slider

 
 

You may use any of the timepoint controls to move between timepoints or play the images 

like a movie. Other controls such as Rotate, Zoom, Hand, Axis, and Histogram function 

exactly as in the 3D Volume View. 

8.5.2 Displaying a 3D Surface View 

You may also display your image as a surface. To do so, click on a thumbnail in your slide 

and select View>3D Surface View.  A new window and corresponding renormalization 

dialog will appear. 
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This view functions very similarly to the 3D Volume View. The Rotate Tool, Hand Tool, 

Zoom Tool, Axis Tool, and Lighting Tool all function as described above in the section on 

3D Volume View.  The 3D Surface View Settings functions similarly to the Volume View 

Settings. To change the intensity at which the surface is drawn, slide the bar on channel 

histogram. 

 

 
 



Chapter 8 - Image Display and Manipulation (Views) 

8-39 

To display or remove surfaces, simply check or uncheck the appropriate channels in the 

Surfaces list. You may also change the color of the surface by selecting the color box for 

the corresponding channel. You may also change the width of the outline using the 

Outline Width slider bar. 

 

8.5.3 Generating a Physically Proportional Rendering of 3D Data 

You may notice that your object may appear disproportionately small, or ―squashed‖ in the 

z direction. When performing 3D imaging, each plane that is captured is represented 

by a set of pixels in the image set. Each pixel is a perfect cube. You will notice that the z 
dimension in the 3D rendering appears to be different than what was actually captured. 

This is because the z step size that was selected during capture is not actually the same as 

the length of the z dimension of the pixel. In the image set, planes are simply stacked on 

top of one another with no regard for the actual z distance traveled (this is done in order to 

save space).  

 

To generate a proportionate rendering: 

 

1. Open a data view (main, three, tile, or Channel View) of the image as discussed 

above. 

 

2. Alter the renormalization parameters and color display as desired (see above).  

 

3. Interpolate between planes and expand your z dimension to represent the actual 

z distance traveled by the microscope by generating an isotropic image (see page 

9-14). 

 

4. Create a Volume or Surface View as discussed in the sections on pages 8-32 and 

8-37. 

  

8.5.4 Creating Series Movies 

 

8.5.4.1 2D Timelapse Images 

Scans through time lapse images can be converted into QuickTime movies. To do so: 

 

1. Open a Main View of the image as discussed above. 

 

2. Alter the renormalization parameters and color display as desired (see pages 8-

14 and 8-17). You may also wish to crop the image (see page 8-20) 

 

3. Select View > Create Series Movie.  The Save As dialog box will appear. 

 

4. Enter a name for the movie and click OK. The Series Movie Properties dialog 

box will appear. 
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5. Enter the speed at which you would like the movie to play in the Frame 

Duration edit field. 0.2 seconds generally yields acceptable results. 

 

6. Click OK. The following dialog box will appear. 

 

 
 

7. Select the export format and quality that you prefer and then click OK. Lossless 

has the highest quality and the largest file size. The following dialog box will 

appear. 

 

 
 

8. Type in a filename and click Save and you are finished. 
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8.5.4.2 4D Images 

 

There are two ways to generate movies of 4D images. 

 

1. Make sure that your slide contains the 4D series only. 

2. Generate a series of projection images as discussed in Creating a Projection 

Image on page 9-14.  Be sure to select the For all images in slide checkbox. 

SlideBook will automatically generate a 2D Timelapse image from the series of 

projection images. 

 

3. You may now generate a series movie as discussed above in steps 3-7. 

 

OR 

 

1. Select individual z planes for each time point by scrolling to the desired z plane 

and selecting the thumbnail button. 

2. Select Image > 4D Operations>Generate Image from Best Planes in 4D 

Sequence. 

 

3. You may now generate a series movie as discussed above. 

8.6 Exporting Views 

Views may be exported as a variety of different file types. These images will be 8-bit for 

each color and should not be used for intensity analysis. However, an exported view may be 

loaded into Adobe Photoshop (or any other illustration program) or inserted directly into a 

word processor document.  

 

NOTE: If you would like to use the image in another analysis program for purposes of 

deriving intensity information, you will need to export the image as described on page   . 

8.6.1 Exporting a 2D view, Three-View, Channel View, or Tile View as a TIFF  

 

1. Open a Main View, Three View, Tile View, or Channel View of the image and 

adjust the look of the data as desired. This may include altering the color display 

and renormalization parameters or cropping the image. 

 

2. Select View > Export > TIFF to export the view as a single TIFF (.tif) file. 

 

3. Enter the file name and select Save.  The TIFF image can now be used in other 

programs. 

 

8.6.2 Exporting a 3D or 2D Timelapse View as a TIFF or TIFF Series 

Three-dimensional Main Views may be exported as a single TIFF file containing multiple-

planes or as a series of TIFF images. 
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1. Open a Main View of the image and adjust the look of the data as desired. 

 

2. Select View > Export > TIFF to export the view as a single TIFF (.tif) file or 

View > Export> All Planes as TIFF to export the view as a series of TIFF 

images (one image for each z or t plane). 

 

3. Enter the file name and select Save.  The TIFF image(s) can now be used in 

other programs. 

8.6.3 Exporting Default Views of All Images in a Slide 

SlideBook allows you to use a single command to export a series of tiff files, one for each 

image in the slide. Each TIFF file will be a single plane that has the same look as the 

thumbnail image (default view). To use this feature: 

 

1. Alter each image to the desired look as described in this chapter. This may 

include altering the color display and renormalization parameters or cropping 

the image. 

 

2. Select View>Export>Default Views of All Images as TIFFs…. 

 

3. Choose a directory for the files and select OK.  The TIFF images will be saved 

under the individual image names in the chosen directory and can be used in 

other programs. 

 

8.6.4 Exporting Volume View and Surface View Movies 

You may wish to export your volume or surface views so that they may be displayed in a 

presentation or online publication. You may export either as a QuickTime movie, or as a 

QTVR (QuickTime Volume Rendering) file. QTVR files can be rotated at arbitrary angles in 

QuickTime (available free at www.apple.com). To export your Volume or Surface View: 

 

1. Click on an open Volume or Surface View to make it the active view. 

 

2. Select View>Export>Movie…. The following dialog box will appear. 

 

 

http://www.apple.com/
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The dialog has the following sections: 

 

 Axis of Rotation Options – you may generate either QuickTime movies 

where your volume or surface rotates around a single axis (x, y, or z) or 

QTVR movies where you may rotate your volume as desired using 

QuickTime. 

 

o Start at current plot orientation – check this box if you want to start 

your movie with the view that is currently displayed. If left unchecked, 

the movie will begin with a view with surfaces at right angles to the 

selected axis.  

 

o Axis relative to screen – check this box if you‘d like the image to rotate 

around an axis relative to the screen. If left unchecked, the image will 

rotate around the image axis. 
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 Rotation Increment - enter the desired rotation increment in the data field. 

The rotation range that you selected is computed in the increments you 

provide.  Choosing a smaller increment increases the smoothness of the 

rotation and adds to the depth cue provided by moving the image.  Projection 

is an expensive computation, however, so choosing a larger increment will 

make the projection process faster.  To generate a single head-on projection 

of the entire image, choose 360. 

 

 Rotation Range – select 360 to rotate the data completely. You may select a 

smaller range if desired. 

 

 Show current timepoint only (disable animation) – available for 4D images 

only. Allows you to render a single timepoint to conserve time and memory. 

 

 Timelapse Options – select the timepoints you would like to render and how 

you would like your timelapse movie to proceed (either step through time as 

the object is rotating, or complete a rotation before proceeding to the next 

timepoint). 

 

 Movie Dimensions – allows you to change the dimensions of the movie 

 

o Keep Aspect Ratio – keeps the current height/width ratio 

o Scale – change the size of the movie with respect to the original image 

dimensions 

o Width/Height – manually enter the dimension you wish to export 

 

 Movie frames per second – adjust the speed of your movie 

 

3. Once you have selected the appropriate pararmeters, select Export. The 

following dialog box will appear. 
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9. Type in a filename and then choose the type of Export you wish to perform from 

the drop-down menu. We recommend Movie to AVI. If you wish to convert to a 

QuickTime Movie, continue to the next steps. If you wish to save as an AVI, click 

Save and you are finished. 

 

10. To save as a Quick Time movie, click on Options. The following dialog will 

appear: 
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11.  Click Settings. The following dialog box will appear. 

 

 
 

12. Drag the quality slider to Best, and select Motion JPEG A from the top drop-

down menu. 

 

13. Click OK to close the Compression Settings and Movie Settings dialog boxes, 

then click Save. 
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9 Preparing an Image for Analysis or Export 

 

Before performing statistical analysis on your images, you may wish to perform a variety of 

pre-processing operations. In this chapter, you will learn how to: 

 

 Manipulate Individual Channels 

 Crop an Image 

 Align an Image 

 Manipulate Timelapse Data 

 Perform Flat Field Correction 

 Perform PhotoBleach Correction 

 Perform Background Subtraction 

 Create a Projection Image 

 Create an Interpolated Image 

 Apply Filters 

 Perform Deconvolution 

 

9.1 Manipulating Individual Channels 

A channel denotes the image data collected for a specific fluorophore. SlideBook allows you 

to manipulate channels prior to performing quantitative analysis on your images. You may 

insert a channel from one image into another image, remove a channel, or create new 

channels using channel math. For timelapse images, you may also create a timelapse 

composite image. The timelapse composite channel adds the previous timepoints to each 

timepoint. Thus, timepoint 3 in a timelapse composite channel is the sum of timepoints 1,2, 

and 3. 

9.1.1 Inserting an Image as a Channel  

You may wish to insert an image containing a single channel, such as a background image, 

into another image that you have collected. To do this: 

 

1. Make sure that the image you would like to insert is in the same slide as the 

destination image (see Copying an Image on page 8-4).  

 

2. Select the destination image (the image that will contain the newly inserted 

image) by clicking on it. You may also start from an open view of the image. 

 

3. Select Image > Channel Operations > Insert Channel… The following dialog 

box will appear: 
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4. Select the image that you would like to insert as a channel from the drop-down 

menu. If the image that you select contains more than one channel, the channel 

that is listed as channel 1 (see Getting and Editing Image Information After 

Capture on page 6-13) will be the channel that is inserted. 

 

5. Select the x, y and z coordinate positions for insertion in the X Pos, Y Pos, and Z 

Pos edit fields. If left at 0, 0, 0, the single channel image will be inserted in the 

upper right hand corner of the image in the first plane (if the destination image 

has multiple planes). Images that are the same size will overlay exactly. 

 

6. Click OK to insert the channel. The new channel can now be selected from the 

channel menus in the info/tool bar and displayed in any view. The channel may 

also be selected when performing channel math (see Using Channel Math on 

page 9-3). 

9.1.2 Removing a Channel 

You may also wish to remove a channel that was either added improperly or does not 

contain useful data. To do so: 

 

1. Click on the image that contains the channel you would like to remove. You may 

also start from an open view of the image. 

 

2. Select Image > Channel Operations > Remove Channel.... The following dialog 

box will appear. 
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The dialog box has the following options for Image Range: 

 

 Current Image- Operation will be performed on the selected image only. 

 

 Current Capture Series- Operation will be performed on all images that 

were acquired during a single capture series.  An example of a capture series 

is a 4D acquisition, where multiple 3D images are generated at each time 

point. 

 

 Current Capture Type- Operation will be performed on all images in the 

slide with the same capture type (2D, 3D, 4D, etc.) as the selected image. 

 

 All Images with Same Channels- Operation will be performed on all images 

in the slide with the same channels as the selected image. 

 

3. Select the channel that you would like to remove from the drop-down menu. 

 

4. Select the image extent for which you would like to remove channels. You may 

select and deselect images using the checkboxes in the Selected Images list. 

 

5. Click OK to remove the channel(s). 

 

NOTE:  Removing a channel is an irreversible process. You may wish to keep a copy of the 

original image. 

9.1.3 Using Channel Math 

SlideBook allows basic mathematical operations to be performed on specified channels in 

an image. This is appropriate when doing background subtraction or when calculating 

bleedthrough. 
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To perform channel math, do the following: 

 

1. Make sure that the channels that are to be used in the mathematical operation 

are present in a single image. You may wish to insert a channel as discussed 

above. 

 

2. Select the image by clicking on it. You may also start from an open view. 

 

3. Select Image > Channel Operations > Channel Math…. The following dialog 

box will appear. 

 

 
 

4. Setting the scope section of the Channel Math window allows channel math 

operations to be applied to multiple images in the slide. Select one of the 

following options: 

 

 Current Image- Operation will be performed on the selected image only. 

 

 Current Capture Series- Operation will be performed on all images that 

were acquired during a single capture series.  An example of a capture series 

is a 4D acquisition, where multiple 3D images are generated at each time 

point. 

 

 Current Capture Type- Operation will be performed on all images in the 

slide with the same capture type (2D, 3D, 4D, etc.) as the selected image. 

 

 All Images with Same Channels- Operation will be performed on all images 

in the slide with the same channels as the selected image. 

 

5. Select the channels that will be used for the mathematical operations from the 

drop-down list. For instance, if you would like to subtract the FITC channel from 
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the CY3 channel, you would select the FITC channel from the second channel 

menu, and the CY3 from the first channel menu. 

      

6. Select the mathematical operation that you would like to perform using the 

radio buttons. From left to right, the operations are: addition, subtraction, 

absolute difference, division, and no operation. If you select (no op), the second 

channel selection will become unavailable. 

 

7. Enter any desired Coefficients or Offsets in the edit fields. The coefficient will 

be multiplied by the selected channel, and the offset will be subtracted. 

 

8. Enter a Channel Name in the edit field and select OK to generate the new 

channel.  This new channel will now appear in the channel selection drop-down 

box in the image views. 

 

9.1.4 Creating a Timelapse Composite Channel 

To create a timelapse composite channel, select Image>Channel Operations>Create 

Timelapse Composite Channel. Select the desired channel from the drop-down channel 

and then OK. An example of a timelapse composite channel is shown below. The timelapse 

composite channel shows the image data as accumulation over time. This is useful if  you 

wish to see the ―path‖ of travel for migrating cells or other objects of interest. 

 

         
 

Original Data 
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Timelapse Composite Channel 

 

9.2 Cropping an Image 

Before analyzing an image, you may wish to crop an image. This is especially important to 

increase the speed of computationally intensive processes such as deconvolution. Please 

see Cropping an Image on page 8-20. 

9.3 Aligning an Image 

Sometimes, due to misalignments of filters or lack of mechanical repeatability, data for one 

channel of an image may be slightly offset from data for another channel.  To solve this 

problem, SlideBook offers an alignment guide that lets you adjust relative positions of any 

channel in the x , y, and z axes.  The alignment guide works alongside a Main View, a 

Three View, or a Tile View (see Using Data Views to Display Images on page 8-6) in order 

to shift how each channel lies in the image with respect to the other channels.   

 

Changing channel alignment for an image makes a permanent change to the image itself 

and will be saved with the image.  In other words, every view that you open from that point 

on will reflect the new alignment.  Of course you can re-adjust the alignment later if you 

wish. 

 

To align an image: 

 

1. Select the image in the slide by clicking on it. 

 

2. Open a Main View, Three View, or a Tile View of an image (see Using Data 

Views to Display Images on page 8-6) 

 

3. Select Image > Align Channels…. The following dialog box will appear. 
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4. Select the channel that you wish to align from the drop-down menu. 

 

5. Use the left and right arrows to move the selected channel in the x direction, and 

the up and down arrows to move in the y direction, or enter an offset for any axis 

directly into the corresponding edit controls.   

 

NOTE: The view will update automatically when you use the arrow buttons, but 

you must press the Apply button if you manually enter the offsets. Clicking 

Cancel will ignore any changes to the edit field that were not previously applied. 

 

6. Click OK when you are satisfied with the image alignment. 

 

NOTE: If you find it necessary to align certain filters consistently, your system may need 

repair. Please contact support@intelligent-imaging.com. 

 

9.4 Manipulating Timelapse Series 

SlideBook allows you to remove timepoints from a timelapse series or merge two timelapse 

series into one series. 

9.4.1 Removing Timepoints from a Timelapse Series 

To remove time points from an image: 

 

1. Click on the thumbnail, or have an open view and select Image>Advanced 

Operations>Remove Multiple Timelapse Planes…. The following dialog box 

will appear: 

 

mailto:support@intelligent-imaging.com
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2. Enter the time point (or group of time points) that you wish to remove. You may 

also choose to subsample the image by selecting Remove every Nth timepoint  

or Keep every Nth timepoint. Alternately, you may enter a list of points to be 

removed. If you display timestamps, you can observe that the timepoints have 

been removed. 

 

3. Select the checkbox Place result in new image if you choose to do so, then select 

OK. If you do not choose to do so, the timepoints will be permanently removed. 

 

9.4.2 Merging Timelapse Series 

If you have an experiment that was captured into multiple timelapse images, you may 

merge these images by selecting Image > Advanced Operations > Merge Timelapse 

Images.... The following dialog box will appear. 

 

 
 

 In the example dialog above, 2Dtl 2 would be appended onto 2D tl 1 and placed into a 

new image. The original images would remain intact.  



Chapter 9 - Preparing an Image for Analysis or Export 

9-9 

9.5 Performing Flat Field Correction 

As with any optical system, specks of dust or pieces of lint will find their way into the 

microscope‘s optical path.  There may also be some variation in the level of illumination 

across the field of capture.  SlideBook offers an operation called flat field correction, which 

eliminates many of these constant artifacts from an image.  Flat field correction is 

particularly useful in brightfield and DIC (Nomarski) imaging, where such artifacts are 

usually more evident than in fluorescence imaging. Flat field correction (or shading 

correction) is not the same as background correction (background subtraction is strictly 

subtraction). When flat field correction is applied, the desired image is multiplied by a 

matrix of coefficients that is determined from a series of flat field images (see Collecting 

Flat Fields below). To generate this matrix, flat field images are collected, and the average 

of each pixel for the three images is calculate to generate a single averaged image (flat field 

image). The average intensity of all the pixels in the resulting averaged image is then 

calculated. Finally, a coefficient matrix (pixel by pixel map) is calculated so that when the 

intensity at any pixel location is multiplied by its coefficient, the generated pixel intensity 

matches the average pixel intensity of the flat field image. If you are planning to perform 

both background subtraction and flat field correction, perform flat field correction first. 

 

9.5.1 Collecting Flat Fields 

In order to perform flat field correction, SlideBook needs to know what an image with no 

sample in focus looks like.  This image should contain all the constant artifacts, but little 

that will change from sample to sample.  From this image, SlideBook can compute a 

coefficient matrix that can be applied to an image to eliminate most of its constant 

artifacts.  SlideBook, in fact, can average several ―empty images‖ to better ensure that the 

flat field contains only constant artifacts of the optical system and not some peculiarity of a 

single ―empty image.‖  

 

Since constant artifacts might exist anywhere along the optical path, a flat field matrix is 

necessary for each combination of objective, filter, and magnification changer setting.  To 

keep things simple, SlideBook stores all collected flat fields in a single database and keeps 

track of the optical parameters for each one. 

 

9.5.1.1 Adding or Replacing a Flat Field 

If you want to add a flat field matrix to the database (or replace an existing entry), you will 

need to capture a series of images on an empty sample using the desired set of optics, 

including the filter, objective, and magnification changer. To add or replace a flat field, do 

the following: 

 

1. Place a blank slide containing no sample (or a uniformly fluorescent slide if 

collecting a fluorescent flat field) on the stage.   

 

2. Bring the desired optics into place as described in Chapter 5 - Using the Focus 

Window.  

 

In order to bring the z stage of the microscope to the correct position, focus on 

any irregularities (e.g., dust or scratches) on the blank slide.   Then move the xy 

position of the slide to a location where there are few irregularities and adjust 
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the microscope so it is slightly out of focus.  This will minimize the contribution 

of irregularities with the slide to the flat field images. 

 

3. Select Edit > Setup Guides > Flat Field Guide to bring up the flat field guide.   

 

4. Specify an exposure time and number of images to take. 

 

Later, you will be able to adjust the exposure time so that the linear range of the 

camera is being used. The number of images required depends on the user:  the 

more images, the more accurately the flat field matrix will reflect only constant 

artifacts, though the collection process will take more time. Typically two or 

three will be sufficient. 

 

5. Select Capture Image 1. SlideBook will capture an image and display it in the 

upper left corner of the guide.    

 

Make sure that the high and low values of the image are safely in the linear 

range of the camera.  Each pixel can take a value between 0 and 4095, so for a 

good flat field image, you want to make sure that the high value is below 4095.  

In fact, since, this exposure time will be used for all images captured for making 

the flat field matrix, it is safer to ensure that the high is below 3500 or so.  Also, 

since background thermal noise can be in the low thousands range, it's a good 

idea to expose the flat field image long enough so that the high is at least 3000. 

 

6. If necessary, make an appropriate adjustment to the exposure time and click 

Recapture Image 1. Otherwise, move the xy position of the slide slightly and 

capture the next image by clicking Capture Image 2.   

 

After the first image, it‘s unlikely you‘ll need to recapture any of the subsequent 

images, but you will still have that option.   

 

7. Acquire the remaining images making sure to move the slide slightly between 

capture.  

 

8. Once you‘ve captured all the images, click on the Finish button to complete the 

process.  

 

9. Repeat the process for other optical combinations.  

 

9.5.1.2 When to Update the Flat Field Database 

If you try to add a flat field matrix for optics where one is already defined, SlideBook will 

alert you and ask if you want to replace the existing one.  SlideBook does not keep multiple 

flat field matrices for identical optics. 

 

As time passes, it is possible for a flat field matrix to become outdated.  Specks may have 

changed position, or other constant artifacts have either appeared or disappeared.  A 

telltale sign that it is time to update a flat field is when performing the flat field operation 

no longer does its job--marked by white specks appearing after applying the flat field.   
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9.5.1.3 Displaying Existing Flat Fields 

You can get a list of the existing flat fields (and their corresponding optical combinations) 

by selecting Edit > Setup Guides > Display Flat Fields. To display the flat field, click on 

the desired flat field icon in the table and press the display button. 

 

 
 

 

9.5.2 Applying Flat Fields 

If you wish to flat field correct an image that was captured using an optical combination 

that has a corresponding entry in the flat field database, you may choose to apply the flat 

field correction during or after image capture.  

 

9.5.2.1 Applying Flat Field Correction During Image Capture 

 

1. Bring a sample into view and focus as discussed in Using the Focus Window on 

page 5-11 of Chapter 5. 

 

2. Open the Capture window by selecting Image > Capture… or by selecting the 

Capture icon in the tool bar .  

 

3. Set all other capture parameters as discussed in Chapters 6 and 7. 

 

4. Select the Flat Field Correction checkbox, which is located below the exposure 

information. 
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5. Click OK to begin capture. The resulting images will be flat field corrected. 

 

 

9.5.2.2 Applying Flat Field Correction After Image Capture 

 

1. Select the image that you would like to correct by clicking on it. You may wish to 

copy the image before applying the flat field, as it is an irreversible operation 

(see Copying an Image on page 8-4). You may also start from an open view of the 

image. 

 

2. Select Image > Apply Flat Field, and the flat field correction will be applied to 

the image. 
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NOTE: If you do not have an entry in the flat field database that match the optics used to 

capture an image, SlideBook will alert you that it is unable to perform a flat field 

correction. 

 

9.6 Performing Photobleach Correction 

Photobleach correction can be used to correct for photobleaching in 2D timelapse images.  

The photobleach correction operation takes the mean intensity at each timepoint and fits a 

line or curve through the mean intensity versus time data.  Then, it determines a 

multiplication factor for each timepoint that is used to adjust the intensities at each pixel, 

resulting in constant intensities over time.  

 

Before performing photobleach correction, you should examine your data to determine 

what type of fit is most appropriate. To do so, you need to view the intensity-time profile of 

your data set. You can do this by drawing a box over the entire field for a single plane, then 

selecting Image > Statistics > Ratio/Timelapse Data. If the intensities decrease linearly 

over time, you may perform a direct fit. If they seem to decrease exponentially, choose 

exponential fit.  

 

To perform photobleach correction: 

 

1. select Image>Photobleach Correction… The following dialog will appear: 

 

 
 

2. Select the fit, and the scope of operation, as described below: 

 

 Current Image- Operation will be performed on the selected image only. 

 

 Current Capture- Operation will be performed on all images that were 

acquired during a single capture series.  An example of a capture series is 
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a 4D acquisition, where multiple 3D images are generated at each time 

point. 

 

 Current Capture Type- Operation will be performed on all images in the 

slide with the same capture type (2D, 3D, 4D, etc.) as the selected image. 

 

 All Images with Same Channels- Operation will be performed on all 

images in the slide with the same channels as the selected image. 

 

3. Select OK to perform the operation.  

 

WARNING: Photobleach Correction is an irreversible operation. Please be sure to save a 

copy of your original data. 

 

9.7 Performing Background Subtraction 

You may also select a region of interest of arbitrary size and subtract the background mean 

intensities from your image using channel math. Please see the example in Chapter 2, 

Creating Masks Manually (Background Subtraction Example) on page 2-21. You may also 

permanently subtract a background ROI: 

 

1. Make a copy of the data that you are working with. 

 

2. Use the Marquee Tool to select a background region in your image. 

 

3. Select Image>Select Background. 

 

4. Select Image>Advanced Operations>Subtract Region Background. The 

average values from your background ROI will be subtracted on a channel by 

channel basis. 

 

WARNING: The background subtraction operation described above is an irreversible 

operation. Please be sure to save a copy of your original data. 

 

9.8 Creating a Projection Image 

You may wish to view 3D data as a single 2D projection image. To do so: 

 

1. Make the desired image the active image by clicking on it. You may also start 

from an open view of the image. 

 

2. Select Image>Create Projection Image… The following dialog box will appear: 
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3. Select the Image Range as described below. You may also select and deselect 

images using the checkboxes in the Selected Images list. 

 

 Current Image- Operation will be performed on the selected image only. 

 

 Current Capture- Operation will be performed on all images that were 

acquired during a single capture series.  An example of a capture series is a 

4D acquisition, where multiple 3D images are generated at each time point. 

 

 Current Capture Type- Operation will be performed on all images in the 

slide with the same capture type (2D, 3D, 4D, etc.) as the selected image. 

 

 All Images with Same Channels- Operation will be performed on all images 

in the slide with the same channels as the selected image. 

 

4. Select the operation and axis for the projection that you would like as described 

below. 

 

 Operation – choose whether the average, maximum, or sum pixel intensity 

will be calculated over the selected axis. 

 

 Axis – choose the axis that will be used for calculation. For example, if Over 

X axis is chosen, the resulting 2D projection will be in the y and z 

dimensions. 

 

5. Select the Generate projection for all images in slide checkbox if you would like 

a projection image to be automatically created for all images in the slide.  This 
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feature is only available if all images in the slide have the same capture type 

and the same dimensions.  It is often used for batch creation of projection images 

for 4D data sets.  The resulting series of projection images are placed into a new 

image located at the end of the slide. 

 

9.9 Creating an Interpolated (Isotropic) Image 

You may notice that your object may appear disproportionately small, or ―squashed‖ in the 

z direction. When performing 3D imaging, each plane that is captured is represented 

by a set of pixels in the image set. Each pixel is a perfect cube. You will notice that the z 
dimension in the 3D image set appears to be different than what was actually captured. 

This is because the z step size that was selected during capture is not actually the same as 

the length of the z dimension of the pixel. In the image set, planes are simply stacked on 

top of one another with no regard for the actual z distance traveled (this is done in order to 

save space). Generating an interpolated image will expand your z dimension to represent 

the actual z distance traveled by the microscope.  

 

To create an interpolated image: 

 

1. Select the image that you would like to expand by clicking on it. You may also 

start from an open view of the image. 

 

2. Select Image>Create Interpolated Image…. The following dialog box will 

appear: 
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The dialog box recommends expansion parameters based on the calibrated pixel 

size and z step size used for capture. These recommended parameters will 

generate an image with the approximate dimensions of the actual sample. You 

can use the recommended expansion parameters or enter custom values in the 

edit boxes.   

 

If the Use only those values in the first mask checkbox is selected, only pixels 

highlighted in the first mask of the original image will be used to create the 

interpolated image.  For more information on creating and using masks, see 

Chapter 10 on page 10-1. 

 

3. Select the Image Range as described below. You may also select and deselect 

images using the checkboxes in the Selected Images list. 

 

 Current Image- Operation will be performed on the selected image only. 

 

 Current Capture- Operation will be performed on all images that were 

acquired during a single capture series.  An example of a capture series is 

a 4D acquisition, where multiple 3D images are generated at each time 

point. 

 

 Current Capture Type- Operation will be performed on all images in the 

slide with the same capture type (2D, 3D, 4D, etc.) as the selected image. 

 

 All Images with Same Channels- Operation will be performed on all 

images in the slide with the same channels as the selected image. 

 

4. Select OK and a new image(s) will be generated.  

 

NOTE:  The m/pixel value for the objective that was used must be accurate for this 

feature to work properly. Before generating the isotropic image, check the image 

information to make sure the m/pixel value is set properly (see Getting and Editing 

Image Information After Capture on page 6-13). 

 

9.10 Applying Filters 

SlideBook offers a variety of filtering options, including a user-defined kernel and semi-

defined Gaussian, Gaussian derivative, hot pixel, median, and mean filters. These filters 

perform local, rather than global, calculations on a pixel by pixel basis. In other words, 

each pixel is altered based on the intensities of the neighboring data.  

9.10.1 User-Defined Convolution Kernels 

This filtering option allows you to define a custom kernel. To apply a custom kernel: 

 

1. Select the image that you would like to correct by clicking on it. You may wish to 

copy the image before applying the filter, as it is an irreversible operation (see 

Copying an Image on page 8-4 of Chapter 5.). You may also start from an open 

view of the image. 
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2. Select Image>Filter>Convolve….  The following dialog box will appear. 

 

 
 

3. Select the Image Range as described below.  

 

 Current Image- Operation will be performed on the selected image only. 

 

 Current Capture- Operation will be performed on all images that were 

acquired during a single capture series.  An example of a capture series is 

a 4D acquisition, where multiple 3D images are generated at each time 

point. 

 

 Current Capture Type- Operation will be performed on all images in the 

slide with the same capture type (2D, 3D, 4D, etc.) as the selected image. 

 

 All Images with Same Channels- Operation will be performed on all 

images in the slide with the same channels as the selected image. 

 

4. Select which channels will be filtered using the convolution kernel. 

 

 For all channels – Convolution operation will be performed on all 

channels in the image. 
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 For the following channels -.Convolution operation will be performed 

only on the selected channels in the image. 

 

5. Select the destination of the filtered channel.   

 

 Replace each channel – The selected channels will be replaced with the 

filtered data. 

 

 Create a new filtered channel – New channels containing the filtered 

data will be created within the image. 

 

6. Select either a 3x3 or a 5x5 Kernel Size. 

 

7. Enter the desired Coefficient and Offset in the edit field. The output value of the 

kernel will be multiplied by the coefficient and added to the offset. These 

parameters can be used to scale the convolved data to a desired range and to 

account for negative kernel output values. 

 

8. Enter the desired matrix elements in array of edit fields. 

 

9. Select OK to perform the convolution. 

9.10.2 Gaussian, Hot Pixel, Mean, and Median Filters 

SlideBook offers a set of standard filters for digital image processing. 

 

 Gaussian – A blurring filter that utilizes a Gaussian kernel of a given radius. 

Useful for removing noise from an image.  

 

 Gaussian Derivative- An edge detection filter that uses a first derivative 

Gaussian kernel of a given radius. 

 

 Mean or Median – Blurring filters that replace the intensity value of a pixel 

with the mean or median intensity value of pixels within a given radius. 

 

 Hot Pixel – A non-linear filter used to remove ―Hot Pixels‖ in an image. If a 

pixels intensity value is some factor greater than the mean of its neighbors it is 

replaced with this mean value. A hot pixel in an image is generally caused by a 

bad pixel on a CCD chip.  

 

To apply the Gaussian, Gaussian Derivative, Mean, Median and Hot Pixel Filters: 

 

1. Select the image that you would like to filter by clicking on it. You may wish to 

copy the image before applying the filter, as this is an irreversible operation (see 

Copying an Image on page 8-4). You may also start from an open view of the 

image. 

 

2. Select the appropriate filter from the Image>Filters hierarchical menu. A dialog 

box will appear that is similar to that shown below. 
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3. Select the batch, channel and destination options for the filter as described in 

the above section User-Defined Convolution Kernels on page 9-17. 

 

4. Each filter has different user-definable parameters. Enter the parameters for 

the filter based on the following descriptions. 

 

 Gaussian filter – A Gaussian kernel of a designated Radius will be used 

to determine a pixels intensity value. 

 

 Gaussian Derivative – A first derivative Gaussian kernel of a designated 

Radius will be used to determine a pixels intensity value.  

 

 Mean or Median – A pixel will be replaced with the mean or median 

intensity value of pixels within a designated Radius.   

 

 Hot Pixel – A pixel whose intensity value is higher than the mean of its 

neighboring pixels by more than the designated Factor will be set to the 

mean of its neighboring pixels. 

 

5. Select OK to filter the image. 
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9.11 Performing No Neighbors Deconvolution 

Deconvolution is the process by which SlideBook mathematically removes out-of-focus 

information from a fluorescence image set.  SlideBook can implement three deconvolution 

approaches: constrained iterative, nearest neighbors, and no neighbors.  No Neighbors 

deconvolution is incorporated into the base SlideBook package.  Nearest neighbors and 

constrained iterative deconvolution are available as an additional SlideBook module.  For 

more information about nearest neighbors and constrained iterative deconvolution refer to 

the supplemental SlideBook Deconvolution Module manual or contact Intelligent Imaging 

Innovations. 

 

No neighbors is the least computationally intensive method of deconvolution offered in 

SlideBook and the only method that can be used on single plane images.  While no 

neighbors deconvolution can be applied to three dimensional data sets, it does not use 

information within multiple planes to calculate and remove out of focus information.  

Rather, it functions by creating a theoretical blurred image from the original two-

dimensional image.  This blurred image is then subtracted from the original image, leaving 

objects that are more likely to be in focus.  

 

9.11.1 Running No Neighbors Deconvolution 

 

1. Select the image that you would like to correct by clicking on it. You may also 

start from an open view. 

 

2. Make sure that the image information is correct as described in Getting and 

Editing Image Information After Capture on page 6-13. 

 

3. Select Image > Deconvolve>No Neighbors. The following dialog box will appear: 
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4. Select the scope of the deconvolution operation. 

 

 Current Image – Operation will be performed on the selected image only. 

 Current Capture Series – Operation will be performed on all images that 

were acquired during a single capture series.  An example of a capture 

series is a 4D acquisition, where multiple 3D images are generated at 

each time point. 

 Current Capture Type – Operation will be performed on all images in 

the slide with the same capture type (2D, 3D, 4D, etc.) as the selected 

image. 

 All Images with Same Channels – Operation will be performed on all 

images in the slide with the same channels as the selected image. 

 

5. Select the destination of the deconvolved image. 

 

 Replace image data – The selected image will be replaced with the 

deconvolved image. A ‗.NoN‘ will be appended to the name of the new 

image indicating that it has been deconvolved. 
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 Create new image(s) – A new image will be will be created containing the 

deconvolved data.  A ‗.NoN‘ will be appended to the name of the new 

image indicating that it has been deconvolved. 

 

NOTE:  If multiple images have been selected for deconvolution (batch 

deconvolution) and the Create new image(s) radio button has been chosen, all 

deconvolved images will be created in a new slide. 

 

6. Select the Channels that will be deconvolved by toggling the checkbox next to the 

channel name. 

 

7. SlideBook‘s deconvolution algorithms can take advantage of a second computer 

processor.  If your computer is equipped with two processors the Use Both 

Processors checkbox will be enabled and selected by default under the Advanced 

Parameters section.  To turn off the use of both processors unselect the checkbox. 

 

8. Select the deconvolution Options according to the following descriptions: 

 

 Subtraction Constant – Adjusts the amount of intensity subtraction used 

in the deconvolution algorithm. Increasing the subtraction constant will 

increase the amount of deblurring but can also result in a loss of image 

data. 

 Theoretical Spacing – Adjusts the distance between theoretical image 

planes used for de-blurring.  The closer the theoretical planes, the greater 

the amount of de-blurring.  Make sure to enter a value greater than zero 

for this parameter. 

 Edge Padding – creates a space around the border of the image in order 

to resolve fluorescent point sources that exist outside of the image. 

 

9. Once the parameters are set, select OK to begin the deconvolution. 

 

In addition to the user-definable parameters, the No Neighbors deconvolution dialog box 

also displays the following information: 

 

 Microscope Components – Displays the optical components that were used to 

take the image. 

 

 Optical Parameters - Displays the optical parameters associated with the 

microscope components used for image capture.  To change these parameters 

refer to Chapter 4 - Configuring Your System on page 4-1. 

 

9.11.2 Memory Requirements for Deconvolution 

Deconvolution is a memory-intensive process and is limited by the size of the image that is 

being deconvolved. On the PC, any given program can use up to 2 GB of memory. This 

results in an 800MB size restriction for No Neighbors Deconvolution. 
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9.12 Exporting Images 

If you would like to perform intensity analysis or image processing in a program other than 

SlideBook, you may want to export the image from the Image menu.  This will export a 16-

bit file that retains all of the intensity data from the original SlideBook image.  In contrast, 

exporting an image from the View menu will generate an 8-bit file.  This will result in a 

loss of data assuming the images were captured on a 12-bit or higher digital camera.  To 

export an image from the Image menu perform the following steps. 

 

1. Select the image that you would like to export by clicking on it. You may also 

start from an open view of the image. 

 

2. Select the appropriate file type from the Image>Export hierarchical menu. A 

dialog box similar to the following will appear. 

 

 
 

3. Select the Image Range as described below. You may also select and deselect 

images using the checkboxes in the Selected Images list. 

 

 Current Image- Operation will be performed on the selected image only. 

 

 Current Capture- Operation will be performed on all images that were 

acquired during a single capture series.  An example of a capture series is 

a 4D acquisition, where multiple 3D images are generated at each time 

point. 

 

 Current Capture Type- Operation will be performed on all images in the 

slide with the same capture type (2D, 3D, 4D, etc.) as the selected image. 
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 All Images with Same Channels- Operation will be performed on all 

images in the slide with the same channels as the selected image. 

 

3. Press OK and to export a single multi-plane image for each channel in the 

selected image(s). 
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10 Using Masks for Image Analysis  

 

Masks are the principal means to perform analysis in SlideBook.  A mask is a binary 

overlay on a 2D, 3D, or timelapse image that can be used to select an arbitrary region (or 

set of regions) of the image at the same resolution as the image itself. Masks are often 

referred to as Regions of Interest (ROI) in other imaging programs. Once you have selected 

a region of interest(s) using masks, you may generate a variety of morphometric 

measurements and intensity statistics on those regions, including:   

 

 Morphometrics 

 Area and Volume 

 Center of Mass 

 Estimated perimeter or surface area 

 Length along major axis 

 Center of area 

 

 Intensity Statistics 

 Mean 

 Minimum and maximum 

 Integrated intensity 

 Center of intensity 

 Correlation (Colocalization) 

 

Plus many others…. 
 

In this chapter, you will learn how to: 

 

 Display an Image Histogram and Mean Intensity 

 Create Masks and Objects 

 Display or Delete Masks 

 Perform Boolean Mask Operations 

 Use Masks to Perform Smooth Curve Analysis 

 Generate and Export Mask and Object Statistics 

 Display Graphs 

 

10.1 Displaying Image Histogram and Mean Intensity 

You may quickly get a statistical snapshot of your image using the Image > Statistics > 

Intensity Statistics… function. A dialog box will display a histogram of the intensityies of 

the entire image by channel along with the mean intensity and standard deviation. You 

must first open a view of your image before selecting the Intensity Statistics menu 

selection. 
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10.2 Creating Masks and Objects 

A mask is a two- or three-dimensional set of binary values that has the same extent as the 

image to which it is assigned. Once created, a mask is permanently stored with its 

corresponding image. Masks are used for performing advanced selection and analysis of 

image data. They can either be created and edited manually or generated automatically 

through threshold segmentation and other techniques.   Selecting Mask > Create… creates 

a mask with the first method; selecting Mask > Segment… creates a mask with the second. 

A single image can contain several different masks.  

 

Often you may have several distinct objects that will have intensities that are very similar, 

and thus will segment together. A mask that contains several distinct entities may be 

divided into objects. For instance, if an image contains a field of many cells, performing 

threshold segmentation of a nuclear stain such as Hoechst will result in a mask that 

contains distinct ―islands.‖  Defining objects permits functions such as counting of objects 

and generating statistics for each subregion. 

 

We will now learn how to create masks using a variety of techniques. 

 

10.2.1 Creating a Mask using Threshold Techniques 

Threshold techniques allow the user to perform a global selection based on image 

intensities.  SlideBook‘s segmentation process generates regions of interest that persist 

throughout the entire image in all dimensions. 

 

1. Click on an open view to make it the active view. 

 

2. Create a mask by selecting Mask>Segment. A dialog box similar to the following 

will appear. Note that it resembles the Renormalization dialog box. 
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3. Select the channel that you would like to segment from the drop-down menu. 

 

4. Enter a name for your mask. 

 

5. Select the scope of the operation using the radio buttons. For any operation that 

segments more than one image, you must select OK to segment all of the desired 

images. If you select Apply, only the current image will be segmented. 

 

 Current Image – segments the current image only 

 

 Current Capture Series (on OK) – segments the current capture series (4D, 

montage, or multipoint series) 

 

 Current Capture Type (on OK) – segments the current capture type only. For 

instance, if you have a 2D timelapse image open in a slide with at least one 

other timelapse image, as well as other capture types, only the 2D timelapse 

images would be segmented. 

  

 All Images with Same Channels (on OK) -  segments images that have the 

exact same number and type of channels. For instance, if you wish to segment 

a FITC channel, and one image contains a FITC channel while another 

contains both DAPI and FITC, both images will NOT be segmented. Only the 

active image will be segmented.  

 

NOTE:  All images in the slide must be of the same size for this operation. 

 

6. Set the thresholds for segmentation. You may do this in one of two ways: 
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a. Move the red and green bars to the right and left by clicking and dragging 

them. Note that when you release the mouse button, the image will be 

segmented and the mask will be displayed. 

  

OR 

  

b. Enter intensity values in the Low and High edit fields, then click Apply 

to register the change and move the red and green bars. 

 

SlideBook has selected, or masked, any pixel that has intensity values that lie 

between the red and green bars in all of the three channels. In other words, 

segmentation is performing an AND operation across the bounds defined in all 

channels.  

 

7. If working with a 3D image, scroll through the image as discussed in Scrolling 

through the Invisible Axis in a 3D or Timelapse Image on page 8-22 and Scrolling 

through a Three View on page 8-30. Note that the mask persists throughout the 

entire image. 

 

8. If you are satisfied with your mask, click on OK. If you are not repeat step 4.  

 

NOTE: Once you have created a mask using threshold techniques, you may use 

editing tools to add or remove pixels in the mask (see  Editing the Mask on page 10-

5). 

 

10.2.2 Creating Masks Manually  

SlideBook also offers a variety of tools that can be used to manually select regions of 

interest. An example demonstrating the creation and use of a manual mask is described in 

the Quick Tour section Creating Masks Manually (Background Subtraction Example) on 

page 2-21. 

 

10.2.2.1 Creating an Empty Mask 

To make a mask manually, you will first create an empty mask, then you will select your 

regions of interest using editing tools. 

 

1. Click on an open view to make it the active view. 

 

2. Create a mask by selecting Mask>Create…. The following dialog box will 

appear. 
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3. Enter a name for the mask in the edit field. 

 

4. Choose to create the mask for the current image or for multiple images using the 

radio buttons, which are defined as follows: 

 

 In the current image – creates mask for the current image only 

 

 In all images in the current capture – creates mask in the current capture 

series (4D, montage, or multipoint series) 

 

 In all images with the current capture type – creates mask for the current 

capture type only. For instance, if you have a 2D timelapse image open in a 

slide with at least one other timelapse image, as well as other capture types, 

only the 2D timelapse images would be segmented. 

  

 In all images with same channels -  creates mask for images that have the 

exact same number and type of channels. For instance, if you wish to 

segment a FITC channel, and one image contains a FITC channel while 

another contains both DAPI and FITC, both images will NOT have a newly 

created mask. A mask will only be created for the active image.  

 

 

5. Click OK to create a new mask for the current image.  

 

 

10.2.2.2  Editing the Mask Manually 

Once you have created an empty mask, you can use a variety of tools to construct a useful 

mask. There are two means of editing the mask: using drawing tools from the tool menu, 

and performing fine adjustments using tools from the Mask menu.  

 

1. Make sure that your mask is the currently selected mask. To do this, click on the 

mask menu  and select the desired mask from the list. 

 

2. Select a tool from the drop-down tool menu  in the info/tool bar (see Using the 

Tool Menu on page 8-27).  



Chapter 10 - Using Masks for Image Analysis 

10-6 

 

  Marquee tool – click and drag to draw a box outline, then select 

Mask>Mark Selection to fill in your selection. To remove the box, choose 

Mask>Unmark Selection. 

 

 Single pixel pencil– click and hold the mouse button to generate a single 

pixel-width freehand line 

 

  Small pencil – click and hold the mouse button to generate a thin 

freehand line 

 

  Large pencil - click and hold the mouse button to generate a thick 

freehand line 

 

  Small eraser - click and hold the mouse button to remove small amounts 

 

  Large eraser - click and hold the mouse button to remove large amounts 

 

  Paint bucket – fill a shape by single clicking within any closed shape 

drawn with the small or large pencil 

 

Additionally, you may generate a 2D or 3D rectangular volume by first defining 

a volume as discussed in Making a 2D or 3D (x,y,z or x,y,t) Selection on page 8-

29, then choosing Mask>Mark Selection. 

 

6. Use the tool to add or remove pixels. The selected pixels will be shown in blue. 

 

7. If you are working with a 3D or timelapse image, and would like to copy your 

selections to other planes in the image, select Mask>Copy This Plane... The 

following dialog box will appear. 

 

 
 

8. Use the radio buttons to select the desired action, and click OK. 
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9. To further refine your mask, you may select a variety of operations by selecting  

Mask>Mask Filter. The menu items are described below. You may use these 

operations in any order or as many times as desired. 

 

 Dilate - applies a dilation kernel to the entire mask and thickens features.  

For any marked voxel in the original mask, the surrounding 26 voxels (eight 

in the same plane and nine in each neighboring plane) in a new mask will be 

marked as well.   

 

 Dilate (2D)- performs the same operation as described above using a kernel 

that only marks voxels in the same plane.  As a result, Dilate and Dilate 

(2D) operations are identical on a two-dimensional image. 

 

 Erode - applies a kernel to the entire mask that removes voxels that are not 

completely surrounded by marked voxels, resulting in thinned features. As a 

result, applying Erode to a 2D mask removes all the marked voxels from the  

mask. 

 

 Erode (2D) - performs the same operation as described above but does not 

recognize the planes above or below. 

 

 Skeletonize – reduces the mask to a set of connected junctions. 

 

NOTE: These operations do not create new masks, but simply edit the current mask. 

 

 

10.2.2.3 Moving the Mask 

You can shift the mask in any direction by selecting Ctrl-arrow keys. 

 

10.2.2.4 Copying a Manually Created Mask to Other Planes or Other Images 

Once you have created a mask, you may choose to copy the mask to other planes in the 

image (if you have a 2D timelapse or 3D image). To do this:  

 

1. Select Mask>Copy This Plane…. The following dialog box will appear: 
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2. Select the desired destination and select OK. 

 

 

You may also copy the mask to all of the images of the same size in the same slide.  To do 

so, from an open view of an image: 

 

1. Display the mask that you wish to copy by selecting it from the mask menu  

in the info/tool bar. 

 

2. Select Mask>Copy to all images in slide… and, when the dialog box appears, 

choose OK. 

 

The mask will be copied to all of the images in the slide provided they are the same size. 

 

10.2.3  Defining Objects 

Objects are defined when you wish to get data for individual objects in a mask. The mask 

statistics dialog box allows you to automatically define objects when generating statistics. 

However, in order to view timelapse graphs of individual objects or to obtain a quick object 

count, you will need to define objects. To do so: 

 

1. Generate a mask that contains distinct regions, either using manual editing or 

segmentation techniques. 

 

2. Select Mask>Define Objects in Mask… The following dialog box will appear.  

 

 
 

The dialog box allows you to set upper and lower bounds on the size of the 

regions that should be made into objects.   
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3. If you would like to set limits on the size of the objects, select Gate Objects by 

Size and choose a minimum and maximum size.  The size bounds can be 

specified in either voxels or cubic microns (square microns for a 2D image). 

 

4. Select the Generate for all similarly named masks in current slide checkbox to 

perform the object definition operation on the entire slide. 

 

NOTE:  This process does not create multiple masks, but rather assigns a number to 

each isolated, contiguous subregion of the existing mask.   

 

 

5. Select OK. A dialog box will appear that gives the status of the object 

generation. When object generation is complete, a dialog box will appear, noting 

the number of objects generated. When objects are defined for a 2D timelapse 

image, SlideBook will display the maximum number of objects generated at any 

given timepoint. 

 

 
 

 

6. Click on OK. If you now position the cursor over one of the objects in the Main 

View, the object number appears to the right of the cursor location coordinates 

in the info/tool bar. 

 

7. If you would like to remove objects, select Masks>Update Object Definitions…. 

The Define Objects dialog will appear as it did when selecting Masks>Define 

Objects in Mask.... 

 

8. Select Gate Objects by Size and increase the lower threshold, or decrease the 

upper threshold, then select OK. The number of objects generated will decrease. 

This is particularly useful when working with noisy data that may contain a 

very large number of objects. 

 

NOTE:  You may not decrease the lower threshold to increase the number of objects. 

If you have removed too many objects, then you will need to remake your mask. 

 

10.2.4 Splitting Objects  

If you have two or more objects that are touching but exist under one contiguous region of 

the mask (a mask object), you may choose to split the mask into multiple objects. This can 

be achieved either manually by drawing lines along which to split the object or in an 

automated fashion. 
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10.2.4.1 Manually Splitting Objects 

To split objects manually, use the line ROI tool to draw lines where you would like to 

separate the objects. Then select Mask > Advanced Operations > Split Objects Along 

Lines. To see the split objects, turn the ROI display off by going to View > Annotations > 

Regions. You may undo the split by selecting Mask > Advanced Operations > Undo Split 

Objects Along Lines. 

 

10.2.4.2  Automatically Splitting Objects 

To split objects automatically, SlideBook employs a Magic Number Seed Watershed 

algorithm. This is useful to separate objects that may be joined by a thin connector as 

shown below. 

 

 
 

This operation is performed by selecting Mask>Advanced>Watershed Splitting (Magic 

Number Seed). As you move and release the slider, the splitting operation will be 

performed. If you move the slider to the left, a more aggressive splitting is performed. 

10.2.5 Removing Objects from Edge of Image 

In some instances, you may wish to eliminate objects that touch the edges of your image. 

To do so, select Mask>Advanced Operations>Remove Edge Objects.  The following dialog 

box will appear. Select the desired Image Range and select OK. 

 

 
 



SlideBook 4.2 User’s Manual 

10-11 

10.2.6 Tracking Objects (Particle Tracking) 

Once you have defined objects, you may wish to track them over time. SlideBook offers two 

methods for particle tracking, automated and manual.  

 

10.2.6.1  Automated Particle Tracking (Tutorial) 

To perform particle tracking, you may either use the Particle Tracking Protocol or 

individual dialog boxes. The Particle Tracking Protocol has the advantage of being able to 

save and reuse your particle tracking parameters, and apply them in a batch fashion. 

Below we describe how to use the Particle Tracking Protocol. Each step in the protocol can 

be accessed via a menu item, which is also noted. You may wish to practice particle 

tracking using the sample file ―ParticleTrackingDemo.sld‖. You may download this file at 

the SlideBook download site.  

 

1. Select the objects you wish to track by generating a mask using thresholding 

and/or manual marking (see Creating a Mask using Threshold Techniques on 

page 10-2 or Creating Masks Manually on page 10-4). You may need to separate 

objects that are touching using mask filters (Mask>Mask Filter>Erode) or 

object splitting algorithm (see Splitting Objects on page 10-9). 

 

For ParticleTrackingDemo.sld, create a mask using a threshold of 217 for the i-

485 channel. 

 

2. Begin by selecting Mask>Particle Tracking>Particle Tracking Protocol. The 

following dialog will appear. 

 



Chapter 10 - Using Masks for Image Analysis 

10-12 

 
 

The dialog box contains the list of protocol steps on the left along with a drop-

down menu for saving and loading settings. The list of steps are listed. Required 

steps must be completed before moving to the next step in the protocol. Steps 

that are not required may be skipped. Once a step is complete, an X will appear 

in the Done column. The right side of the dialog will update as you progress 

through the protocol.  

 

3. Select Tracking Parameters as described below. 

 

 Mask Name – Select the Mask that contains the objects you would like to 

track. The menu will default to the mask that is currently displayed on your 

open view. 

 

 Remove Objects smaller than – Check this box to selectively remove objects 

smaller than a given size. Enter the size in the edit field and choose either 

microns or pixels as the unit. 

 

 Track with – Select the parameter that you wish to track from the drop-

down list. 

 

 Center of Area - the coordinates of the center of the object, 

unweighted by intensity values. 
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 Center of Intensity - the coordinates of the center of the object, 

weighted by intensity values. If you select this feature, you will also 

need to select the channel that is used for weighting. 

 

 Mean Adjusted Center of Intensity – the coordinates of the center of 

the objected, weighted by intensity values that are above the mean 

intensity. This is a useful feature to track if you have hand delineated 

your objects. By using values that fall above the mean, any 

imprecision in your hand delineation does not impact the center of 

intensity calculation. If you select this feature, you will also need to 

select the channel that is used for weighting. 

 

 Maximum Movement – enter the maximum movement that you expect from 

any given object from one time point to the next. This will help the particle 

tracking algorithm distinguish between objects that may have similar 

centroid values. 

 

 Minimum Path Length – enter the minimum number of timepoints that 

must be tracked in order to determine a path. For instance, if you enter ―3‖, 

any object that cannot be followed for at least 3 timepoints will be removed 

for the mask. 

 

NOTE: This dialog box may also be found via the Mask>Particle 

Tracking>Particle Tracking menu 

 

4. For the tutorial, select the parameters as shown in the dialog below. 
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5. Select Track and the tracking algorithm will be executed. When completed the 

paths will be displayed on the image. You may click on the image and scroll 

through the timepoints to see the paths. The first point in the path appears blue, 

and the last appears red, with a gradation of color between. At this point, you 

may wish to view the object IDs by selecting View>Annotations>Object IDs. 

Also, you may wish to perform the tracking algorithm using new parameters. 

You may enter those parameters and then press Track again. If you already 

know the parameters in advance you may select Track and Continue. The 

tracking algorithm will be executed and the protocol will automatically advance 

to the next step. 

 

NOTE: You may turn path display on and off by selecting Mask>Particle 

Tracking>Display Paths. 

 

6. Once tracking is complete, select Next. The protocol will advance to the next 

step.  
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Here, you may choose to calculate the following statistics for each path. 

 

d1

d4

d3

d2

d5 d7

d6

 
 

Fig. 10.1 – Schematic of tracked object. Blue circles represent centroids 

 

 Endpoint Displacement – the distance traveled between the first and last 

timepoints of the path, as represented by the length of the red line in the 

figure above. 

 Endpoint Speed – the distance represented by the length of the red line 

divided by the time required to travel that distance. 

 Average Speed – the total distance traveled (the sum of distances d1 to d7 as 

shown in the figure above) divided by the time required to travel that 

distance 

 Total Displacement – the total distance traveled by the object (the sum of 

distances d1 to d7 as shown in the figure above) 

 Path Length – number of timepoints in the path 

 Path Lifetime – the total elapsed time for a given path 
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 Path Start Point – centroid of the first point in the path 

 Path End Point – centroid of the last point in the path 

 MSD – mean square displacement (coming soon) 

 

Note: The Path Statistics dialog box can also be found by selecting 

Mask>Particle Tracking > Path Statistics. 

 

7. Select the statistics you wish to calculate using the checkbox. Select Calculate 

and Continue if you wish to progress to the next step, or simply select Calculate 

if you wish to view your statistics without going to the next step, then select 

Next when you are ready to go to the next step. The following dialog will appear. 

 

 
 

Note: Object statistics can also be calculated via the Mask Statistics dialog 

(Mask>Statistics). 

 

Statistic definitions are given in the section Generating and Exporting Mask and 

Object Statistics on page 10-22. 

 

8. Select the statistics that you wish to calculate and either select Calculate and 

Continue, or Calculate and then Next. The following dialog will appear. 
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9. If you have more than one image in the slide, you may choose to apply the 

protocol to other images in the slide. Simply check the checkboxes of the images 

you wish to analyze, and either select Apply and Close to finish the protocol, or 

select Apply to perform the batch analysis. You may select whether you would 

like to send results to the screen or straight to disk. 

 

10. If you would like to save the particle tracking parameters for processing another 

slide, select Save As.. from the Save/Load Settings drop-down menu. Enter a 

name for the settings and select OK. You may now select those settings the next 

time you open the Particle Tracking Protocol dialog. You may also delete 

settings or modify the settings and then choose Save to save the settings with 

the same name. 

 

10.2.6.2  Performing Manual Particle Tracking 

 

1. Open a main view of the image containing objects you wish to track. 

2. Go to Mask>Particle Tracking>Manual Tracking. The following dialog box will 

appear. 
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3. Select either the medium or large pencil tool from the tool menu. The view will 

go to the first timepoint automatically. 

 

4. Click near the center of the first object you would like to track. The view will 

automatically move to the next timepoint. 

 

5. Continue clicking on the object you would like to track until the path is 

complete. When complete, either choose New Path to go back to the first 

timepoint and start over, or OK to close the dialog. You may now generate object 

statistics as described in Generating Statistics for Masks and Objects on page 

10-22. 

10.3 Displaying or Deleting a Mask 

If you have just issued either the Mask > Create or Mask > Segment… commands, the 

new mask is already selected and displayed. If not, you must select the mask you want to 

edit using the mask pop-up menu  in an open view of the image.  Note that while you 

are editing from within a particular view, the mask is owned by the image, not just the 

particular view.  Any changes you make to the mask can be seen in any other view in which 

the same mask is displayed.  

 

To delete a mask: 

 

1. Select Mask > Delete… The following dialog box will appear. 

 



SlideBook 4.2 User’s Manual 

10-19 

 
 

2. Choose the mask(s) you wish to remove using the radio buttons and drop-down 

menu. You may also choose to delete the mask from the current image or all 

images in the slide. 

 

3. Choose OK to remove the mask. 

 

10.4 Boolean Mask Operations  

Masks can be combined or altered using Boolean operations.  For instance, the intersection 

of two masks can be generated by an AND operation.  The Mask Operations dialog lets you 

either generate a new mask that contains the result of a Boolean operation or replace an 

existing mask with the result of an operation.  

 

To perform Boolean mask operations: 

 

1. Open a view that contains the masks you would like to manipulate. 

 

2. Select Mask > Mask Operations…. The following dialog will appear. 
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3. Using the radio buttons, select whether the operation will take place for the 

current image or the entire slide. 

 

4. Select the masks to be used from the Left Mask and Right Mask menus.  

 

5. Select the operation to be performed using the radio buttons. 

 

 And – selects pixels that are in both masks 

 Minus – removes any pixels that are present in the right mask from the left 

mask 

 Not – selects all pixels that are not marked in the left mask 

 Or – generates the union of, or adds, the two selected masks 

 XOr – adds both masks and removes any common pixels 

 

6. Select the destination for the mask operation using the radio buttons. If you 

want the result to replace the contents of either the left or right mask, select the 

corresponding radio button for that mask.  If you want to generate a new mask, 

select the New Mask radio button and give the new mask a name in the edit 

field. 

 

7. Click OK to perform the Boolean operation. You may display the new or edited 

mask as described above. 

 

10.5 Using Masks for Smooth Curve Analysis (Kymograph) 

You may use masks to identify regions to be used for smooth curve analysis, also known as 

kymograph analysis. Smooth curve analysis allows you to follow time-dependent lateral 
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intensity changes along a static object. For example, an action potential moving along a 

neural spine could be displayed as an x vs. t image using smooth curve analysis. You could 

then extract velocity and displacement information from this image. To perform smooth 

curve analysis: 

 

1. Open a main view or three view of your timelapse data. 

 

2. Create a new mask as discussed above in Creating an Empty Mask on page 10-4. 

 

3. Select the single pixel pencil tool from the tool menu  and draw a line along 

the desired object. 

 

4. Copy the mask to all planes in the image by selecting Mask>Copy This Plane... 

The following dialog box will appear. 

 

 
 

5. Use the radio buttons to select the desired action, and click OK. 

 

6. Select Mask>Advanced Operations> Smooth Curve Analysis. The following 

dialog box will appear. 
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7. Adjust the dimensions as necessary (please see Appendix A for a detailed 

description of Smooth Curve parameters) and select OK. A new image will 

appear in your slide. 

 

8. Open a main view of the Smooth Curve Image and select the y axis from the axis 

menu  on the info/tool bar. You are now able to display a 2D view of your 3D 

selection. You may perform velocity measurements of timelapse data with the 

ruler tool (see Making Distance or Velocity Measurements on page 8-30). 

 

10.6 Generating and Exporting Mask and Object Statistics 

You can answer many quantitative questions about a mask through mask statistics.  

SlideBook lets you compute three types of mask statistics:  statistics for the entire mask, 

statistics for each time point in a time lapse image, and statistics for objects (defined above 

on page 10-1). SlideBook allows for a wide range of statistics to be generated, from simple 

to sophisticated. 

 

10.6.1 Counting Objects in a Mask  

You may wish to count the individual objects, in your mask. If you do not wish to obtain 

other statistics, you may count objects by generating objects (see page 10-8). You may also 

get an object count by generating the Object Count statistic (see next section). This is 

especially useful if you wish to count objects for multiple images in a slide. 

10.6.2 Generating Statistics for Masks and Objects 

SlideBook allows you to generate a wide variety of statistics for regions of interest in 2D 

and 3D data.  

 

To generate statistics from an open view of an image: 
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1. Display the mask of interest by selecting it from the mask menu . 

 

2. Select Mask > Statistics….  The following dialog box will appear. 

 

 
 

 

The dialog box has the following sections: 

 

 Image Scope – allows for generation of statistics in multiple images. If you 

are working with a 2D or 3D image, the first radio button will be selected by 

default. If you are working with a 2D timelapse or 4D data set, the second 

radio button will be selected by default. You may select the third radio 

button if you have multiple images with the same mask name.  

 

 Mask Scope – allows you to select whether you want statistics for the entire 

mask or on a per object basis. If you have chosen to obtain statistics for 

multiple images, the Object option will be unavailable. 

 

 Primary Mask – defaults to the mask that is currently displayed but can be 

altered via the drop-down menu. The primary mask will automatically be 

made into objects. You may also remove objects under a specified pixel size 

(gating by size, see page 10-8). To get statistics for all pixels in the mask, 

leave this box unchecked. 

 

 Secondary Mask – can be selected to obtain additional statistics (see below). 

 

 Features – lists all available statistics that may be calculated. Note that the 

list of features will depend on the dimensions of the mask. For instance, area 

will be displayed as a statistic for 2D masks, while volume will be displayed 

for 3D masks. 
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 Output Grouped By – these choices are only activated if you are performing 

object statistics on 2D timelapse or 4D images.  Sample output is shown 

below: 

Output Grouped By Statistic 

 

 
 

Output Grouped By Object 
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Output Grouped by Timepoint 

 

 
 

3. Click on the desired statistic and then choose Select at the bottom of the dialog. 

Repeat for other desired statistics SlideBook offers the following options for 

statistics for a single mask: 

 

Morphometry 

 

 Object Count – number of objects. This statistic is only available when you 

select Entire Mask in the Mask Scope section of the statistics dialog. 

 

 Volume (voxels) / Area (pixels) - total number of voxels.  Note that in a 2D or 

time lapse image, you will always get an area measurement. 

 

 Volume (µm³) / Area (µm²) - volume in cubic (or in 2D or time lapse images, 

square) µm.  Note that the image must have the correct objective and optovar 

selected for these values to be accurate (see Defining Objectives on page 4-12 

and Defining Magnification Changers on page 4-26).  

 

 Surface area (µm²) / Perimeter (µm) – the area of exposed voxel faces for 3D 

objects (or in 2D or time lapse images, pixel faces).  Note that these values 

should only be used as rough estimates, as area or perimeter measurements 

are highly affected by the resolution of the image. 

 

 Center of Area/Volume – the coordinates of the center of the object, 

unweighted by intensity values. 

 

 Major Axis Length – please contact support@intelligent-imaging.com for 

documentation on this calculation. 

 

mailto:support@intelligent-imaging.com
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 Minor Axis Length – please contact support@intelligent-imaging.com for 

documentation on this calculation. 

 

 Longest Chord Length - the distance between the two furthest voxels in the 

shape.  

 

Intensity 

 

 Center of intensity – the coordinates of the center of the marked object 

weighted by intensity, calculated for each channel 

 

 Mean intensity - average marked voxel intensity value for each channel 

 

 Sum intensity - sum of all marked voxel intensity values for each channel.  

Note that this value is equivalent to the product of the mean intensity and 

the volume or area. 

 

 Minimum and Maximum intensity - data for both the lowest and highest 

marked voxel intensity value for each channel 

 

 Variance – the variance of intensities of the marked voxels 

 

 Standard Deviation -  the standard deviation of intensities of the marked 

voxels 

 

Cross-Channel 

 

 Pearson‘s Correlation – the correlation of intensity in one channel with 

another; a -1.0 value signifies no correlation, while a value of 1.0 signifies 

perfect correlation. This statistic can be used for measuring colocalization. 

The equation used is shown below. Ri is the intensity in channel 1 for pixel I, 

and Gi is the intensity in channel 2 for the same pixel. Rav and Gav are the 

average (mean) intensity values over all pixels. 

 
 Mander‘s Coefficients – these coefficients indicate the percent of protein 1 

colocalized with protein 2 (M1) and the percent of protein 2 colocalized with 

protein 1 (M1) as given by the equation below. The value T (threshold) is 

considered to be zero intensity. Thus, adequate background subtraction must 

be performed. 

mailto:support@intelligent-imaging.com
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SlideBook offers the following statistics to describe relationships between 

objects that are present in two different masks. You must first set the Mask 

Scope to Object, then select a secondary mask to view these statistics. 

 

Cross-Mask 

 

 Mask Overlap -  returns a value of 1.0 if the object in the primary mask has 

at least one pixel that overlaps with an object in the secondary mask, returns 

0 if there is no overlap 

 

 Mask Contains Other Masks – returns a value of 1.0 if an object in the 

primary mask is contained in the object of the secondary mask, returns 0 if it 

is not 

 

 

Under Development 

These statistics are currently under development. Please contact 

support@intelligent-imaging.com if you require these features.  

 

 Convex Hull Area (µm² or pixels) – the area of the set of points that describe 

a convex shape, for 2D objects only  (available for objects and entire mask) 

 

 Radial Descriptors 

 

 Radial Descriptors (real space) 

 

 Relative COM position – returns the center of mass coordinates of an object 

in the primary mask as it relates to the center of mass coordinates of a 

containing object in the secondary mask  

 

 Contained Point to Point Coordinates – returns the coordinates of the two 

points closest to one another in the contained (primary) objects to the 

containing (secondary) objects. The type of coordinates that are used to 

determine closest distances can be selected using the checkboxes shown 

below: 
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For instance, if COM (Center of Mass) is selected for both contained and 

containing masks, the search for closest distance is limited to two points, and 

the two COM coordinates are reported. If Surface is selected, the entire 

surface of the primary and secondary masks is compared and the two closest 

surface coordinates are reported. 

 

 Contained Point to Point Distances - returns the distances of the two points 

closest to one another in the contained (primary) objects to the containing 

(secondary) objects 

 

 Point to Point Coordinates – returns the coordinates of the two points 

closest to one another in each primary object to each secondary object. Thus 

an array of  n x m paired coordinates will be returned for a primary mask 

containing n objects and a secondary mask containing m objects. 

 

 Point to Point Distances - returns the distance of the two points closest to 

one another in each primary object to each secondary object. Thus an array of  
n x m distances will be returned for a primary mask containing n objects and 

a secondary mask containing m objects. 

 

 Closest Point to Point Coordinates – returns the object ID for the closest 

object in the secondary mask to the current object, along with the distance 

and coordinates involved. 

 

 

4. Select Display to generate a new window that shows the selected statistics.  

Alternatively, you may directly export the data by pressing Export (see below). 

 

If you have generated object data, you may click on any of the object numbers in 

the table, and the corresponding object will be highlighted in orange in the data 

view. 

 

5. To save the data, select the Export button.  A dialog box will appear that will 

allow you to choose the file destination.  

 

6. Select a destination and a file name, then select Save. The file will be saved as a 

tab-delimited text file (.txt) file, which can be easily importable into a 

spreadsheet program, such as Excel. 
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10.7 Displaying Graphs 

SlideBook allows you to view intensity profiles of selected data. You may view line 

intensity or timelapse intensity profiles. 

10.7.1 Viewing a Line Intensity Profile  

SlideBook allows you to generate a line intensity profile using the Image menu. To view 

the intensity profile of a line, do the following: 

 

1. From an open view, use the Ruler tool to draw a line (see Making Distance or 

Velocity Measurements on page 8-30). You may draw this line in two or three 

dimensions. 

 

2. Select Image>Line Intensity. A dialog box similar to the following will appear. 

 

 
 

3. Select the channel that you would like to view from the Channel menu. The line 

intensity profile displays pixel distance on the x axis and intensity on the y axis. 

 

4. To export the data, click Export…. You will be prompted to enter a filename. 

 

5. Navigate to the desired file location, enter a filename, and choose Save. The 

intensity profile data will be saved as a text file that can be opened in programs 

such as Excel. 

 

6. Click Close to close the dialog box. 
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10.7.2 Viewing Timelapse Intensity Profiles 

SlideBook also allows you to view timelapse intensity profiles. There are four methods for 

viewing profiles.  

 

10.7.2.1  Method 1 – Using Masks 

 

1. Select the regions that you would like to profile using masks (see above). 

 

2. If there are multiple objects in the mask for which you would like to plot 

intensity profiles, generate objects by selecting Mask>Define Objects in Mask… 

(see above for a discussion of objects). 

 

3. Select Image>Ratio/Timelapse Data to generate a timelapse intensity graph. 

 

 

 
 

4. Use the radio buttons in the upper left hand corner to either Graph all Regions 

or Graph all Channels.  

 

 Graph all Regions - displays all regions for a single channel. If you have 

multiple fluors, you may select the channel to display from the Channel 

menu. 

 

 Graph all Channels – displays all channels for a single region. If you have 

multiple regions defined, you may select the region to display from the 

Regions menu. 
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5. To export the data, click Export…. You will be prompted to enter a filename. 

 

6. Navigate to the desired file location, enter a filename, and choose Save. The 

intensity profile data will be saved as a text file that can be opened in programs 

such as Excel. 

 

7. Click Close to close the dialog box. 

 

10.7.2.2 Method 2 – Point and Click 

From a main view, select the point selection tool from the tool menu .  Press Ctrl and 

left click on any object in the image. An intensity-time profile will appear. The intensity 

displayed is the average intensity of an area around the point where you clicked of the 

specified radius. You can alter the radius edit field, and choose to export the statistics as a 

tab-delimited text file (.txt). 

 

10.7.2.3  Method 3 – Using ROIs 

If you have drawn regions of interest to monitor timelapse capture, you can create graphs 

of these regions post-capture. 

 

1. Open a View of your data. 

 

2. Select View>Annotation>ROIs to display the ROIs. 

 

3. Select View>Graph…. The following dialog will appear. 

 

 
 

4. Select the type of graph you wish to display and the channels that you wish to 

display and select OK. 

 

The graphs can be explored as described in Creating Graphs to Monitor Regions of Interest 

on page 7-17. 
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NOTE: You can add ROIs by using any of the ROI tools to draw regions. Please see Creating 

ROIs and Graphs to Monitor Regions of Interest  on page 7-15 for more information on 

creating and deleting ROIs. 
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Appendix A:  Smooth Curve Analysis (Kymograph) 

 

Smooth curve analysis allows you to follow time-dependent lateral intensity changes along 

a static object. For example, an action potential moving along a neural spine could be 

displayed as an x vs. t image using smooth curve analysis. You could then extract velocity 

and displacement information from this image.  

 

SlideBook‘s Smooth Curve Analysis is a mathematically rigorous and flexible operation 

with several adjustable parameters. These parameters are defined using the following 

figure. 
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Figure A1: Representation of Smooth Curve Analysis (Kymograph) 

 

The above figure is a schematic of a pixel map of a 2D image. When performing kymograph 

analysis, you first define a curve along a static object that will serve as a ―backbone‖ for 

your analysis. Once this curve is defined, you may perform a smooth curve analysis. 

Smooth curve analysis uses the following parameters: 

 

 Spline parameters – Knot Interval (discrete pixels), the default is set to five. A 

spline is fit between two ―knots‖. Multiple splines are used to fit a given curve. The 

knots are shown in pink in the figure above. 
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 Measurement dimensions  

 

o Radius Perpendicular to Curve (pixel units) – shown as dimension r2 in the 

figure above 

 

o Radius Parallel to Curve (pixel units) – shown as dimension r1 in the figure 

above 

 

o Increment Along Curve (pixel units) – center to center distance between 

rectangular areas used to calculate smooth curve. In the above figure, the 

boxes are drawn every two pixels units along the curve. The resultant 

smooth curve analysis with have half the resolution of the original image. 

 

Once these parameters are defined, the smooth curve algorithm averages the areas at each 

timepoint and creates a new image in 2 dimensions (distance in x vs. time in y).  
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